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L’impression s’interrompt après chaque 11 travaux d’impression lorsque vous utilisez un port LPR

Cet article permet de résoudre un problème où l’impression s’interrompt après chaque 11 travaux d’impression lors de l’impression via un port distant d’imprimante de ligne (LPR) et les ID d’événement 2004 et 4227 sont enregistrés.

Numéro de base de connaissances d’origine : 2003449

Symptômes

L’impression peut s’interrompre après toutes les 11 tâches d’impression lorsque vous imprimez via un port LPR (Line Printer Remote). Lorsque cela se produit, les événements suivants sont enregistrés dans le journal système sur le serveur :

Serveur d’impression Windows Server 2003

Type d'événement : Avertissement
Source d’événement : Moniteur d’impression LPR
ID d’événement : 2004
Description : printer printername <> on host <HOST IP/Name> rejette notre demande. Réessaye jusqu’à ce qu’elle accepte la demande ou que le travail soit annulé par l’utilisateur.

Serveur d’impression Windows Server 2008

Nom du journal : système
Source : Tcpip
ID d’événement : 4227
Catégorie de tâche : None
Niveau : Avertissement
Mots clés : Classique
Utilisateur : N/A
Description : TCP/IP n’a pas pu établir une connexion sortante, car le point de terminaison local sélectionné a été récemment utilisé pour se connecter au même point de terminaison distant. Cette erreur se produit généralement lorsque les connexions sortantes sont ouvertes et fermées à un débit élevé, ce qui entraîne l’utilisation de tous les ports locaux disponibles et le fait de forcer TCP/IP à réutiliser un port local pour une connexion sortante. Pour réduire le risque d’altération des données, la norme TCP/IP nécessite une période minimale pour s’écouler entre les connexions successives d’un point de terminaison local donné à un point de terminaison distant donné.

Cause

Les ports LPR utilisent les ports de source et de destination LPR par défaut (TCP : 721-731, TCP : 515). Cela fait un total de 11 ports. Une fois ces 11 ports utilisés, l’impression s’interrompt jusqu’à ce que les ports expirent et deviennent à nouveau disponibles.

Résolution

Nous vous recommandons d’utiliser des ports TCP\IP standard au lieu des ports LPR. Si vous devez utiliser des ports LPR, vous pouvez toujours utiliser des ports TCP\IP. Toutefois, vous devez les définir en mode LPR. Les articles suivants décrivent plus en détail les ports TCP\IP standard.

Moniteur de port standard pour TCP/IP dans Windows Server 2003

Pour contourner la valeur par défaut RFC de 11 ports pour les ports LPR, procédez comme suit :

  1. Définissez la clé de Registre suivante (REG_DWORD) :

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\LPDSVC\lpr
    Nom de la valeur : UseNonRFCSourcePorts
    Données de valeur : 1
    Type de valeur : binaire
    0 = utilise les ports 721-731 (par défaut)
    1 = utilise n’importe quel port dynamique

  2. Redémarrez le service Spooler pour activer la fonctionnalité.

Plus d’informations

Par défaut, la clé n’est pas présente. Cela limite le nombre de ports LPR à 11. La définition de la valeur de Registre sur 1 permet au LPD d’utiliser n’importe quel port dont le nombre est supérieur à 1024 pour transmettre les travaux.

Collecte de données

Si vous avez besoin de l’aide du support Microsoft, nous vous recommandons de collecter les informations en suivant les étapes mentionnées dans Collecter des informations à l’aide de TSS pour les problèmes liés à l’expérience utilisateur.