Comment Visual Studio facilite le contrôle de version avec Git

S’applique à :ouiVisual Studio nonVisual Studio pour Mac nonVisual Studio Code

Avez-vous déjà souhaité revenir à une version antérieure de votre code ? Vous trouvez-vous manuellement stocker des copies de votre code dans différents emplacements en tant que sauvegarde ? Eh bien, le contrôle de version est la réponse.

Git est le système de contrôle de version moderne le plus couramment utilisé. Avec Git, vous pouvez suivre les modifications de code que vous apportez au fil du temps et vous pouvez rétablir des versions spécifiques. Ainsi, que vous soyez un développeur professionnel ou que vous appreniez à coder, l’expérience Git de Visual Studio peut vous être très utile.

Conseil

Pour en savoir plus sur l’utilisation de Git et GitHub dans Visual Studio, inscrivez-vous à la série d’apprentissage Git.

Démarrer avec GitHub & dans Visual Studio

Le contrôle de version avec Visual Studio est facile avec Git. Nous vous rencontrons là où vous êtes. Vous pouvez travailler à distance avec le fournisseur Git de votre choix, tel que GitHub ou Azure DevOps. Vous pouvez également travailler localement sans fournisseur.

Pour commencer à utiliser Git avec Visual Studio :

  • Si vous avez un dépôt Git hébergé sur un fournisseur Git comme GitHub, clonez le référentiel sur votre ordinateur local.

  • Sinon, créez facilement un dépôt Git et ajoutez votre code. Si vous n’avez pas encore de fournisseur Git, nous vous recommandons de commencer avec GitHub, car l’expérience Git dans Visual Studio est optimisée pour ce fournisseur. GitHub offre un stockage de code cloud gratuit et sécurisé où vous pouvez stocker votre code et y accéder à partir de n’importe quel appareil, n’importe où.

Non seulement vous pouvez ajouter des comptes GitHub et GitHub Enterprise à votre trousseau, mais vous pouvez également les exploiter comme vous le faites avec des comptes Microsoft. Si vous n’avez pas de compte GitHub, suivez ces étapes pour créer un compte GitHub à utiliser avec Visual Studio maintenant.

Si vous débutez avec Git, le https://git-scm.com/ site web est un bon endroit pour commencer.

Boîte de dialogue Créer un référentiel Git dans Visual Studio.

Afficher les fichiers dans Explorateur de solutions

Lorsque vous clonez un référentiel ou ouvrez un référentiel local, Visual Studio bascule vers le contexte Git. Explorateur de solutions charge le dossier à la racine du référentiel Git et analyse l’arborescence des répertoires pour les fichiers visibles tels que CMakeLists.txt ou ceux avec l’extension de .sln fichier. Pour plus d’informations, consultez Afficher les fichiers dans Explorateur de solutions.

Workflow de boucle interne intuitive

Pour votre flux de travail Git quotidien, Visual Studio offre un moyen transparent d’interagir avec Git tout en codeant sans vous éloigner de votre code.

Vous êtes autorisé à utiliser plusieurs tâches et à expérimenter votre code par le biais de branches. Si vous ou votre équipe travaillez sur plusieurs fonctionnalités en même temps, ou si vous souhaitez explorer des idées sans affecter votre code de travail, le branchement est très utile. Le flux de travail Git recommandé utilise une nouvelle branche pour chaque fonctionnalité ou correctif sur lequel vous travaillez. Découvrez comment créer une branche à partir de Visual Studio.

Une fois que vous avez créé une branche et que vous y basculez, vous pouvez commencer à travailler en modifiant les fichiers existants ou en ajoutant de nouveaux, puis en validant votre travail dans le référentiel. Pour en savoir plus sur la création d’une validation dans Visual Studio et pour mieux comprendre les états de fichier dans Git, reportez-vous à la page Créer une validation .

Git est un système de contrôle de version distribué, ce qui signifie que toutes les modifications apportées jusqu’à présent sont des modifications locales uniquement. Pour contribuer à ces modifications à un référentiel distant, vous devez envoyer les validations locales à un référentiel distant.

Si vous travaillez dans une équipe ou si vous utilisez des machines différentes, vous devez également extraire et extraire continuellement de nouvelles modifications sur le référentiel distant. Pour en savoir plus sur la gestion des opérations réseau Git dans Visual Studio, reportez-vous à la page Extraction, extraction, push et synchronisation .

IDE Visual Studio avec le menu Git et l’onglet Modifications Git dans Explorateur de solutions montrant.

Collaboration de gestion des & référentiels

Toutefois, il existe des moments où il est plus judicieux de se concentrer sur votre référentiel Git. Par exemple, vous devrez peut-être obtenir une bonne image de ce que votre équipe a travaillé, ou copier une validation à partir d’une autre branche, ou simplement nettoyer vos validations sortantes. Visual Studio inclut des fonctionnalités puissantes de navigation et de collaboration de référentiel qui éliminent la nécessité d’utiliser d’autres outils.

Pour vous aider à vous concentrer sur votre dépôt Git, Visual Studio dispose d’une fenêtre de référentiel Git , qui est une vue consolidée de tous les détails de votre référentiel, notamment les branches locales et distantes et l’historique de validation. Vous pouvez accéder à cette fenêtre directement à partir de Git ou d’Affichage dans la barre de menus ou à partir de la barre d’état.

IDE Visual Studio qui met en surbrillance le menu Git et l’onglet Modifications Git dans Explorateur de solutions.

Parcourir et gérer des référentiels Git

Pour en savoir plus sur la façon dont vous pouvez utiliser la fenêtre référentiel Git dans Visual Studio pour parcourir et gérer votre référentiel Git, reportez-vous aux pages suivantes :

Gérer les conflits de fusion

Les conflits peuvent se produire lors d’une fusion si deux développeurs modifient les mêmes lignes dans un fichier et Git ne savent pas automatiquement qui est correct. Git arrête la fusion et vous informe que vous êtes dans un état conflictuel. En savoir plus dans la page Résoudre les conflits de fusion .

Personnaliser vos paramètres Git

Pour personnaliser vos paramètres Git au niveau d’un référentiel, ainsi qu’au niveau global :

  1. Accédez à Git>Settings dans la barre de menus ou Tools>Options>Source Control>Git Global Settings
  2. Choisissez les options souhaitées.

Boîte de dialogue Options dans laquelle vous pouvez choisir des paramètres de personnalisation et de personnalisation dans l’IDE Visual Studio.

Commentaires améliorés sur l’expérience &

Nous continuons d’ajouter de nouvelles fonctionnalités pour améliorer l’expérience Git. Pour plus d’informations sur les fonctionnalités récentes et une enquête de commentaires, consultez la prise en charge du dépôt multifacteur dans le billet de blog Visual Studio. Si vous avez une suggestion, faites-nous savoir! Nous apprécions l’occasion de vous engager dans le Developer Community.

Pour essayer des mises à jour plus récentes/préliminaires sur l’expérience Git disponible, téléchargez et installez à partir de la page Aperçu de Visual Studio 2022 . Lisez nos notes de publication de Visual Studio 2022 pour plus d’informations sur chaque version.

Git est maintenant l’expérience de contrôle de version par défaut dans Visual Studio 2019. Depuis la version 16.6, nous avons travaillé sur la création de l’ensemble de fonctionnalités et l’itération sur celle-ci en fonction de vos commentaires. Dans la version 16.8, il est devenu l’expérience de contrôle de version par défaut pour tout le monde.

Notes

Nous continuons également à générer et à itérer sur le jeu de fonctionnalités Git dans Visual Studio 2022. Pour en savoir plus sur une mise à jour de fonctionnalités récente, consultez la prise en charge du dépôt multifacteur dans le billet de blog Visual Studio.

En savoir plus sur Git

Git est le système de contrôle de version moderne le plus couramment utilisé. Par conséquent, que vous soyez un développeur professionnel ou que vous appreniez à coder, Git peut être très utile pour vous. Si vous débutez avec Git, le https://git-scm.com/ site web est un bon endroit pour commencer. Là, vous trouverez des feuilles de triche, un livre en ligne populaire et des vidéos Git Basics.

Démarrer avec Git dans Visual Studio 2019

Nous allons vous guider dans l’utilisation de la nouvelle expérience Git dans Visual Studio, mais si vous souhaitez d’abord effectuer une visite guidée rapide, consultez la vidéo suivante :

Longueur de la vidéo : 5,27 minutes

Il existe trois façons de commencer à utiliser Git avec Visual Studio pour être plus productif :

  • Créez un dépôt Git. Si vous avez déjà du code qui n’est pas associé à Git, vous pouvez commencer par créer un dépôt Git.
  • Clonez un référentiel Git existant. Si le code sur lequel vous souhaitez travailler n’est pas sur votre ordinateur, vous pouvez cloner n’importe quel référentiel distant existant.
  • Ouvrez un référentiel Git existant. Si votre code est déjà sur votre ordinateur, vous pouvez l’ouvrir à l’aide> d’unprojet ou d’une solution de fichierouvert> (ou dossier) et Visual Studio détecte automatiquement s’il dispose d’un référentiel Git initialisé.

Remarque

À compter de Visual Studio 2019 version 16.8, nous incluons une expérience de compte GitHub entièrement intégrée. Vous pouvez maintenant ajouter des comptes GitHub et GitHub Enterprise à votre trousseau. Vous pouvez les ajouter et les exploiter comme vous le faites avec des comptes Microsoft, ce qui signifie que vous aurez un temps plus facile d’accéder à vos ressources GitHub dans Visual Studio. Pour plus d’informations, consultez la page Travailler avec des comptes GitHub dans Visual Studio .

Conseil

Si vous n’avez pas de compte GitHub, vous pouvez commencer par suivre les étapes décrites dans le compte Créer un compte GitHub à utiliser avec la page Visual Studio .

Créer un référentiel Git dans Visual Studio 2019

Si votre code n’est pas associé à Git, vous pouvez commencer par créer un dépôt Git. Pour ce faire, sélectionnezGit Create Git> Repository dans la barre de menus. Ensuite, dans la boîte de dialogue Créer un référentiel Git , entrez vos informations.

Boîte de dialogue Créer un référentiel Git dans Visual Studio.

La boîte de dialogue Créer un dépôt Git facilite l’envoi de votre nouveau référentiel vers GitHub. Par défaut, votre nouveau référentiel est privé, ce qui signifie que vous êtes le seul qui peut y accéder. Si vous décochez la case, votre dépôt sera public, ce qui signifie que toute personne sur GitHub peut l’afficher.

Conseil

Que votre référentiel soit public ou privé, il est préférable d’avoir une sauvegarde à distance de votre code stocké en toute sécurité sur GitHub, même si vous ne travaillez pas avec une équipe. Cela vous permet également de mettre votre code à votre disposition, quel que soit l’ordinateur que vous utilisez.

Vous pouvez choisir de créer un référentiel Git local uniquement à l’aide de l’option Local uniquement . Vous pouvez également lier votre projet local à un référentiel distant vide existant sur Azure DevOps ou tout autre fournisseur Git à l’aide de l’option Remote existante .

Cloner un référentiel Git existant dans Visual Studio 2019

Visual Studio inclut une expérience de clone simple. Si vous connaissez l’URL du référentiel à cloner, vous pouvez coller l’URL dans la section Emplacement du référentiel , puis choisir l’emplacement du disque vers lequel vous souhaitez cloner Visual Studio.

Boîte de dialogue Cloner un référentiel Git dans Visual Studio.

Si vous ne connaissez pas l’URL du dépôt, Visual Studio facilite la navigation, puis clonez votre dépôt GitHub ou Azure DevOps existant.

Ouvrir un référentiel local existant dans Visual Studio 2019

Une fois que vous avez cloné un référentiel ou créé un référentiel, Visual Studio détecte le référentiel Git et l’ajoute à votre liste de référentiels locaux dans le menu Git.

À partir de là, vous pouvez accéder et basculer rapidement entre vos référentiels Git.

Option Référentiels locaux dans le menu Git dans Visual Studio

Afficher les fichiers dans Explorateur de solutions dans Visual Studio 2019

Lorsque vous clonez un référentiel ou ouvrez un référentiel local, Visual Studio vous bascule dans ce contexte Git en enregistrant et en fermant les solutions et projets ouverts précédemment. Explorateur de solutions charge le dossier à la racine du référentiel Git et analyse l’arborescence des répertoires pour les fichiers visibles. Ces fichiers incluent des fichiers tels que CMakeLists.txt ou ceux avec l’extension de fichier .sln.

Visual Studio ajuste son affichage en fonction du fichier que vous chargez dans Explorateur de solutions :

  • Si vous clonez un référentiel qui contient un seul fichier .sln, Explorateur de solutions charge directement cette solution pour vous.
  • Si Explorateur de solutions ne détecte aucun fichier .sln dans votre référentiel, il charge par défaut la vue dossier.
  • Si votre référentiel contient plusieurs fichiers .sln, Explorateur de solutions affiche la liste des vues disponibles pour vous permettre de choisir.

Vous pouvez basculer entre l’affichage actuellement ouvert et la liste des affichages à l’aide du bouton Basculer des vues dans la barre d’outils Explorateur de solutions.

Explorateur de solutions avec le bouton Switch Views sélectionné dans Visual Studio.

Pour plus d’informations, consultez la section Afficher les fichiers dans Explorateur de solutions section Ouvrir un projet à partir d’un didacticiel de dépôt.

Fenêtre Modifications Git dans Visual Studio 2019

Git effectue le suivi des modifications de fichier dans votre dépôt au fur et à mesure que vous travaillez et sépare les fichiers de votre dépôt en trois catégories. Ces modifications sont équivalentes à ce que vous voyez lorsque vous entrez la git status commande dans la ligne de commande :

  • Fichiers non modifiés : ces fichiers n’ont pas changé depuis votre dernière validation.
  • Fichiers modifiés : ces fichiers ont des modifications depuis votre dernière validation, mais vous ne les avez pas encore intermédiaires pour la validation suivante.
  • Fichiers intermédiaires : ces fichiers ont des modifications qui seront ajoutées à la validation suivante.

Comme vous effectuez votre travail, Visual Studio effectue le suivi des modifications de fichier apportées à votre projet dans la section Modifications de la fenêtre Modifications Git .

Fenêtre Modifications Git dans Visual Studio.

Lorsque vous êtes prêt à effectuer des modifications, cliquez sur le bouton (plus) sur chaque fichier que vous souhaitez mettre en scène, ou cliquez avec le + bouton droit sur un fichier, puis sélectionnez Étape. Vous pouvez également mettre en scène tous vos fichiers modifiés en un seul clic à l’aide du bouton tout + (plus) en haut de la section Modifications .

Lorsque vous effectuez une modification, Visual Studio crée une section Modifications intermédiaires . Seules les modifications apportées à la section Modifications intermédiaires sont ajoutées à la validation suivante, que vous pouvez effectuer en sélectionnant Validation intermédiaire. La commande équivalente pour cette action est git commit -m "Your commit message". Les modifications peuvent également être désaténuées en cliquant sur le bouton ( moins). La commande équivalente pour cette action consiste git reset <file_path> à annuler la mise en scène d’un seul fichier ou git reset <directory_path> à désétager tous les fichiers d’un répertoire.

Vous pouvez également choisir de ne pas mettre en scène vos fichiers modifiés en ignorant la zone de préproduction. Dans ce cas, Visual Studio vous permet de valider directement vos modifications sans avoir à les mettre en scène. Entrez simplement votre message de validation, puis sélectionnez Valider tout. La commande équivalente pour cette action est git commit -a.

Visual Studio facilite également la validation et la synchronisation avec un clic à l’aide des raccourcis Validation all et Push etCommit All and Sync . Lorsque vous double-cliquez sur n’importe quel fichier dans les sections Modifications et modifications intermédiaires , vous pouvez voir une comparaison ligne par ligne avec la version non modifiée du fichier.

Comparaison de lignes par ligne des versions de fichiers dans Visual Studio

Conseil

Vous pouvez associer un élément de travail Azure DevOps à une validation à l’aide du caractère « # » si vous êtes connecté au référentiel Azure DevOps. Vous pouvez connecter votre référentiel Azure DevOps via Team Explorer>Gérer les connexions.

Sélectionner une branche existante dans Visual Studio 2019

Visual Studio affiche la branche actuelle dans le sélecteur en haut de la fenêtre Modifications Git .

Branches actuelles que vous pouvez afficher à l’aide du sélecteur en haut du sélecteur De modifications Git dans Visual Studio

La branche actuelle est également disponible dans la barre d’état dans le coin inférieur droit de l’IDE Visual Studio.

Branches actuelles que vous pouvez afficher à l’aide de la barre d’état située en bas à droite dans l’IDE Visual Studio

À partir des deux emplacements, vous pouvez basculer entre les branches existantes.

Créer une branche dans Visual Studio 2019

Vous pouvez également créer une branche. La commande équivalente pour cette action est git checkout -b <branchname>.

La création d’une branche est aussi simple que d’entrer le nom de la branche et de la baser sur une branche existante.

Boîte de dialogue Créer une branche dans Visual Studio

Vous pouvez choisir une branche locale ou distante existante comme base. La case à cocher De la branche De caisse vous bascule automatiquement vers la branche nouvellement créée. La commande équivalente pour cette action est git checkout -b <new-branch><existing-branch>.

Fenêtre Référentiel Git dans Visual Studio 2019

Visual Studio dispose d’une nouvelle fenêtre de référentiel Git , qui est une vue consolidée de tous les détails de votre référentiel, y compris toutes les branches, les distants et les historiques de validation. Vous pouvez accéder à cette fenêtre directement à partir de Git ou d’Affichage dans la barre de menus ou à partir de la barre d’état.

Gérer les branches dans Visual Studio 2019

Lorsque vous sélectionnez Gérer les branches dans le menu Git , vous verrez l’arborescence des branches dans la fenêtre dépôt Git . Dans le volet gauche, vous pouvez utiliser le menu contextuel de clic droit pour extraire les branches, créer de nouvelles branches, fusionner, rebaser, choisir cerise, etc. Lorsque vous cliquez sur la branche, vous pouvez voir un aperçu de son historique de validation dans le volet droit.

Validations entrantes et sortantes dans Visual Studio 2019

Lorsque vous récupérez une branche, la fenêtre Modifications Git a un indicateur sous la liste déroulante de branche, qui affiche le nombre de validations nonpulées de la branche distante. Cet indicateur indique également le nombre de validations locales non vides.

Fenêtre Modifications Git qui affiche l’élément d’interface utilisateur déroulante de l’indicateur dans Visual Studio

L’indicateur fonctionne également comme un lien pour vous amener à l’historique de validation de cette branche dans la fenêtre du référentiel Git . Le haut de l’historique affiche désormais les détails de ces validations entrantes et sortantes. À partir de là, vous pouvez également décider d’extraire ou d’envoyer les validations.

Fenêtre référentiel Git qui affiche l’historique de validation d’une branche dans Visual Studio

Détails de validation dans Visual Studio 2019

Lorsque vous double-cliquez sur une validation, Visual Studio ouvre ses détails dans une fenêtre d’outil distincte. À partir de là, vous pouvez rétablir la validation, réinitialiser la validation, modifier le message de validation ou créer une balise sur la validation. Lorsque vous cliquez sur un fichier modifié dans la validation, Visual Studio ouvre l’affichage Diff côte à côte de la validation et de son parent.

Boîte de dialogue Détails de validation dans Visual Studio

Gérer les conflits de fusion dans Visual Studio 2019

Les conflits peuvent se produire lors d’une fusion si deux développeurs modifient les mêmes lignes dans un fichier et Git ne sait pas automatiquement qui est correct. Git arrête la fusion et vous informe que vous êtes dans un état conflictuel.

Visual Studio facilite l’identification et la résolution d’un conflit de fusion. Tout d’abord, la fenêtre dépôt Git affiche une barre d’informations en or en haut de la fenêtre.

Message « Fusion terminée avec conflits » dans Visual Studio

La fenêtre Modifications Git affiche également un message « Fusionner est en cours avec des conflits », avec les fichiers non fusionnés dans leur section distincte ci-dessous.

Message « Fusionner en cours avec des conflits » dans Visual Studio

Mais si aucun de ces fenêtres n’est ouvert, et que vous accédez au fichier qui a des conflits de fusion, vous n’aurez pas à rechercher le texte suivant :

    <<<<<<< HEAD
    =======
    >>>>>>> main

Au lieu de cela, Visual Studio affiche une barre d’informations en or en haut de la page qui indique que le fichier ouvert a des conflits. Ensuite, vous pouvez cliquer sur le lien pour ouvrir l’Éditeur de fusion.

Capture d’écran du message « Fichier contient des conflits de fusion » dans Visual Studio

Éditeur de fusion dans Visual Studio 2019

L’Éditeur de fusion dans Visual Studio est un outil de fusion triple qui affiche les modifications entrantes, vos modifications actuelles et le résultat de la fusion. Vous pouvez utiliser la barre d’outils au niveau supérieur de l’Éditeur de fusion pour naviguer entre les conflits et les différences fusionnées automatiquement dans le fichier.

Éditeur de fusion dans Visual Studio

Vous pouvez également utiliser les bascules pour afficher/masquer les différences, afficher/masquer les différences de mots et personnaliser la disposition. Il existe des cases à cocher en haut de chaque côté que vous pouvez utiliser pour prendre toutes les modifications d’un côté ou de l’autre. Toutefois, pour prendre des modifications individuelles, vous pouvez cliquer sur les cases à gauche des lignes conflictuelles de chaque côté. Enfin, lorsque vous avez terminé la résolution des conflits, vous pouvez sélectionner le bouton Accepter la fusion dans l’Éditeur de fusion. Vous écrivez ensuite un message de validation et validez les modifications pour terminer la résolution.

Personnaliser vos paramètres Git dans Visual Studio 2019

Pour personnaliser et personnaliser vos paramètres Git au niveau d’un référentiel, ainsi qu’à un niveau global, accédez àParamètresGit> dans la barre de menus ou à Outils>Options>contrôle de code source dans la barre de menus. Choisissez ensuite les options souhaitées.

Boîte de dialogue Options dans laquelle vous pouvez choisir des paramètres de personnalisation et de personnalisation dans l’IDE Visual Studio.

Comment utiliser l’expérience Team Explorer complète dans Visual Studio 2019

La nouvelle expérience Git est le système de contrôle de version par défaut dans Visual Studio 2019 à partir de la version 16.8 . Toutefois, si vous souhaitez le désactiver, vous pouvez. Accédez auxfonctionnalités d’aperçu del’environnement>d’outils>>, puis activez la case à cocher Nouvelle expérience utilisateur Git, qui vous revient à Team Explorer pour Git.

Section Fonctionnalités d’aperçu de la boîte de dialogue Options dans Visual Studio

Voir aussi