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Solución de problemas con la calificación de clientes potenciales para administradores del sistema

Problema 1: permisos insuficientes o error de acceso denegado cuando un usuario intenta calificar a un cliente potencial

La forma de resolver este error depende de los siguientes escenarios de propiedad para los registros de clientes potenciales.

Escenario de propiedad Pasos de resolución
El cliente potencial es propiedad del usuario que intenta calificarlo.
  1. Asegúrese de que tiene un rol de administrador del sistema o permisos equivalentes.
  2. Vaya a Configuración>rol de seguridad.
  3. Abra el rol de seguridad del usuario.
  4. En la pestaña Registros principales , asigne los permisos Crear, Leer, Anexar y Anexar a al rol de seguridad en el nivel de usuario en las siguientes entidades:
    • Cuenta
    • Conducir
    • Contacto
    • Oportunidad
    Rol de seguridad con acceso en el nivel de usuario.

  5. En la pestaña Entidades personalizadas , asigne acceso de lectura a cualquier entidad personalizada.
  6. En la pestaña Personalizaciones , asigne acceso de lectura a Mapa de atributos, Personalizaciones, Entidad y Mapa de entidad.
El cliente potencial que el usuario está intentando calificar está en su unidad de negocio.
  1. Vaya a Configuración>rol de seguridad.
  2. Abra el rol de seguridad del usuario.
  3. Asigne permisos Crear, Leer, Anexar y Anexar a al rol de seguridad del usuario en el nivel de unidad de negocio en las siguientes entidades:
    • Cuenta
    • Conducir
    • Contacto
    • Oportunidad
    Rol de seguridad con acceso en el nivel de unidad de negocio.
  4. Asignar acceso de lectura a cualquier entidad personalizada.
  5. Asignar acceso de lectura a asignación de atributos, personalizaciones, entidad y mapa de entidad.
El cliente potencial que el usuario está intentando calificar está en su organización.
  1. Vaya a Configuración>rol de seguridad.
  2. Abra el rol de seguridad del usuario.
  3. Asigne permisos Crear, Leer, Anexar y Anexar a al rol de seguridad del usuario en el nivel de organización en las siguientes entidades:
    • Cuenta
    • Conducir
    • Contacto
    • Oportunidad
    Rol de seguridad con acceso a nivel de organización.
  4. Asignar acceso de lectura a cualquier entidad personalizada.
  5. Asignar acceso de lectura a asignación de atributos, personalizaciones, entidad y mapa de entidad.

Durante la calificación de un cliente potencial, los registros que (opcionalmente) se crean son: Oportunidad, Contacto y Cuenta. Para obtener más información, consulte Calificar o convertir clientes potenciales.

Si el usuario recibe errores relacionados con privilegios incluso después de asignar los privilegios adecuados como se mencionó anteriormente en esta sección, es posible que falten privilegios en algunas entidades a las que se accede durante la creación de los registros de cuenta, contacto o oportunidad. Por ejemplo, es posible que al usuario le falten privilegios en algunas entidades personalizadas a las que se accede cuando algunos complementos o flujos de trabajo se ejecutan en alguna operación de las entidades de cuenta, contacto o oportunidad.

Para solucionar este problema, siga estos pasos:

  1. Aísle el problema a la creación de un registro de oportunidad, cuenta o contacto: Pida al usuario que intente crear registros individuales de Cuenta, Contacto y Oportunidad y vea si recibe el mismo problema relacionado con privilegios al crear estos registros. Pueden tener problemas de privilegios en uno o varios tipos de registros, por lo que es importante realizar este paso para cada tipo de registro. Por ejemplo, es posible que no tengan los privilegios adecuados en las entidades Cuenta y Contacto.

  2. Identifique si algún complemento o flujo de trabajo registrado al crear la entidad está causando problemas: Después de aislar el problema para crear un registro de entidad determinado, compruebe si algún complemento o flujo de trabajo que se ejecute al crear estos registros de entidad tiene acceso a otras entidades en las que falta privilegios al usuario actual. Para ello, descubra todos los complementos o flujos de trabajo registrados al crear registros de entidad y desactívelos uno por uno para identificar el complemento o flujo de trabajo que provoca el problema. Una vez que identifique el complemento o el flujo de trabajo que provoca el problema, desactívelo para desbloquear el proceso de creación de registros. Para obtener más información sobre cómo identificar todos los flujos de trabajo registrados para una entidad, vea Desactivar proceso de flujo de trabajo personalizado.

Para obtener más información sobre cómo identificar complementos registrados al crear un registro de entidad, vea Desactivar complemento personalizado.

Problema 2: el comando "Calificar clientes potenciales" no está disponible en el registro de clientes potenciales

Causa

El comando Desfasado Calificar para clientes potenciales solo está visible en el formulario Cliente potencial si las entidades Cuenta, Contacto, Cliente potencial y Oportunidad se establecen como editables en La interfaz unificada y las entidades Cuenta, Contacto y Oportunidad están disponibles en Móvil sin conexión.

Solución

Si el comando Calificar para clientes potenciales no está disponible, compruebe lo siguiente:

  • Las entidades Account, Contact, Lead o Opportunity se establecen en solo lectura para dispositivos móviles. Si es así, desactive la casilla Solo lectura en móvil en la personalización de entidades para que la entidad se pueda modificar para la interfaz unificada. Para obtener más información, consulte Solución de problemas con la interfaz unificada.
  • Compruebe si las entidades Account, Contact y Opportunity forman parte del perfil sin conexión móvil. Si no es así, agregue estas entidades al perfil y publique los cambios. Para obtener más información, consulte Habilitación de entidades para la sincronización sin conexión móvil.