הערה
הגישה לדף זה מחייבת הרשאה. באפשרותך לנסות להיכנס או לשנות מדריכי כתובות.
הגישה לדף זה מחייבת הרשאה. באפשרותך לנסות לשנות מדריכי כתובות.
ייתכן שתיתקל בבעיות שונות בעת שימוש בניתוב ישיר כדי לבצע שיחות יוצאות מלקוח Microsoft Teams לבקר גבול הפעלה (SBC). בעיות אלה כוללות את הפעולות הבאות:
- מזהה מתקשר שגוי מוצג לנמען השיחה.
- לא נוצר חיבור ל- SBC.
- משתמשים מסוימים בדייר אינם יכולים לבצע שיחות.
- אף משתמש בדייר אינו יכול לבצע שיחות.
מאמר זה דן בגורמים פוטנציאליים לבעיות אלה ומספק פתרונות שתוכל לנסות.
מזהה מתקשר שגוי מוצג לנמען
בעת שימוש בניתוב ישיר, פרטי מזהה מתקשר המועברים לנמען השיחה From
P-Asserted-Identity
מפורטים בכותרות בהודעה אפשרויות פרוטוקול התחלת הפעלה (SIP).
הכותרת From
העליונה מכילה אחד מהפריטים הבאים:
- מספר הטלפון שהוקצה למתקשר שיזם את השיחה. אם מספר הטלפון של מתקשר חייב להיות מוסתר מהנמען של השיחה, הוא מוחלף ב"אנונימי".
- מספר שירות המוקצה למתקשר באמצעות ה-
CsCallingLineIdentity
cmdlet. - מספר הטלפון של מתקשר המקורי אם השיחה הועברה.
הכותרת P-Asserted-Identity
העליונה מכילה את מספר הטלפון של המשתמש שחויב עבור השיחה. אם Privacy:id
הוגדר, הדבר מציין כי המידע בכותרת צריך להיות מוסתר מהנמען של השיחה.
סיבה
אם המידע בכותרות From
P-Asserted-Identity
ובכותרות אינו תואם, ואם רשת טלפונים ממותגת ציבורית (PSTN) P-Asserted-Identity
From
תעדפת את פרטי הכותרת מעל פרטי הכותרת, מוצג מידע שגוי.
פתרון
כדי לוודא שמזהה המשתמש הנכון מוצג לנמען השיחה, קבע את תצורת SBC P-Asserted-Identity
כך שתסיר את הכותרת מההודעה של אפשרויות SIP או שנה את התוכן שלה.
החיבור ל- SBC לא נוצר
לעתים, שיחות מגיעות ל- SBC אך לא נוצר חיבור. במצב זה, כאשר SBC מקבל הודעת אפשרויות SIP מ- Teams, היא מחזירה הודעת כשל הכוללת קודי שגיאה בטווח של 400 עד 699.
כל אחת מהגורמים הבאים עשויה למנוע חיבור ל- SBC.
סיבה 1
הודעת כשל SIP נוצרת על-ידי התקן טלפוניה אחר באותה רשת כמו SBC.
רזולוציה 1
פתור בעיות במכשיר האחר כדי לתקן את השגיאה. אם אתה זקוק לסיוע, פנה לספק המכשיר.
סיבה 2
ספק PSTN שלך נתקל בבעיה מסוימת ושולח את הודעת הכשל של SIP. סביר להניח שזה המקרה אם קוד שגיאת הכשל הוא SIP 403 או SIP 404.
רזולוציה 2
פנה לספק PSTN שלך לקבלת תמיכה כדי לפתור את הבעיה.
סיבה 3
הבעיה אינה נגרמת על-ידי התקן אחר ברשת או על-ידי ספק PSTN שלך. עם זאת, הגורם לכך אינו ידוע באופן אחר.
רזולוציה 3
פנה לספק SBC לקבלת תמיכה כדי לפתור את הבעיה.
משתמשים מסוימים אינם יכולים לבצע שיחות
אם החיבור בין לקוח Teams ל- SBC פועל כראוי, אך חלק מהמשתמשים אינם יכולים לבצע שיחות, ייתכן שהבעיה נגרמת על-ידי הגדרות שגויות או הקצאה שגויה של משתמשים אלה.
סיבה 1
למשתמשים חסר לוח החיוג בכרטיסיה שיחות ב - Teams.
רזולוציה 1
ודא שלמשתמש יש את הרשיון הנכון (E3 עם Phone System או E5) ואת כל ההגדרות הדרושות. כדי לבדוק את ההגדרות, הפעל את ה- cmdlet Get-CsOnlineUser ב- Teams PowerShell, באופן הבא:
Get-CsOnlineUser -Identity <UserIdParameter> | fl Identity,EnterpriseVoiceEnabled,HostedVoiceMail,OnPremLineURI
יש לציין את כל הערכים הדרושים כמתואר במאמר הפיכת משתמשים לזמינים עבור ניתוב ישיר, קול ודואר קולי.
סיבה 2
אף אחת מהדפוסים במדיניות ניתוב קולי מקוון (OVRP) אינה תואמת למספר שחויג המשתמש.
רזולוציה 2
ודא שהתנאים הבאים מתקיימים:
- קיימת תבנית ב- OVRP התואמת למספר שחויג.
- פרופיל השימוש עבור השיחה תואם לפרופיל המוגדר עבור המשתמש הספציפי.
- השער שצוין עבור SBC זמין. אם הוא אינו זמין, הפוך אותו לזמין או בחר שער אחר שזמין.
סיבה 3
ה- OVRP של המשתמש מכיל תווים לא חוקיים.
רזולוציה 3
ניתן להוסיף תווים בלתי נראים לא חוקיים ל- OVRP כאשר אתה מדביק בו מידע מ- Microsoft Word או ממשתמשים אחרים של WYSIWYG. למרות שהתווים אינם מוצגים, הם נחשבים בעת החלטה על הנתיב שהשיחה אמורה לקבל.
כדי לפתור את הבעיה, הסר את המדיניות ולאחר מכן צור אותה מחדש על-ידי שכתוב ידני או העתקתה מעורך שאינו WYSIWYG, כגון פנקס רשימות.
אף משתמש אינו יכול לבצע שיחות
אם אף אחד מהמשתמשים אינו יכול לבצע שיחות, ככל הנראה השיחות אינן מגיעות ל- SBC. בדוק את אחת הסיבות הבאות.
סיבה 1
ל- Teams יש שער לא זמין.
רזולוציה 1
השתמש במרכז הניהול של Microsoft Teams כדי לוודא שהשער שנמצא בשימוש על-ידי Teams זמין וזמין.
באפשרותך גם להשתמש ב- PowerShell של Teams כדי לבדוק ולעדכן את השער, לפי הצורך.
כדי לבדוק את מצב השער, הפעל את ה- cmdlet Get-CsOnlinePSTNGateway . על הפלט להראות שערך הפרמטר Enabled
מוגדר ל- True
. בדוגמה הבאה, הפרמטר Enabled
מוגדר True
עבור השער sbc1.contoso.com
אך לא עבור sbc2.contoso.com
השער.
Get-CsOnlinePSTNGateway | fl Identity,Fqdn,SipSignalingPort,MaxConcurrentSessions,Enabled
כדי לוודא שהשער sbc2.contoso.com
זמין ל- Teams, הפעל את ה- cmdlet Set-CsOnlinePSTNGateway כדי להגדיר את הפרמטר Enabled
ל- True
.
Set-CsOnlinePSTNGateway -Identity "sbc2.contoso.com" -Enabled $true
כדי לבדוק אם השער sbc2.contoso.com
זמין כעת, הפעל שוב את ה- Get-CsOnlinePSTNGateway
cmdlet:
Get-CsOnlinePSTNGateway -Identity "sbc2.contoso.com" | fl Identity,Fqdn,SipSignalingPort,MaxConcurrentSessions,Enabled
לקבלת מידע נוסף, ראה חיבור SBC שלך לניתוב ישיר.
סיבה 2
השער אינו מגיב להודעות של אפשרויות SIP מאחר שהתקן מסוים ברשת, כגון חומת אש, חוסם את ההודעות.
רזולוציה 2
ודא כי כתובות ה- IP ו- FQDN של איתות SIP מותרות בכל התקני הרשת שמחברים את ה- SBC לאינטרנט. כתובות ה- IP שיש מותרות מפורטות תחת איתות SIP: שמות FQDN.
מידע נוסף
עדיין זקוק לעזרה? עבור אל קהילת Microsoft.