Salesforce CRM users unable to see data in Copilot for Sales
This article helps you troubleshoot and resolve an issue where users can't see data in Microsoft Copilot for Sales.
Note
Microsoft Sales Copilot is rebranded as Microsoft Copilot for Sales in January 2024. The screenshots in this article will be updated with the new name soon.
Who is affected?
Requirement type | Description |
---|---|
Client app | Copilot for Sales Outlook add-in |
Platform | Web and desktop clients |
OS | Windows and Mac |
Deployment | User managed and admin managed |
CRM | Salesforce |
Users | Users who don't have permission to view fields added in Copilot for Sales forms |
Symptoms
When a user opens Copilot for Sales in Outlook, the following error message is displayed:
Something went wrong
Cause
The field-level security for the field is set to invisible in Salesforce CRM. As a result, Copilot for Sales can't reference that field as expected in the configuration.
Resolution 1: Fix field-level security in Salesforce CRM
Sign in to Salesforce CRM as an administrator and open Setup.
Open Object Manager.
Select the entity that is throwing the error.
In the navigation bar on the left, select Fields & Relationships.
Select the field that is throwing the error.
Select Set Field-Level Security at the top.
Ensure that Visible is set for the right profiles.
Validate the same for custom permissions sets.
For more information regarding field-level security in Salesforce CRM, see Field-Level Security.
Resolution 2: Change settings in Copilot for Sales to hide fields or remove edit capabilities
Change the admin settings from the Copilot for Sales admin settings in Microsoft Teams to hide the fields or remove editing capabilities.
Sign in to Microsoft Teams with your administrator credentials.
In the navigation bar on the left, select Copilot for Sales.
On the Settings tab, select Forms.
Select the entity for which you're seeing the error.
Under Manage fields, perform one of the following actions:
Select Publish to save your changes.
Resolution 3: Refresh the data from CRM
If you don't know which field is causing the issue, you can refresh the data from CRM. This action will sync the latest changes from CRM to Copilot for Sales and remove any fields that were removed from CRM but are still available in Copilot for Sales. After you refresh the data, you must close and reopen the Copilot for Sales add-in in Outlook.
More information
If your issue is still unresolved, go to the Copilot for Sales - Microsoft Community Hub to engage with our experts.
Third-party information disclaimer
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.