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Publish agent to Microsoft admin center

Important

You need to be part of the Frontier preview program to get early access to Microsoft Agent 365. Frontier connects you directly with Microsoft’s latest AI innovations. Frontier previews are subject to the existing preview terms of your customer agreements. As these features are still in development, their availability and capabilities may change over time.

Use the a365 publish command to package your agent, and then upload the package to the Microsoft 365 admin center. After publishing, you can create agent instances within your organization and govern the agent.

Prerequisites

Before you begin, make sure you have the following items.

Required accounts and permissions

  • Microsoft 365 tenant with one of the following roles (required for the Admin Center upload step):

    • Global Administrator
    • Agent ID Administrator

Required tools

Required setup steps

Before publishing, complete these steps:

  1. Create agent blueprint - Follow the setup step to create your agent blueprint.
  2. Test agent locally - Verify your agent works correctly by using Agents Playground (see Test agents locally).
  3. Prepare configuration files - Ensure a365.config.json and a365.generated.config.json are up to date.

Publish command

Run the a365 publish command:

a365 publish

Note

Running a365 publish -h shows all the options that this command supports.

What this command does:

  1. Update manifest - Updates manifest.json with your agent blueprint ID
  2. Create package - Packages manifest.json and icons into manifest.zip
  3. Print instructions - Displays step-by-step instructions for uploading via the Microsoft 365 admin center

Upload to admin center

After a365 publish finishes, follow the printed instructions to upload your agent:

  1. Go to the Microsoft 365 admin center.
  2. Navigate to Agents > All agents.
  3. Select Upload custom agent.
  4. Upload the manifest.zip file from the manifest folder in your project.

For more information, see Upload agents to the Microsoft 365 admin center.

Verify successful publishing

Use the following checklist to verify your agent published successfully:

CLI publish succeeds
manifest folder created with manifest.json and manifest.zip
Agent appears in Microsoft admin center

CLI output

You see these output messages when the publish command succeeds:

Manifest updated successfully
manifest.zip created successfully
✅ Step-by-step upload instructions printed

If the command fails, review the error messages and ensure that you completed blueprint setup.

Possible errors:

Error Step to resolve
Agent blueprint ID not found Run a365 setup to complete blueprint setup.
Permissions missing Re-run setup with the a365 setup permissions command.

Follow these steps when publishing fails.

Manifest files

You can test the following files in the manifest folder by using the Test-Path PowerShell command.

# Check manifest folder and contents exists
Test-Path <deploymentProjectPath>/manifest/
Test-Path <deploymentProjectPath>/manifest/manifest.json
Test-Path <deploymentProjectPath>/manifest/manifest.zip
# All should return: True

Note

If you don't see these files, try running the a365 publish command again.

Agent appears in admin center

Note

After uploading, it can take 5-10 minutes for your agent to appear in admin center and Teams. This delay is normal.

Confirm that the agent is present by using these steps:

  1. Go to Microsoft 365 admin center.
  2. Navigate to Agents > All agents.
  3. Your agent appears in the list.

The following table shows what details you can find:

Field What to Check
Name Your agent name (from manifest.json)
Version Version number (for example, 1.0.0)
Publisher Your organization name
Availability Available/All Users

See also

Next steps

After you publish your agent, create an instance so you can configure and use it in your tenant.

Troubleshooting

Common problems when publishing agents to the Microsoft 365 admin center.

Tip

Agent 365 Troubleshooting Guide contains high-level troubleshooting recommendations, best practices, and links to troubleshooting content for each part of the Agent 365 development lifecycle.

Publish command fails

Symptoms:

  • Error during a365 publish
  • manifest.zip isn't created

Root causes:

  • Setup isn't complete
  • Manifest validation errors
  • Insufficient permissions

Solution:

  1. Verify that the setup is complete.

    a365 config display -g
    # Check for: agentBlueprintId
    
  2. Run the publish command and follow the prompts.

Upload fails in admin center

Symptoms:

  • Error when uploading manifest.zip in the Microsoft 365 admin center
  • Agent doesn't appear after upload

Root causes:

  • Insufficient permissions in the admin center
  • Invalid or outdated manifest.zip

Solution:

  1. Ensure you have the Global Administrator or Agent ID Administrator role.
  2. Run a365 publish again to generate a fresh manifest.zip.
  3. Try uploading again following the upload steps.

For more help, see Upload agents to the Microsoft 365 admin center.