A tartalomindex állapota továbbra is elakadt egy Exchange Server 2010-adatbázis bejárása során

Eredeti tudásbáziscikk száma: 2820817

Jelenségek

Egy Microsoft Exchange Server 2010-adatbázisban a tartalomindex állapota "bejárásként" jelenik meg, és úgy tűnik, hogy soha nem éri el a "kifogástalan" állapotot. Emellett annak ellenére, hogy a Dokumentumok száma sikeresen indexelt teljesítményszámláló az indexelt dokumentumok számának fokozatos növekedését mutatja, a Postaládák száma bejárásig számláló értéke nem a várt módon csökken.

Ebben az esetben a rendszer a következő eseményeket naplózza az alkalmazásnaplóban:

Time:
ID: 102
Level: Error
Source: MSExchange Search Indexer
Machine: Mailboxserver.contoso.com
Message: Exchange Search Indexer has failed to crawl the mailbox (8832ee80-47b8-4b0e-a98f-c4a239794707) in database (Database1) due to error: (Microsoft.Exchange.Search.MailboxCrawlFailedException: Failed to logon to mailbox). This mailbox will be retried later.
Time:
ID: 5617
Level: Error
Source: CI Troubleshooter
Machine: Mailboxserver.contoso.com
Message: CI troubleshooter exchange search service restart attempt 81.

A probléma oka

Ez a probléma akkor fordul elő, ha a System Center Operations Manager a Toubleshoot-CI.ps1 szkriptet futtatja. Emiatt az Exchange-Search szolgáltatás újraindul az indexelési folyamat befejezése előtt.

Megoldás

A probléma megoldásához akadályozza meg, hogy a System Center Operations Manager-kiszolgáló az alábbi módon futtassa a Troubleshoot-CI.ps1 szkriptet:

  1. Nyissa meg a System Center Operations Managert.
  2. Kattintson a Felügyeleti csomag objektumfigyelője elemre>.
  3. A Keresés mezőbe írja be a hibaelhárítás kifejezést, majd kattintson a Keresés gombra.
  4. Keresse meg Troubleshoot-CI.ps1 szkriptnek megfelelő elemet, kattintson rá a jobb gombbal, majd kattintson a Tulajdonságok parancsra.
  5. A Felülbírálás lapon kattintson a Felülbírálás gombra.
  6. Jelölje be az Engedélyezve jelölőnégyzetet, állítsa a Felülbírálás értéke beállítást False (Hamis) értékre, majd kattintson az OK gombra.

További információ

A System Center Operations Manager általában kétóránként futtatja a Troubleshoot-CI.ps1 szkriptet. Ha azonban a Troubleshoot-CI.ps1 szkript az alábbi tünetek valamelyikét észleli, az elindítja az Exchange keresési szolgáltatás újraindítását:

  • Holtpont: Az Exchange Search holtpontjai az MSSearch szálaira való várakozás során.
  • Sérülés: Egy vagy több keresési index sérült.
  • Istálló: Egy holtponthoz hasonlít, amelyben az indexek nincsenek frissítve.
  • Teendőlista: A keresési katalógus vissza van jelölve, így az ütemezett indexkeresések nem a várt módon futnak.

Íme egy példa egy eseményre, amely a Troubleshoot-CI.ps1 szkript futtatásakor van naplózva:

Time:
ID: 5611
Level: Error
Source: CI Troubleshooter
Machine: Mailboxserver.contoso.com
Message: Indexing backlog reached a critical limit of 48 hours or the number of items in the retry queue is greater than 10000 for one or more databases: Database1 (0, 12572, 0)Database1 (0, 31859, 0)

Ha az adatbázisok nagy méretű postaládákkal vagy nagy elemszámú postaládákkal rendelkeznek, az indexelési folyamat általában két óránál hosszabb időt vesz igénybe. Amikor az Exchange keresési szolgáltatás újraindul, a postaládák visszakerülnek a listára újraindexelés céljából. Ebben az esetben előfordulhat, hogy a bejárási folyamat soha nem kap lehetőséget a befejezésre.