Megosztás a következőn keresztül:


Hiba történt a postaládák helyszíni környezetből Exchange Online hibrid telepítésben való áthelyezésekor: A felhasználó áthelyezése már folyamatban van

Eredeti tudásbáziscikk száma: 4502865

Jelenségek

Tegyük fel, hogy a Microsoft 365-ben hibrid Exchange Server és Exchange Online üzemel. Amikor postaládákat próbál áthelyezni a helyszínről Exchange Online, a következőhöz hasonló hibaüzenet jelenik meg:

Hiba: UserAlreadyBeingMigratedException: A "Name" felhasználónak már van függőben lévő kérése. Távolítsa el a meglévő kérést, és folytassa az aktuális köteget, vagy indítson el egy új köteget ehhez a felhasználóhoz. --> A(z) "Name" postaláda már át lett helyezve a "Cloud Database Name" (Felhőadatbázis neve) adatbázisba.

Hiba: MigrationPermanentException: Az előkészítési áthelyezés nem hozható létre, mert a "Name" felhasználó áthelyezése már folyamatban van. –> Az előkészítési áthelyezés nem hozható létre, mert a "Név" felhasználó áthelyezése már folyamatban van.

A probléma oka

Ez a probléma akkor fordulhat elő, ha az alábbi feltételek valamelyike teljesül:

  • Már rendelkezik áthelyezési kérelemmel (aktív vagy árva) Exchange Online az adott felhasználóhoz. Ebben a forgatókönyvben a hibaüzenet valószínűleg a következő:

    A"Név" postaláda már át lett helyezve a "Cloud Database Name"< (Felhőadatbázis neve>) helyre.

  • Már rendelkezik áthelyezési kérelemmel (aktív vagy árva) a helyszíni Exchange Server az adott felhasználóhoz. Ebben a forgatókönyvben a hibaüzenet valószínűleg a következő:

    Az előkészítési áthelyezés nem hozható létre, mert a"Név" felhasználó áthelyezése már folyamatban van.

Megoldás

A probléma megoldásához kövesse az alábbi lépéseket.

1. lépés: Az érintett felhasználó áthelyezési kérésének azonosítása

Megjegyzés:

Ha nem biztos a felhasználó identitásában, az összes áthelyezési kérést a parancs futtatásával lefuttatva Get-MoveRequest megkeresheti az érintett felhasználót.

2. lépés: Az áthelyezési kérelem vagy áthelyezési hivatkozások ellenőrzése és törlése

A helyszíni vagy a Exchange Online található felhasználói áthelyezési kérelem állapotát is ellenőrizheti. Az állapot valószínűleg Befejezve vagy Sikertelen állapotban lesz. El kell távolítania ezt az áthelyezési kérelmet, hogy létre tudjon hozni egy új áthelyezési kérelmet a felhasználó Exchange Online való áttelepítéséhez.

Ha a törölni kívánt áthelyezési kérelem nincs migrálási köteghez vagy migrálási felhasználóhoz társítva, futtathatja Remove-MoveRequest közvetlenül a PowerShellben. Ellenkező esetben azt javasoljuk, hogy távolítsa el a megfelelő áttelepítési köteget vagy a megfelelő áttelepítési felhasználót a kötegből. Ezzel az áthelyezési kérelem eltávolításával is foglalkoznia kell.

Ha nem talál áthelyezési kérelmet a felhasználóhoz a helyszíni vagy Exchange Online szervezetekben, és továbbra is hibaüzenet jelenik meg (a felhasználó áthelyezése folyamatban van), manuálisan kell törölnie az adott felhasználó áthelyezési hivatkozásait a helyi Active Directory tárolóból.

Ehhez hajtsa végre a következő lépéseket:

Figyelmeztetés

Ha az Attribute Szerkesztő, az ADSI Edit beépülő modult, az LDP segédprogramot vagy bármely más LDAP 3-es verziójú ügyfelet használja, és helytelenül módosítja az Active Directory-objektumok attribútumait, komoly problémákat okozhat. A Microsoft nem tudja garantálni, hogy az Active Directory-objektumattribútumok helytelen módosításakor felmerülő problémák megoldhatók. Ezeket az attribútumokat saját felelősségére módosíthatja. Az attribútumok eltávolítása vagy módosítása előtt mindig jegyezze fel az értéket, hogy visszavonhassa a módosításokat.

  1. Nyissa meg a Active Directory - felhasználók és számítógépek a tartományvezérlő (DC) kiszolgálón.

  2. Keresse meg az érintett felhasználót, kattintson a Nézet gombra, jelölje be a Speciális szolgáltatások jelölőnégyzetet, majd nyissa meg az Attribútum Szerkesztő lapot.

  3. Keresse meg az msExchMailboxMove attribútumokat, és ellenőrizze, hogy be van-e állítva érték az adott felhasználóhoz.

    Az msExchMailboxMoveRemoteHostName értéket például az <tenant.onmicrosoft.com> adja meg, ha legalább egy kísérlet történt a felhasználó Exchange Online való áthelyezésére.

    Ha az áthelyezési kérelem sikeresen el lett távolítva a Exchange Online -ból (vagyis nem találja a powershell Exchange Online-parancs futtatásávalGet-MoveRequest), de az msExchMailboxMoveRemoteHostName attribútum be van állítva, ez arra utal, hogy az áthelyezési hivatkozás nem lett megfelelően törölve helyi Active Directory. Ebben a forgatókönyvben árva áthelyezési kérelemmel rendelkezik az adott felhasználóhoz.

    Egy elsődleges vagy archivált postaláda árva helyi áthelyezési kérésére egy másik példa az lehet, ha nincs a helyszínen áthelyezési kérelem, de vannak olyan attribútumok, mint például a következők:

    • msExchMailboxMoveSourceMDBLink
    • msExchMailboxMoveTargetMDBLink
    • msExchMailboxMoveSourceArchiveMDBLink
    • msExchMailboxMoveTargetArchiveMDBLink
  4. Törölje manuálisan az értéket az Active Directoryban, majd hozzon létre egy másik áthelyezési kérelmet Exchange Online az adott felhasználóhoz.