Megosztás a következőn keresztül:


PRB: Hibaüzenet: 0x80004005: Általános hiba: A beállításkulcs nem nyitható meg

Jelenségek

Amikor egy Access-adatbázishoz csatlakozó lapot ér el, a következő hibaüzenet jelenhet meg a böngészőben:

Microsoft OLE DB Provider for ODBC Drivers (0x80004005)[Microsoft][ODBC Microsoft Access Driver]General error Unable to open registry key 'Temporary (volatile) Jet DSN for process 0x614 Thread 0x6c0 DBC 0x21dd07c Jet'.
(FileName), (LineNumber)

A probléma oka

A lap eléréséhez használt fiók nem rendelkezik hozzáféréssel a HKEY_LOCAL_MACHINE\SOFTWARE\ODBC beállításkulcshoz.

Megoldás

Fontos

Az alábbi bekezdés, módszer, illetve feladat a beállításjegyzék módosítását magában foglaló lépéseket taglalja. A beállításjegyzék helytelen módosítása azonban komoly problémákat okozhat, ezért ügyeljen az utasítások pontos betartására. A módosítás előtt készítsen biztonsági másolatot a beállításjegyzékről, hogy szükség esetén visszaállíthassa azt. A beállításjegyzék biztonsági mentésével és visszaállításával kapcsolatos további információkért kattintson a következő cikkszámra a microsoftos tudásbázisban található cikk megtekintéséhez: 322756 A beállításjegyzék biztonsági mentése és visszaállítása a Windowsban

  1. Indítsa el a Beállításjegyzék-Szerkesztő (Regedt32.exe).

  2. Válassza ki a következő kulcsot a beállításjegyzékben:

    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC

  3. A Biztonság menüben kattintson az Engedélyek elemre.

  4. Írja be a weblapot elérő fiókhoz szükséges engedélyeket.

  5. Lépjen ki a Beállításszerkesztő segédprogramból.

Állapot

A jelenség szándékos.