A Windows PowerShell rendszerkövetelményei

Ez a cikk a Windows PowerShell 3.0, Windows PowerShell 4.0, Windows PowerShell 5.0 és Windows PowerShell 5.1 rendszerkövetelményei. Emellett speciális funkciók, például Windows PowerShell integrált szkriptelési környezet (ISE), a Common Information Model (CIM) parancsai és munkafolyamatok.

Windows 8.1 és Windows Server 2012 R2 tartalmazza az összes szükséges programot. Ez a cikk a Windows korábbi kiadásainak felhasználói számára készült.

Operációsrendszer-követelmények

Windows PowerShell 5.1

Windows PowerShell 5.1 a Windows következő verzióiban fut. Az Windows PowerShell 5.1 futtatásához telepítse az Windows Management Framework 5.1-et. További információ: A WMF 5.1 telepítése és konfigurálása.

Windows-verzió Rendszerkövetelmények
Windows Server 2022 Alapértelmezés szerint telepítve
Windows Server 2019 Alapértelmezés szerint telepítve
Windows Server 2016 Alapértelmezés szerint telepítve
Windows Server 2012 R2 A Windows Management Framework 5.1 telepítése
Windows Server 2012 A Windows Management Framework 5.1 telepítése
Windows Server 2008 R2 service Pack 1 A Windows Management Framework 5.1 telepítése
Windows 11 Alapértelmezés szerint telepítve
Windows 10 1607-es vagy újabb verzió Alapértelmezés szerint telepítve
Windows 10 1507-es, 1511-es verzió A Windows Management Framework 5.1 telepítése
Windows 8.1 A Windows Management Framework 5.1 telepítése
Windows 7 Service Pack 1 csomaggal A Windows Management Framework 5.1 telepítése

Windows PowerShell 5.0

Windows PowerShell 5.0 a Windows következő verzióiban fut. Az Windows PowerShell 5.0 futtatásához telepítse az Windows Management Framework 5.1-et. További információ: A WMF 5.1 telepítése és konfigurálása. Windows Management Framework 5.1 felülírja az 5.0 Windows Management Framework.

Windows-verzió Rendszerkövetelmények
Windows Server 2022 Alapértelmezés szerint a magasabb verzió van telepítve
Windows Server 2019 Alapértelmezés szerint a magasabb verzió van telepítve
Windows Server 2016 Alapértelmezés szerint a magasabb verzió van telepítve
Windows Server 2012 R2 A Windows Management Framework 5.1 telepítése
Windows Server 2012 A Windows Management Framework 5.1 telepítése
Windows Server 2008 R2 service Pack 1 A Windows Management Framework 5.1 telepítése
Windows 11 Alapértelmezés szerint a magasabb verzió van telepítve
Windows 10 1607-es vagy újabb verzió Alapértelmezés szerint a magasabb verzió van telepítve
Windows 10 1507-es, 1511-es verzió Alapértelmezés szerint telepítve
Windows 8.1 A Windows Management Framework 5.1 telepítése
Windows 7 Service Pack 1 csomaggal A Windows Management Framework 5.1 telepítése

Windows PowerShell 4.0

A Windows PowerShell 4.0 a Windows alábbi verzióiban fut. A Windows PowerShell 4.0 futtatásához telepítse az operációs rendszerhez tartozó Windows Management Framework megadott verzióját.

Windows-verzió Rendszerkövetelmények
Windows 8.1 Alapértelmezés szerint telepítve
Windows Server 2012 R2 Alapértelmezés szerint telepítve
Windows 7 Service Pack 1 csomaggal A Windows Management Framework 4.0 telepítése
Windows Server 2008 R2 service Pack 1 A Windows Management Framework 4.0 telepítése

Windows PowerShell 3.0

Windows PowerShell 3.0 a Windows alábbi verzióiban fut. A Windows PowerShell 3.0 futtatásához telepítse az operációs rendszerhez tartozó Windows Management Framework megadott verzióját.

Windows-verzió Rendszerkövetelmények
Windows 8 Alapértelmezés szerint telepítve
Windows Server 2012 Alapértelmezés szerint telepítve
Windows 7 Service Pack 1 csomaggal A Windows Management Framework 3.0 telepítése
Windows Server 2008 R2 service Pack 1 A Windows Management Framework 3.0 telepítése
Windows Server 2008 Service Pack 2 A Windows Management Framework 3.0 telepítése

A Microsoft .NET-keretrendszer követelményei

Az alábbi táblázat a Windows PowerShell .NET-keretrendszer követelményeit mutatja be.

Verzió .NET-követelmény
Windows PowerShell 5.1 A Microsoft .NET-keretrendszer 4.5 teljes telepítését igényli. A Windows 8.1 és a Windows Server 2012 R2 alapértelmezés szerint tartalmazza a Microsoft .NET-keretrendszer 4.5-ös verziót.
Windows PowerShell 5.0 A Microsoft .NET-keretrendszer 4.5 teljes telepítését igényli. A Windows 8.1 és a Windows Server 2012 R2 alapértelmezés szerint tartalmazza a Microsoft .NET-keretrendszer 4.5-ös verziót.
Windows PowerShell 4.0 A Microsoft .NET-keretrendszer 4.5 teljes telepítését igényli. A Windows 8.1 és a Windows Server 2012 R2 alapértelmezés szerint tartalmazza a Microsoft .NET-keretrendszer 4.5-ös verziót.
Windows PowerShell 3.0 A Microsoft .NET-keretrendszer 4 teljes telepítését igényli. Windows 8 és Windows Server 2012 alapértelmezés szerint tartalmazza a Microsoft .NET-keretrendszer 4.5-ös verziót, amely megfelel ennek a követelménynek.

Az alábbi hivatkozások segítségével letöltheti a Microsoft .NET-keretrendszer a Microsoft letöltőközpontból.

Verzió Hivatkozás
.NET-keretrendszer 4.5 (dotNetFx45_Full_setup.exe) Microsoft .NET-keretrendszer 4.5
.NET-keretrendszer 4 (dotNetFx40_Full_setup.exe) Microsoft .NET-keretrendszer 4 (webtelepítő)

Windows Management Framework 4.0

Windows PowerShell 5.0-s verzióhoz a Windows Management Framework 4.0-s verziót elő kell telepíteni Windows Server 2008 R2 SP1 és Windows 7 SP1 rendszeren.

WS-Management 3.0

Windows PowerShell 3.0-s és Windows PowerShell 4.0-s WS-Management 3.0 szükséges, amely támogatja a WinRM szolgáltatást és a WSMan protokollt. Ez a program a Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows Management Framework 4.0 és Windows Management Framework 3.0-s.

Windows Management Instrumentation 3.0

Windows PowerShell 3.0-s és Windows PowerShell 4.0-s verzióhoz Windows Management Instrumentation 3.0 (WMI) szükséges. Ez a program a Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows Management Framework 4.0 és Windows Management Framework 3.0-s. Ha a program nincs telepítve a számítógépre, a WMI-t igénylő szolgáltatások, például a CIM-parancsok nem futnak.

Common Language Runtime 4.0

Windows PowerShell 3.0, Windows PowerShell 4.0 és Windows PowerShell 5.0 a Common Language Runtime (CLR) 4.0-s verzióra van lefordítva.

A grafikus felhasználói felület követelményei

Windows PowerShell egy konzolalapú alkalmazás, amelyhez nincs szükség grafikus felhasználói felületre. Jól használható olyan számítógépekhez, amelyek nem rendelkeznek képernyőkkel vagy monitorokkal, vagy felhasználói felülettel, például az Windows Server 2012 R2 vagy Windows Server 2012 Server Core telepítési lehetőségeihez.

Egyes elemekhez grafikus felhasználói felület szükséges. Részletekért tekintse meg az egyes elemek súgócikkét.

Windows PowerShell motorra vonatkozó követelmények

A Windows PowerShell 4.0 úgy lett kialakítva, hogy visszamenőlegesen kompatibilis legyen a Windows PowerShell 3.0-s és Windows PowerShell 2.0-s verzióval. A Windows PowerShell 2.0-hoz és Windows PowerShell 3.0-hoz írt parancsmagok, szolgáltatók, beépülő modulok, modulok és szkriptek változatlanul futnak a Windows PowerShell 4.0-ban.

A Microsoft .NET-keretrendszer 4 futásidejű aktiválási szabályzatának változása miatt azonban Windows PowerShell Windows PowerShell 2.0-s verzióhoz írt és a Common Language Runtime (CLR) 2.0-val lefordított programok nem futtathatók módosítás nélkül a Windows PowerShell 3.0, amely a CLR 4.0-val van lefordítva.

A Windows PowerShell 2.0-s motor minimális követelménye a Microsoft .NET-keretrendszer 2.0.50727. Ezt a követelményt a Microsoft .NET-keretrendszer 3.5 Service Pack 1 teljesíti. Ezt a követelményt a Microsoft .NET-keretrendszer 4-es és újabb verziói nem teljesítik a Microsoft .NET-keretrendszer.

A Windows PowerShell 2.0 motor hozzáadásával vagy telepítésével, valamint a Microsoft .NET-keretrendszer szükséges verzióinak hozzáadásával vagy telepítésével kapcsolatos információkért lásd: A Windows PowerShell 2.0 motor telepítése. A Windows PowerShell 2.0-s motor elindításával kapcsolatos információkért lásd: A Windows PowerShell 2.0-s motor indítása.

Windows előtelepítési környezet

Windows PowerShell 2.0, Windows PowerShell 3.0 és Windows PowerShell 4.0 a Windows előtelepítési környezetben (Windows PE) fut. A következő parancsmagok azonban nem támogatottak.

A WinRM szolgáltatás nincs jelen a Windows PE környezetben.

Lásd még

Windows PowerShell telepítése

A Windows PowerShell indítása

Windows Management Framework