Kód fejlesztése Visual Studio projektek vagy megoldások nélkül

Szinte bármilyen címtáralapú projekt kódját megnyithatja Visual Studio megoldás vagy projektfájl nélkül. Ez azt jelenti, hogy például klónozhat egy repozitóriumot a GitHubon, közvetlenül a Visual Studióban nyithatja meg, és anélkül kezdheti el a fejlesztést, hogy megoldást vagy projektet kellene létrehoznia. Szükség esetén megadhatja az egyéni buildelési feladatokat, és egyszerű JSON-fájlokon keresztül indíthatja el a paramétereket.

Miután megnyitotta a kódfájlokat Visual Studio, Megoldáskezelő megjeleníti a mappában lévő összes fájlt. A szerkesztés megkezdéséhez kattintson bármelyik fájlra. A háttérben Visual Studio elkezdi indexelni a fájlokat az IntelliSense, a navigáció és az újrabontási funkciók engedélyezéséhez. Fájlok szerkesztése, létrehozása, áthelyezése vagy törlése során Visual Studio nyomon követi a módosításokat, és folyamatosan frissíti az IntelliSense indexét. A kód szintaxisszínezéssel jelenik meg, és sok esetben alapszintű IntelliSense-utasításkiegészítést is tartalmaz.

Note

Ha a VS Code-ra vonatkozó információkat keres, látogasson el a Getting Visual Studio Code lapra.

Bármely kód megnyitása

A kódot a következő módokon nyithatja meg Visual Studio:

  • A Visual Studio menüsávon válassza a File>Open>Folder lehetőséget, majd keresse meg a kód helyét.

  • A kódot tartalmazó mappa helyi (jobb gombos) menüjében válassza az Open in Visual Studio parancsot.

  • Válassza a Mappa megnyitása hivatkozást a kezdőablakban.

    Important

    Nem minden kód nyitható meg a Open Mappa hivatkozással a Visual Studio kezdőablakból. Ha például a kódfájlt egy megoldás részeként – más szóval egy .sln fájlban – mentette, a kód megnyitásához az itt felsorolt lehetőségek egyikét kell használnia.

  • Ha Ön billentyűzetfelhasználó, nyomja le a Ctrl+Shift+Alt+O billentyűkombinációt a Visual Studio.

  • Kód megnyitása klónozott GitHub adattárból.

Több mappa megnyitása

A Visual Studio 2022 17.9 Preview 1 verziójától kezdve több mappát is megadhat a Visual Studióban való megnyitáshoz. Több mappa megnyitása különösen hasznos a sok nem kapcsolódó kóddal rendelkező kódtárakban, és a fejlesztőknek csak egy részhalmazra van szükségük a munkához.

  • A Visual Studio menüsávon válassza a File>Open>Munkatér lehetőséget, majd keresse meg a .code-workspace fájl helyét.
  • Maga .code-workspace a fájl várhatóan egy . JSON-séma, amely a következőhöz hasonlóan néz ki:
{
    "folders" : [
        {
            "path" : "some\\child\\foo",
            "name" : "The Foo"
        },
        {
            "path" : "..\\..\\some\\unrelated\\bar"
        },
        {
            "path" : "C:\\a\\full\\path\\baz"
        },
        {
            "path" : "${env.ANY_ENV_VARIABLE}\\foobar"
        }
    ]
}

Minden "path" érték lehet bármilyen relatív vagy gyökerező elérési út. A gyökérvonalaknak ugyanazon a meghajtóbetűjelen kell lenniük. A környezeti változók a szintaxissal ${env.ANY_ENV_VARIABLE}használhatók. A "name" tulajdonság használatával vizuális aliast hozhat létre a Megoldáskezelő mappához.

Kód megnyitása klónozott GitHub adattárból

Az alábbi példa bemutatja, hogyan klónozhat egy GitHub adattárat, majd nyithatja meg a kódját Visual Studio. Az eljárás végrehajtásához GitHub-fiókkal kell rendelkeznie, és a Git for Windowsnak telepítve kell lennie a rendszerén. További információ: A Visual Studio és Git for Windows használatával használható GitHub fiók létrehozása.

  1. Nyissa meg a GitHub klónozni kívánt adattárat.

  2. Válassza a Letöltés vagy letöltés gombot, majd a Copy to Clipboard gombot a legördülő menüben a GitHub adattár biztonságos URL-címének másolásához.

    GitHub klónozás gomb

A Git használata a Visual Studióban

2019 Visual Studio version 16.8 új, egyszerűsített Git-felületet vezettünk be, amellyel GitHub fájljait kezelheti. További információ: Visual Studio verziókövetési dokumentumok.

A Team Explorer használata a Visual Studióban

A Team Explorer továbbra is használható a Visual Studio 2022-ben, valamint a Visual Studio 2019 version 16.8 és újabb verzióiban. Az új Git-felület használata azonban egyszerűbb lehet. További információ: Hogyan Visual Studio egyszerűbbé teszi a verziókövetést a Git.

Note

A Team Explorer régi munkaelem-felülete elavult. A továbbiakban a munkaelemek nem nyílnak meg a Visual Studio belül, hanem a webes portálon nyílnak meg, ahol modernebb, konzisztensebb felületet talál. Ez a módosítás összhangban van a 2019- Visual Studio és 2022-ben bevezetett frissítésekkel, és biztosítja, hogy a munkaelemek minden funkciója elérhető legyen a webes felületen. További információkért lásd: munkaelemek a Visual Studióban.

  1. A Visual Studio válassza a Team Explorer lapot a Team Explorer megnyitásához. Ha nem látja a lapot, nyissa meg aCsoportkezelő>.

  2. A Team Explorer Local Git-adattárak szakaszában válassza a Clone parancsot, majd illessze be a GitHub lap URL-címét a szövegmezőbe.

    A projekt klónozása

  3. A Klónozás gombra kattintva klónozhatja a projekt fájljait egy helyi Git-adattárba. Az adattár méretétől függően ez a folyamat több percet is igénybe vehet.

  4. Miután az adattárat klónozta a rendszerbe, a Team Explorerben válassza az újonnan klónozott adattár helyi menüjének Megnyitás parancsát (jobb gombbal kattintva).

    Klónozott adattár

  5. Válassza a Show Mappanézet parancsot a fájlok megtekintéséhez Megoldáskezelő.

    Mappanézet megjelenítése

    Mostantól böngészhet a klónozott adattárban lévő mappákban és fájlokban, és megtekintheti és kereshet a kódot a Visual Studio kódszerkesztőben, szintaxisszínezéssel és egyéb funkciókkal kiegészítve.

A kód futtatása és hibakeresése

A Visual Studióban projekt vagy megoldás nélkül is hibakeresheti a kódját! Bizonyos nyelvek hibakereséséhez előfordulhat, hogy meg kell adnia egy érvényes indítási fájlt a kódbázisban, például egy szkriptet, végrehajthatót vagy projektet. Az eszköztár Start gombja melletti legördülő lista felsorolja az Visual Studio észlelt összes indítási elemet, valamint a konkrétan kijelölt elemeket. Visual Studio először ezt a kódot futtatja a kód hibakeresésekor.

A kód Visual Studio való futtatásának konfigurálása a kód típusától és a buildelési eszközöktől függően eltérő.

MSBuildet használó kódbázisok

Az MSBuild-alapú kódbázisok több buildkonfigurációval is rendelkezhetnek, amelyek megjelennek a Start gomb legördülő listájában. Jelölje ki az indítási elemként használni kívánt fájlt, majd a Start gombra kattintva kezdje el a hibakeresést.

Note

C# és Visual Basic kódbázisok esetében telepítve kell lennie az .NET asztali fejlesztés számítási feladatnak. C++ kódbázisok esetén telepítve kell lennie a C++ számítási feladattal rendelkező asztali fejlesztésnek .

Egyéni buildeszközöket használó kódbázisok

Ha a kódbázis egyéni buildeszközöket használ, akkor meg kell mondania a Visual Studiónak, hogyan építse fel a kódot a buildfeladatok segítségével, amelyeket egy .json fájlban definiáltak. További információ: Buildelési és hibakeresési feladatok testreszabása.

Python vagy JavaScript-kódot tartalmazó kódbázisok

Ha a kódbázis Python vagy JavaScript-kódot tartalmaz, nem kell konfigurálnia .json fájlokat, de telepítenie kell a megfelelő számítási feladatot. Az indítási szkriptet is konfigurálnia kell:

  1. A Node.js-fejlesztés vagy a Python-fejlesztés munkaterhelést a Eszközök>Eszközök és szolgáltatások letöltése lehetőség választásával, illetve a Visual Studio bezárásával és a Visual Studio Installer futtatásával telepítheti.

    Node.js és Python fejlesztési számítási feladatok

  2. A Megoldáskezelő javaScript- vagy Python-fájl jobb gombbal kattintva vagy helyi menüjében válassza a Set indítóelemként parancsot.

  3. A hibakeresés megkezdéséhez kattintson a Start gombra.

C++ kódot tartalmazó kódbázisok

A Visual Studióban a C++-kód megoldások vagy projektek használata nélküli megnyitásával kapcsolatos információkért lásd: C++-hoz készült Mappa megnyitása projektek.

Visual Studio projektet tartalmazó kódbázisok

Ha a kódmappa Visual Studio projektet tartalmaz, a projektet indítóelemként is kijelölheti.

Projekt beállítása indítási elemként

A Start gomb szövege úgy változik, hogy a projekt az indítási elem.

Kivetítés a Start gombon