Megosztás a következőn keresztül:


Hiba Viva Connections alkalmazás elérése a Teams asztali ügyfélprogramból

Jelenségek

A szervezete követte a Viva Connections beállításának és elindításának lépéseit. Amikor azonban megpróbálja elérni a Viva Connections alkalmazást a Microsoft Teams asztali ügyfélprogramból, a következő hibaüzenet jelenik meg:

Hiba történt. Nem sikerült bejelentkezni. Ha a hiba továbbra is fennáll, forduljon a rendszergazdához, és adja meg a hibakódot CAA20004.

Ha a hibaüzenetben a További problémaadatok lehetőséget választja, a következő részletek jelennek meg:

AADSTS650057: Érvénytelen erőforrás. Az ügyfél olyan erőforráshoz kért hozzáférést, amely nem szerepel a kért engedélyek között az ügyfél alkalmazásregisztrációjában.

Képernyőkép a hibaüzenetről további információkkal.

Megjegyzés: Ez a probléma csak akkor fordul elő, ha az Viva Connections alkalmazást a Teams asztali ügyfélről éri el. Ez a hiba nem jelenik meg, ha a Teams webes ügyfélprogramból éri el a Viva Connections alkalmazást.

A probléma oka

Ez a hiba akkor fordul elő, ha SharePoint-keretrendszer (SPFx) kijelzőt ad hozzá a Viva Connections. A kijelző hozzáadása miatt a SharePoint Online ügyfél-bővíthetőségi webalkalmazás-egyszerű objektuma, amely az Microsoft Entra ID>App registrations alatt érhető el, nincs megfelelően konfigurálva, hogy megbízzon a Teams asztali ügyfélprogramban.

Megoldás

A probléma megoldásához lépjen az API-hozzáférés lapra a SharePoint Felügyeleti központban:

  1. Jelentkezzen be a SharePoint Felügyeleti központba globális rendszergazdai hitelesítő adatokkal.
  2. Válassza a Speciális>API-hozzáférés lehetőséget.

Ha nem látja az API acess lehetőséget, kövesse az alábbi lépéseket:

  1. Jelentkezzen be a SharePoint Felügyeleti központba globális rendszergazdai hitelesítő adatokkal.
  2. Válassza a További szolgáltatások lehetőséget.
  3. Válassza a Megnyitás gombot az Alkalmazások területen.
  4. Válassza az API-hozzáférés lehetőséget.