Memecahkan masalah Inventaris dan Pelacakan Perubahan

Artikel ini menjelaskan cara memecahkan dan mengatasi masalah Inventaris dan Pelacakan Perubahan Azure Automation. Untuk informasi umum tentang Inventaris dan Pelacakan Perubahan, lihat Ringkasan Inventaris dan Pelacakan Perubahan.

Kesalahan umum

Skenario: Mesin sudah terdaftar ke akun yang berbeda

Masalah

Anda mungkin menerima pesan kesalahan berikut:

Unable to Register Machine for Change Tracking, Registration Failed with Exception System.InvalidOperationException: {"Message":"Machine is already registered to a different account."}

Penyebab

Komputer telah disebarkan ke ruang kerja lain untuk Pelacakan Perubahan.

Resolusi

  1. Pastikan bahwa komputer Anda melaporkan ke ruang kerja yang benar. Untuk panduan tentang cara memverifikasi, lihat Memverifikasi konektivitas agen ke Azure Monitor. Pastikan juga ruang kerja ini ditautkan ke akun Azure Automation Anda. Untuk mengonfirmasi, buka akun Azure Automation, lalu pilih Ruang kerja tertaut di bagian Sumber Daya Terkait.

  2. Pastikan komputer muncul di ruang kerja Analitik Log yang ditautkan ke akun Azure Automation. Jalankan kueri berikut di ruang kerja Analitik Log.

    Heartbeat
    | summarize by Computer, Solutions
    

    Jika komputer ada dalam hasil kueri, berarti komputer belum masuk baru-baru ini. Kemungkinan terjadi masalah konfigurasi lokal. Anda harus menginstal ulang agen Analitik Log.

    Jika Anda melihat komputer dalam hasil kueri, pastikan bahwa, di bagian properti Solusi, Pelacakan Perubahan tercantum. Tindakan ini akan memastikan bahwa komputer telah didaftarkan dalam Inventaris dan Pelacakan Perubahan. Jika tidak, periksa masalah konfigurasi cakupan. Konfigurasi cakupan menentukan komputer yang dikonfigurasi untuk Inventaris dan Pelacakan Perubahan. Untuk mengonfigurasi konfigurasi cakupan untuk komputer target, lihat Mengaktifkan Inventaris dan Pelacakan Perubahan dari akun Azure Automation.

    Di ruang kerja Anda, jalankan kueri ini.

    Operation
    | where OperationCategory == 'Data Collection Status'
    | sort by TimeGenerated desc
    
  3. Jika Anda mendapatkan Data collection stopped due to daily limit of free data reached. Ingestion status = OverQuota hasil, kuota yang ditentukan pada ruang kerja Anda telah tercapai, yang mana telah menghentikan data untuk disimpan. Di ruang kerja Anda, buka Penggunaan dan estimasi biaya. Pilih Tingkat harga baru yang memungkinkan Anda menggunakan lebih banyak data, atau klik Batas harian, dan hapus batas.

Usage and estimated costs.

Jika masalah masih berlanjut, ikuti langkah-langkah dalam Menyebarkan Windows Hybrid Runbook Worker untuk menginstal ulang Hybrid Worker untuk Windows. Untuk Linux, ikuti langkahnya di Menyebarkan Linux Hybrid Runbook Worker.

Jendela

Skenario: Rekaman Inventaris dan Pelacakan Perubahan tidak ditampilkan untuk komputer Windows

Masalah

Anda tidak melihat hasil Inventaris dan Pelacakan Perubahan untuk komputer Windows yang telah diaktifkan untuk fitur tersebut.

Penyebab

Kesalahan ini dapat memiliki penyebab berikut:

  • Agen Analitik Log Azure untuk Windows tidak berjalan.
  • Komunikasi kembali ke akun Azure Automation diblokir.
  • Paket pengelolaan Inventaris dan Pelacakan Perubahan tidak diunduh.
  • VM yang diaktifkan mungkin berasal dari komputer kloning yang tidak disiapkan dengan Persiapan Sistem (sysprep) dengan agen Analitik Log untuk Windows terinstal.

Resolusi

Di komputer agen Analitik Log, buka C:\Program Files\Microsoft Monitoring Agent\Agent\Tools dan jalankan perintah berikut:

net stop healthservice
StopTracing.cmd
StartTracing.cmd VER
net start healthservice

Jika masih memerlukan bantuan, Anda dapat mengumpulkan informasi diagnostik dan menghubungi dukungan.

Catatan

Agen Analitik Log memungkinkan pelacakan kesalahan secara default. Untuk mengaktifkan pesan kesalahan verbose seperti dalam contoh sebelumnya, gunakan parameter VER. Untuk jejak informasi, gunakan INF saat menggunakan StartTracing.cmd.

Agen Log Analytics untuk Windows tidak berjalan

Pastikan bahwa agen Analitik Log untuk Windows (HealthService.exe) berjalan di komputer.

Komunikasi ke akun Azure Automation diblokir

Periksa Pemantau Peristiwa di komputer, dan cari peristiwa apa pun yang berisi kata changetracking di dalamnya.

Untuk mempelajari alamat dan port yang harus diizinkan agar Inventaris dan Pelacakan Perubahan berfungsi, lihat Perencanaan jaringan.

Paket pengelolaan tidak diunduh

Pastikan bahwa paket manajemen Inventaris dan Pelacakan Perubahan berikut diinstal secara lokal:

  • Microsoft.IntelligencePacks.ChangeTrackingDirectAgent.*
  • Microsoft.IntelligencePacks.InventoryChangeTracking.*
  • Microsoft.IntelligencePacks.SingletonInventoryCollection.*
VM dari komputer kloning yang persiapan sistemnya (sysprep) belum dilakukan

Jika menggunakan gambar kloning, lakukan sysprep gambar terlebih dahulu, lalu instal agen Analitik Log untuk Windows.

Linux

Skenario: Tidak ada hasil Inventaris dan Pelacakan Perubahan di komputer Linux

Masalah

Anda tidak melihat hasil Inventaris dan Pelacakan Perubahan untuk komputer Windows yang diaktifkan untuk fitur tersebut.

Penyebab

Berikut beberapa kemungkinan penyebab khusus untuk masalah ini:

  • Agen Log Analytics untuk Linux tidak berjalan.
  • Agen Log Analytics untuk Linux tidak dikonfigurasi dengan benar.
  • Ada konflik pemantauan integritas berkas (FIM).

Resolusi

Agen Log Analytics untuk Linux tidak berjalan

Verifikasi bahwa daemon untuk agen Analitik Log untuk Linux (omsagent) berjalan di komputer Anda. Jalankan kueri berikut di ruang kerja Analitik Log yang ditautkan ke akun Azure Automation Anda.

Copy
Heartbeat
| summarize by Computer, Solutions

Jika komputer tidak ada dalam hasil kueri, berarti komputer belum masuk. Mungkin ada masalah konfigurasi lokal dan Anda harus menginstal ulang agen. Untuk informasi tentang penginstalan dan konfigurasi, lihat Mengumpulkan data log dengan agen Analitik Log.

Jika komputer Anda muncul di hasil kueri, verifikasi konfigurasi cakupan. Lihat Solusi pemantauan penargetan di Azure Monitor.

Untuk pemecahan masalah lainnya terkait masalah ini, lihat Masalah: Anda tidak melihat data Linux apa pun.

Agen Log Analytics untuk Linux tidak dikonfigurasi dengan benar

Agen Analitik Log untuk Linux mungkin tidak dikonfigurasi dengan benar untuk pengumpulan output baris perintah dan log dengan menggunakan alat Pengumpul Log OMS. Lihat Ringkasan Inventaris dan Pelacakan Perubahan.

Konflik FIM

Fitur FIM Pertahanan Microsoft untuk Cloud mungkin salah memvalidasi integritas file Linux Anda. Verifikasi bahwa FIM beroperasi dan dikonfigurasi dengan benar untuk pemantauan file Linux. Lihat Ringkasan Inventaris dan Pelacakan Perubahan.

Langkah berikutnya

Jika Anda tidak melihat masalah di sini atau tidak dapat menyelesaikan masalah, coba salah satu saluran berikut untuk mendapatkan dukungan tambahan:

  • Dapatkan jawaban dari para ahli Azure melalui Forum Internet Azure.
  • Sambungkan dengan @AzureSupport, akun resmi Microsoft Azure untuk meningkatkan pengalaman pelanggan. Dukungan Azure menghubungkan komunitas Azure dengan jawaban, dukungan, dan para ahli.
  • Ajukan insiden dukungan Azure. Buka situs Dukungan Azure, lalu pilih Dapatkan Dukungan.