Bagikan melalui


Memecahkan masalah ConstrainedAllocationFailed saat menerapkan layanan Cloud (klasik) ke Azure

Penting

Cloud Services (klasik) sekarang tidak lagi digunakan untuk pelanggan baru dan akan dihentikan untuk semua pelanggan pada 31 Agustus 2024. Penyebaran baru sebaiknya menggunakan Azure Resource Manager yang baru berdasarkan model penyebaran Azure Cloud Services (dukungan tambahan).

Dalam artikel ini, Anda memecahkan masalah kegagalan alokasi di mana layanan Azure Cloud (klasik) tidak dapat disebarkan karena kendala alokasi.

Saat Anda menerapkan instans ke Layanan Awa (klasik), atau menambahkan instans peran web atau pekerja baru, Microsoft Azure mengalokasikan sumber daya komputasi.

Anda mungkin terkadang menerima kesalahan selama operasi ini bahkan sebelum Anda mencapai batas langganan Azure.

Tip

Informasi ini mungkin juga berguna saat Anda merencanakan penerapan layanan Anda.

Gejala

Di portal Microsoft Azure, navigasi ke layanan Cloud Anda (klasik) dan di bar samping pilih Log operasi (klasik) untuk melihat log.

Gambar menunjukkan bilah Log operasi (klasik).

Saat Memeriksa log layanan Cloud (klasik), Anda akan melihat pengecualian berikut:

Tipe Pengecualian Pesan kesalahan
ConstrainedAllocationFailed Operasi Azure '{Operation ID}' gagal dengan kode Compute.ConstrainedAllocationFailed. Alokasi gagal; tidak dapat memenuhi batasan dalam permintaan. Penyebaran layanan baru yang diminta terikat ke Grup Afinitas, atau menargetkan Jaringan Virtual, atau ada penyebaran yang ada di bawah layanan yang dihosting ini. Salah satu kondisi ini membatasi penerapan baru ke sumber daya Azure tertentu. Coba lagi nanti atau coba kurangi ukuran komputer virtual (VM) atau jumlah instans peran. Atau, jika memungkinkan, hapus batasan atau coba sebarkan ke wilayah yang berbeda.

Penyebab

Saat instans pertama diterapkan ke layanan Cloud (baik dalam penahapan atau produksi), layanan Cloud tersebut disematkan ke kluster.

Seiring waktu, sumber daya dalam kluster ini dapat dimanfaatkan sepenuhnya. Jika layanan Cloud (klasik) membuat permintaan alokasi untuk lebih banyak sumber daya saat sumber daya yang tidak mencukup tersedia di kluster yang disematkan, permintaan tersebut mengakibatkan kegagalan alokasi. Untuk informasi selengkapnya, lihat masalah umum kegagalan alokasi.

Solusi

Layanan cloud yang ada disematkan ke kluster. Penyebaran lebih lanjut untuk layanan Cloud (klasik) terjadi di kluster yang sama.

Ketika Anda mengalami kesalahan alokasi dalam skenario ini, tindakan yang direkomendasikan adalah menerapkan ulang ke layanan Cloud baru (klasik) (dan memperbarui CNAME).

Tip

Solusi ini kemungkinan paling berhasil karena memungkinkan platform untuk memilih dari semua kluster di wilayah itu.

Catatan

Solusi ini tidak akan menimbulkan downtime.

  1. Terapkan beban kerja ke layanan Cloud baru (klasik).

    Peringatan

    Jika Anda tidak ingin kehilangan alamat IP yang terkait dengan slot penerapan ini, Anda dapat menggunakan Solusi 3 - Pertahankan alamat IP.

  2. Perbarui catatan CNAME atau A untuk mengarahkan lalu lintas ke layanan Cloud baru (klasik).

  3. Setelah tidak ada lalu lintas yang masuk ke situs lama, Anda dapat menghapus layanan Cloud lama (klasik).

Lihat Pemecahan masalah kegagalan alokasi layanan Cloud (klasik) | Microsoft Docs untuk langkah-langkah perbaikan lebih lanjut.

Langkah berikutnya

Untuk solusi kegagalan alokasi dan informasi latar belakang lainnya:

Jika masalah Azure Anda tidak diatasi dalam artikel ini, kunjungi forum Azure di Microsoft Developer Network (MSDN) dan Stack Overflow. Anda dapat memposting masalah Anda di forum ini, atau memposting ke @AzureSupport di Twitter. Anda juga dapat mengirimkan permintaan dukungan Azure. Untuk mengirimkan permintaan dukungan, pada halaman dukungan Azure, pilih Dapatkan dukungan.