Konfigurasikan BFD melalui Azure ExpressRoute

Azure ExpressRoute mendukung Deteksi Penerusan Dua Arah (BFD) melalui peering privat dan peering Microsoft. Saat mengaktifkan BFD melalui ExpressRoute, Anda dapat mempercepat deteksi kegagalan tautan antara perangkat Microsoft Enterprise edge (MSEE) dan router yang dikonfigurasi oleh sirkuit ExpressRoute Anda (CE/PE). Anda dapat mengonfigurasi Azure ExpressRoute melalui perangkat perutean edge atau perangkat perutean Partner Edge Anda (jika Anda menggunakan layanan koneksi Lapisan 3 terkelola). Dokumen ini akan memandu Anda mengenali kebutuhan BFD, dan cara mengaktifkan BFD melalui Azure ExpressRoute.

Kebutuhan akan BFD

Diagram berikut menunjukkan keuntungan saat mengaktifkan BFD melalui sirkuit ExpressRoute: 1

Anda dapat mengaktifkan sirkuit ExpressRoute melalui koneksi Lapisan 2 atau koneksi Lapisan 3 terkelola. Dalam kedua kasus, jika terdapat lebih dari satu perangkat Lapisan-2 di jalur koneksi ExpressRoute, tanggung jawab mendeteksi kegagalan tautan di jalur terletak pada sesi BGP yang terlalu berlebihan.

Pada perangkat MSEE, BGP tetap aktif dan waktu penahanan biasanya dikonfigurasi masing-masing 60 dan 180 detik. Maka dari itu, ketika terjadi kegagalan tautan, dibutuhkan waktu hingga tiga menit untuk mendeteksi kegagalan tautan dan mengalihkan lalu lintas ke koneksi alternatif.

Anda dapat mengontrol pengatur waktu BGP dengan mengonfigurasi BGP yang lebih rendah untuk tetap aktif dan waktu penahanan pada perangkat edge peering Anda. Jika timer BGP tidak sama di antara dua perangkat peering, sesi BGP akan menetapkan menggunakan nilai waktu yang lebih rendah. BGP tetap aktif dapat diatur paling rendah tiga detik, dan waktu penahan paling rendah 10 detik. Namun, menetapkan timer BGP yang sangat agresif tidak disarankan karena protokolnya proses intensif.

Dalam skenario ini, BFD dapat membantu. BFD menyediakan deteksi kegagalan tautan dengan overhead rendah dalam interval waktu sub-detik.

Catatan

BFD memberikan waktu failover yang lebih cepat ketika kegagalan link terdeteksi, tetapi konvergensi koneksi secara keseluruhan akan memakan waktu hingga satu menit untuk failover antara gateway jaringan virtual ExpressRoute dan MSEE.

Mengaktifkan BFD

BFD dikonfigurasi secara default di bawah semua antarmuka peering ExpressRoute privat dan Microsoft yang baru dibuat pada MSEE. Dengan demikian, untuk mengaktifkan BFD, Anda hanya perlu mengonfigurasi BFD pada perangkat primer dan sekunder Anda. Mengonfigurasi BFD adalah proses dua langkah. Anda mengonfigurasi BFD pada antarmuka lalu menautkannya ke sesi BGP.

Contoh konfigurasi CE/PE (menggunakan Cisco IOS XE) ditunjukkan di bawah ini.

interface TenGigabitEthernet2/0/0.150
   description private peering to Azure
   encapsulation dot1Q 15 second-dot1q 150
   ip vrf forwarding 15
   ip address 192.168.15.17 255.255.255.252
   bfd interval 300 min_rx 300 multiplier 3


router bgp 65020
   address-family ipv4 vrf 15
      network 10.1.15.0 mask 255.255.255.128
      neighbor 192.168.15.18 remote-as 12076
      neighbor 192.168.15.18 fall-over bfd
      neighbor 192.168.15.18 activate
      neighbor 192.168.15.18 soft-reconfiguration inbound
   exit-address-family

Catatan

Untuk mengaktifkan BFD di bawah peering privat atau Microsoft yang sudah ada, Anda harus mengatur ulang peering. Ini perlu dilakukan pada sirkuit yang dikonfigurasi dengan peering privat sebelum Agustus 2018 dan peering Microsoft sebelum Januari 2020. Lihat Reset peering ExpressRoute

Negosiasi Timer BFD

Di antara serekan BFD, kedua serekan yang semakin lambat menentukan laju transmisi. Interval transmisi/terima MSEES BFD diatur ke 300 milidetik. Dalam skenario tertentu, interval dapat ditetapkan pada nilai yang lebih tinggi dari 750 milidetik. Dengan mengonfigurasi nilai yang lebih tinggi, Anda dapat memaksa interval ini menjadi lebih panjang tetapi tidak mungkin untuk mempersingkatnya.

Catatan

Jika Anda telah mengonfigurasi sirkuit Azure ExpressRoute Geo-redundan atau menggunakan konektivitas IPSec VPN Site-to-Site sebagai cadangan. Mengaktifkan BFD akan membantu kegagalan lebih cepat setelah kegagalan konektivitas ExpressRoute.

Langkah berikutnya

Untuk informasi atau bantuan selengkapnya, lihat tautan berikut ini: