Jarak jauh WSMan tidak didukung pada platform non-Windows

Sejak rilis PowerShell 6, dukungan untuk remoting melalui WS-Management (WSMan) pada platform non-Windows hanya tersedia untuk serangkaian distribusi Linux terbatas. Semua versi distribusi yang mendukung WSMan tidak lagi didukung oleh vendor Linux yang membuatnya.

Di non-Windows, WSMan mengandalkan proyek Open Management Infrastructure (OMI), yang tidak lagi mendukung powerShell jarak jauh. Klien OMI WSMan bergantung pada OpenSSL 1.0. Sebagian besar distribusi Linux telah pindah ke OpenSSL 2.0, yang tidak kompatibel dengan versi mundur. Saat ini, tidak ada distribusi yang didukung yang memiliki dependensi yang diperlukan agar klien OMI WSMan berfungsi.

Rencana kami untuk PowerShell 7.3 adalah menghapus pustaka yang sudah usang dan kode pendukung untuk platform non-Windows. Jarak jauh berbasis WSMan masih didukung antara sistem Windows. Remoting melalui SSH didukung untuk semua platform. Untuk informasi selengkapnya, lihat PowerShell jarak jauh melalui SSH.

Catatan

Pengguna mungkin dapat membuat WSMan jarak jauh berfungsi menggunakan modul PSWSMan . Modul ini tidak didukung atau dikelola oleh Microsoft.