Persyaratan Sistem Windows PowerShell

Artikel ini mencantumkan persyaratan sistem untuk Windows PowerShell 3.0, Windows PowerShell 4.0, Windows PowerShell 5.0, dan Windows PowerShell 5.1. Dan, fitur khusus, seperti Windows PowerShell Integrated Scripting Environment (ISE), perintah Common Information Model (CIM), dan alur kerja.

Windows 8.1 dan Windows Server 2012 R2 menyertakan semua program yang diperlukan. Artikel ini dirancang untuk pengguna rilis Windows sebelumnya.

Persyaratan sistem operasi

Windows PowerShell 5.1

Windows PowerShell 5.1 berjalan pada versi Windows berikut. Untuk menjalankan Windows PowerShell 5.1, instal Windows Management Framework 5.1. Untuk informasi selengkapnya, lihat Menginstal dan Mengonfigurasi WMF 5.1.

Versi Windows Persyaratan sistem
Windows Server 2022 Terinstal secara default
Server Windows 2019 Terinstal secara default
Server Windows 2016 Terinstal secara default
Windows Server 2012 R2 Menginstal Windows Management Framework 5.1
Windows Server 2012 Menginstal Windows Management Framework 5.1
Windows Server 2008 R2 dengan Paket Layanan 1 Menginstal Windows Management Framework 5.1
Windows 11 Terinstal secara default
Windows 10 versi 1607 ke atas Terinstal secara default
Windows 10 versi 1507, 1511 Menginstal Windows Management Framework 5.1
Windows 8.1 Menginstal Windows Management Framework 5.1
Windows 7 dengan Paket Layanan 1 Menginstal Windows Management Framework 5.1

Windows PowerShell 5.0

Windows PowerShell 5.0 berjalan pada versi Windows berikut. Untuk menjalankan Windows PowerShell 5.0, instal Windows Management Framework 5.1. Untuk informasi selengkapnya, lihat Menginstal dan Mengonfigurasi WMF 5.1. Windows Management Framework 5.1 menggantikan Windows Management Framework 5.0.

Versi Windows Persyaratan sistem
Windows Server 2022 Versi yang lebih tinggi diinstal secara default
Server Windows 2019 Versi yang lebih tinggi diinstal secara default
Server Windows 2016 Versi yang lebih tinggi diinstal secara default
Windows Server 2012 R2 Menginstal Windows Management Framework 5.1
Windows Server 2012 Menginstal Windows Management Framework 5.1
Windows Server 2008 R2 dengan Paket Layanan 1 Menginstal Windows Management Framework 5.1
Windows 11 Versi yang lebih tinggi diinstal secara default
Windows 10 versi 1607 ke atas Versi yang lebih tinggi diinstal secara default
Windows 10 versi 1507, 1511 Terinstal secara default
Windows 8.1 Menginstal Windows Management Framework 5.1
Windows 7 dengan Paket Layanan 1 Menginstal Windows Management Framework 5.1

Windows PowerShell 4.0

Windows PowerShell 4.0 berjalan pada versi Windows berikut. Untuk menjalankan Windows PowerShell 4.0, instal versi Windows Management Framework yang ditentukan untuk sistem operasi Anda.

Versi Windows Persyaratan sistem
Windows 8.1 Terinstal secara default
Windows Server 2012 R2 Terinstal secara default
Windows 7 dengan Paket Layanan 1 Menginstal Windows Management Framework 4.0
Windows Server 2008 R2 dengan Paket Layanan 1 Menginstal Windows Management Framework 4.0

Windows PowerShell 3.0

Windows PowerShell 3.0 berjalan pada versi Windows berikut. Untuk menjalankan Windows PowerShell 3.0, instal versi Windows Management Framework yang ditentukan untuk sistem operasi Anda.

Versi Windows Persyaratan sistem
Windows 8 Terinstal secara default
Windows Server 2012 Terinstal secara default
Windows 7 dengan Paket Layanan 1 Menginstal Windows Management Framework 3.0
Windows Server 2008 R2 dengan Paket Layanan 1 Menginstal Windows Management Framework 3.0
Windows Server 2008 dengan Paket Layanan 2 Menginstal Windows Management Framework 3.0

Persyaratan Microsoft .NET Framework

Tabel berikut ini memperlihatkan persyaratan .NET Framework untuk Windows PowerShell.

Versi Persyaratan .NET
Windows PowerShell 5.1 Memerlukan penginstalan penuh Microsoft .NET Framework 4.5. Windows 8.1 dan Windows Server 2012 R2 menyertakan Microsoft .NET Framework 4.5 secara default.
Windows PowerShell 5.0 Memerlukan penginstalan penuh Microsoft .NET Framework 4.5. Windows 8.1 dan Windows Server 2012 R2 menyertakan Microsoft .NET Framework 4.5 secara default.
Windows PowerShell 4.0 Memerlukan penginstalan penuh Microsoft .NET Framework 4.5. Windows 8.1 dan Windows Server 2012 R2 menyertakan Microsoft .NET Framework 4.5 secara default.
Windows PowerShell 3.0 Memerlukan penginstalan penuh Microsoft .NET Framework 4. Windows 8 dan Windows Server 2012 menyertakan Microsoft .NET Framework 4.5 secara default, yang memenuhi persyaratan ini.

Gunakan tautan berikut untuk mengunduh Microsoft .NET Framework dari Pusat Unduhan Microsoft.

Versi Tautan
.NET Framework 4.5 (dotNetFx45_Full_setup.exe) Microsoft .NET Framework 4.5
.NET Framework 4 (dotNetFx40_Full_setup.exe) Microsoft .NET Framework 4 (Penginstal Web)

Windows Management Framework 4.0

Windows PowerShell 5.0 mengharuskan Windows Management Framework 4.0 diinstal sebelumnya pada Windows Server 2008 R2 SP1 dan Windows 7 SP1.

WS-Management 3.0

Windows PowerShell 3.0 dan Windows PowerShell 4.0 memerlukan WS-Management 3.0, yang mendukung layanan WinRM dan protokol WSMan. Program ini termasuk dalam Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows Management Framework 4.0, dan Windows Management Framework 3.0.

Instrumentasi Manajemen Windows 3.0

Windows PowerShell 3.0 dan Windows PowerShell 4.0 memerlukan Instrumentasi Manajemen Windows 3.0 (WMI). Program ini termasuk dalam Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows Management Framework 4.0, dan Windows Management Framework 3.0. Jika program ini tidak diinstal pada komputer, fitur yang memerlukan WMI, seperti perintah CIM, jangan jalankan.

Runtime Bahasa Umum 4.0

Windows PowerShell 3.0, Windows PowerShell 4.0, dan Windows PowerShell 5.0 dikompilasi terhadap Common Language Runtime (CLR) 4.0.

Persyaratan antarmuka pengguna grafis

Windows PowerShell adalah aplikasi berbasis konsol yang tidak memerlukan antarmuka pengguna grafis. Sangat cocok untuk komputer yang tidak memiliki layar atau monitor, atau antarmuka pengguna, seperti opsi penginstalan Server Core Windows Server 2012 R2 atau Windows Server 2012.

Beberapa item memerlukan antarmuka pengguna grafis. Untuk detailnya, lihat artikel bantuan untuk setiap item.

Windows PowerShell persyaratan mesin

Windows PowerShell 4.0 dirancang agar kompatibel dengan versi Windows PowerShell 3.0 dan Windows PowerShell 2.0. Cmdlet, penyedia, snap-in, modul, dan skrip yang ditulis untuk Windows PowerShell 2.0 dan Windows PowerShell 3.0 berjalan tidak berubah di Windows PowerShell 4.0.

Namun, karena perubahan kebijakan aktivasi runtime di Microsoft .NET Framework 4, Windows PowerShell program host yang ditulis untuk Windows PowerShell 2.0 dan dikompilasi dengan Common Language Runtime (CLR) 2.0 tidak dapat berjalan tanpa modifikasi di Windows PowerShell 3.0, yang dikompilasi dengan CLR 4.0.

Persyaratan minimum mesin Windows PowerShell 2.0 adalah Microsoft .NET Framework 2.0.50727. Persyaratan ini dipenuhi oleh Microsoft .NET Framework 3.5 Paket Layanan 1. Persyaratan ini tidak dipenuhi oleh Microsoft .NET Framework 4 dan rilis Microsoft .NET Framework yang lebih baru.

Untuk informasi tentang menambahkan atau menginstal mesin Windows PowerShell 2.0, dan menambahkan atau menginstal versi microsoft .NET Framework yang diperlukan, lihat Menginstal Mesin Windows PowerShell 2.0. Untuk informasi tentang memulai mesin Windows PowerShell 2.0, lihat Memulai Mesin Windows PowerShell 2.0.

Windows Preinstallation Environment

Windows PowerShell 2.0, Windows PowerShell 3.0, dan Windows PowerShell 4.0 berjalan di Windows Preinstallation Environment (Windows PE). Namun, cmdlet berikut tidak didukung.

Layanan WinRM tidak ada di Windows PE.

Lihat juga

Menginstal Windows PowerShell

Memulai Windows PowerShell

Windows Management Framework