Catatan Rilis PreviewLogoVisual Studio 2022 versi 17.3


Tip

Tonton rekaman acara peluncuran Visual Studio 2022 untuk mempelajari tentang apa yang baru, mendengar trik tips & , dan mengunduh swag digital gratis.

Komunitas | Pengembang Peta Strategi | Visual Studio 2022Persyaratan | Sistem Kompatibilitas | Kode | yang Dapat Didistribusikan Riwayat | RilisKetentuan | Lisensi Blogs | Masalah | Rilis Terbaru yang DiketahuiWhats New di Dokumen Visual Studio


Klik tombol untuk mengunduh versi terbaru Visual Studio 2022. Untuk petunjuk tentang menginstal dan memperbarui Visual Studio 2022, lihat Memperbarui Visual Studio 2022 ke rilis terbaru. Selain itu, lihat instruksi tentang cara menginstal secara offline.

Tombol Unduh KomunitasUnduh Tombol ProfesionalTombol Unduh Perusahaan

Kunjungi situs Visual Studio untuk mengunduh produk Visual Studio 2022 lainnya.

Penting

Saluran Pratinjau tidak "ditayangkan" dan tidak dimaksudkan untuk digunakan pada komputer produksi atau untuk membuat kode produksi. Untuk informasi selengkapnya, lihat Siklus Hidup dan Layanan Produk Visual Studio.

Tombol Unduh Pratinjau KomunitasUnduh Tombol Pratinjau ProfesionalTombol Unduh Pratinjau Perusahaan


Yang Baru di Visual Studio 2022 versi 17.3

Visual Studio 2022 Blog

Blog Visual Studio 2022 adalah sumber resmi wawasan produk dari Tim Teknik Visual Studio. Anda dapat menemukan informasi mendalam tentang rilis Visual Studio 2022 di postingan berikut:


17.3.4 Visual Studio 2022 versi 17.3.4

dirilis 13 September 2022

Masalah yang Ditangani dalam rilis 17.3.4 ini

  • Hentikan penerbitan positif palsu untuk peringatan C4191.
  • Rilis ini memperbaiki peringatan berikut, "Nilai atribut 'PublicKey' di 'Microsoft .NET Framework 4.7.2 (x86 dan x64)' tidak cocok dengan file 'C:\Program Files (x86)\Microsoft SDKs\ClickOnce Bootstrapper\Packages\DotNetFX472\NDP472-KB4054530-x86-x64-AllOS-ENU.exe'. ", setelah menerbitkan proyek ClickOnce di Visual Studio 17.3

Pemberitahuan Keamanan

CVE-2022-38013 .NET Penolakan Kerentanan Layanan Penolakan kerentanan layanan ada di ASP.NET Core 3.1 dan .NET 6.0 di mana klien berbahaya dapat menyebabkan luapan tumpukan yang dapat mengakibatkan penolakan serangan layanan ketika penyerang mengirim payload khusus yang diurai selama pengikatan model.


17.3.3 Visual Studio 2022 versi 17.3.3

dirilis 30 Agustus 2022

Masalah yang Ditangani dalam rilis 17.3.3 ini

  • Memperbaiki masalah yang akan menyebabkan VS macet saat menggunakan penggantian nama di proyek C# atau VB.NET.

Dari Komunitas Pengembang


17.3.2 Visual Studio 2022 versi 17.3.2

dirilis 23 Agustus 2022

Masalah yang Ditangani dalam rilis 17.3.2 ini

  • Memperbaiki perintah Kotak Alat -> Pilih Item saat bahasa non-bahasa Inggris dipilih di Visual Studio.
  • Alat penginstal telah diperbarui untuk menangani dependensi internal yang mungkin hilang.

Dari Komunitas Pengembang

Saran Komunitas Pengembang: Anda bertanya, kami mendengarkan!

Lihat daftar masalah Komunitas Pengembang di bawah ini yang ditangani di Visual Studio 2022 versi 17.3


17.3.3 Visual Studio 2022 versi 17.3.3

dirilis 30 Agustus 2022

Masalah yang Ditangani dalam rilis 17.3.3 ini

  • Memperbaiki masalah yang akan menyebabkan VS macet saat menggunakan penggantian nama di proyek C# atau VB.NET.

Dari Komunitas Pengembang


17.3.2 Visual Studio 2022 versi 17.3.2

dirilis 23 Agustus 2022

Masalah yang Ditangani dalam rilis 17.3.2 ini

  • Memperbaiki perintah Kotak Alat -> Pilih Item saat bahasa non-bahasa Inggris dipilih di Visual Studio.
  • Alat penginstal telah diperbarui untuk menangani dependensi internal yang mungkin hilang.
  • Memanggil menu konteks Penjelajah Solusi tidak akan lagi menyebabkan VS tidak responsif.

Dari Komunitas Pengembang


17.3.1 Visual Studio 2022 versi 17.3.1

dirilis 16 Agustus 2022

Masalah yang Ditangani dalam rilis 17.3.1 ini

  • Termasuk pembaruan layanan 10.0.22000.832 untuk Windows SDK untuk Windows 11.

Dari Komunitas Pengembang


17.3.0 Visual Studio 2022 versi 17.3

dirilis 9 Agustus 2022

Ringkasan Apa yang Baru dalam Rilis Visual Studio 2022 versi 17.3 ini

  • GA Build beban kerja MAUI
  • Dukungan Hot Reload MAUI/Blazor CSS
  • Sekarang Anda dapat mencoba pilihan fitur baru di Visual Studio dengan setiap pembaruan, menggunakan fitur Apa yang Baru.
  • Pilih setiap fitur untuk mempelajari selengkapnya tentang fitur tertentu.

Yang Baru di Visual Studio

Akun Pengembang Apple

Pratinjau ini mencakup dukungan awal untuk akun AppStoreConnect Individual yang diperlukan untuk Pengembang Apple non-Perusahaan.

  • Untuk menambahkan akun Individual, buka Tools\Options lalu pilih item "Akun Apple" yang terletak di bagian Xamarin. Di "Akun Apple", klik "Tambahkan Akun..." dan pilih "Tambahkan Akun Individual" dan masukkan informasi Kunci API AppStoreConnect.
  • Setelah akun dibuat, sertifikat dan profil provisi dapat diakses melalui tombol "Lihat Detail".
  • Masalah umum:
    • Provisi Otomatis mungkin tidak berfungsi dengan benar untuk Akun individual dalam beberapa kasus. Untuk mengatasinya, ikuti instruksi untuk provisi manual.

Isti Audio di Editor

  • Kami telah memperkenalkan isti audio baru di editor Visual Studio. Saat diaktifkan, Visual Studio akan memutar suara saat tanda sisipan pengeditan tiba di baris dengan titik henti, kesalahan, atau peringatan. Secara default, Visual Studio menggunakan suara yang sama dengan Visual Studio Code, tetapi suara ini dapat dikonfigurasi ke preferensi pengguna.
  • Untuk mengaktifkan petunjuk audio, buka Alat\Opsi dan cari "Fitur Pratinjau" di bawah Lingkungan. Di Fitur Pratinjau, opsi baru adalah "Aktifkan Isti Audio untuk editor". Jika dicentang, saat Visual Studio dimulai lagi, suara akan diputar.
  • Untuk mengonfigurasi tanda audio individual, ketuk tombol Windows di Windows 10 atau Windows 11 dan cari "Ubah suara sistem". Di bawah Acara Program, cari simpul "Microsoft Visual Studio" di pohon Peristiwa Program. Peristiwa baru adalah "Line has Breakpoint", "Line has Error" dan "Line has Warning". Ini dapat digunakan untuk menyesuaikan atau menonaktifkan suara individual.

Panel Kontrol Suara di Windows

Alat Git

Dukungan pementasan baris, alias penahapan interaktif dengan kemampuan untuk menahapkan baris dan/atau potongan kode tertentu langsung dari editor dan tampilan diff. Untuk memulai, tahapkan salah satu perubahan terbaru Anda dengan memilih margin warna yang sesuai dan menggunakan antarmuka pengguna Intip Perbedaan untuk melakukan perubahan Anda.

Baca posting blog kami untuk mempelajari lebih lanjut dan membagikan umpan balik Anda.

Dukungan penahapan baris

C++

  • Toolchain Arm64EC tidak lagi ditandai sebagai eksperimental dan siap untuk penggunaan produksi.
  • Terminal Visual Studio sekarang dapat digunakan sebagai klien SSH dengan koneksi SSH anda yang disimpan. Dengan C++ untuk Linux Tools terinstal, buka jendela alat Terminal dan dropdown Terminal akan diisi dengan koneksi tersimpan Anda. Jika dipilih, mereka akan membuka jendela Terminal baru di dalam Visual Studio dan pseudoterminal pada sistem jarak jauh Anda. Karakter kontrol, warna, dan kesadaran posisi kursor semuanya didukung.
  • Visual Studio sekarang dapat menambahkan templat kelas Unreal Engine untuk proyek UE Anda. Untuk mencoba fitur ini, pastikan "dukungan IDE untuk Unreal Engine" dipilih dalam beban kerja "Pengembangan game dengan C++" dalam alat penginstal VS. Saat mengerjakan proyek UE, klik kanan proyek atau folder/filter dan pilih Tambahkan > Kelas UE.
  • Buka Definisi sekarang akan mengingat tanda tangan sebelumnya dan menavigasi sesuai ketika kecocokan yang lebih baik tidak tersedia (misalnya setelah Anda mengubah tanda tangan salah satu pasangan secara manual).
  • Meningkatkan responsivitas Go To All. Sebelumnya, hasil muncul setelah Anda berhenti mengetik. Dalam pengalaman baru, hasil akan ditampilkan saat Anda mengetik.
  • Dalam konteks yang mengharuskan penyelesaian jenis enum (misalnya penugasan ke variabel enum, case label, jenis enum yang dikembalikan, dll.) daftar pelengkapan otomatis sekarang akan difilter hanya ke enumerator yang cocok dan konstruksi terkait.
  • Menambahkan dukungan NuGet PackageReference untuk proyek C++/CLI MSBuild yang menargetkan .NET Core. Perubahan ini dilakukan untuk membuka blokir basis kode campuran agar tidak dapat mengadopsi .NET Core. Ini tidak berfungsi untuk jenis proyek C++ lainnya atau jenis proyek C++ apa pun yang menargetkan .NET Framework. Tidak ada rencana untuk memperluas dukungan PackageReference ke skenario C++ tambahan karena tim sedang mengerjakan pengalaman terpisah yang melibatkan vcpkg yang akan berfungsi untuk skenario non-MSBuild dan menambahkan fungsionalitas tambahan.
  • Menambahkan jendela Serial Monitor untuk pengembangan yang disematkan, tersedia melalui Debug > Windows > Serial Monitor.
  • Peningkatan pengindeksan C++ sebesar ~66% dibandingkan dengan 17,2.
  • Memperbarui versi CMake yang dikirim dengan Visual Studio ke versi 3.23. Lihat catatan rilis CMake 3.23 untuk detail tentang apa yang tersedia.
  • Meningkatkan versi alat LLVM yang dikirim dengan Visual Studio ke v14. Lihat catatan rilis LLVM dan Clang untuk detail tentang apa yang tersedia.
  • Memperbarui Dev 16.11 C++ Toolset secara berdampingan ke versi 14.29.30145.00. Versi terbaru Dev 16.11 C++ Toolset berisi perbaikan bug penting, termasuk memperbaiki semua laporan cacat C++20 yang tersisa. Untuk informasi tentang perbaikan bug, termasuk laporan cacat C++20 di Dev 16.11, silakan lihat https://docs.microsoft.com/en-us/visualstudio/releases/2019/release-notes#16.11.14
  • Kami telah melakukan berbagai penyempurnaan pada pengalaman dalam editor modul C++. "kami terus berupaya meningkatkan kualitas pengalaman tetapi mendorong Anda untuk mencoba di 17.3 dan melaporkan masalah yang tersisa melalui Komunitas Pengembang.

Men-debug & Diagnostik

  • Alat Analisis Diagnostik sekarang menyertakan penganalisis yang mencantumkan tumpukan panggilan unik dalam cadangan memori bersama dengan utas yang mengeksekusinya.
  • Visualizer IEnumerable sekarang mendukung ekspor data dalam format CSV. Cukup gunakan dropdown di sudut kanan atas dan pilih CSV. Visualizer juga akan memungkinkan Anda memfilter string filter berbasis data yang diinginkan. Visualizer akan mengembalikan semua baris yang berisi nilai yang cocok dengan string filter. Anda juga dapat mengekspor hasil yang difilter dan diurutkan dalam format CSV/Excel.

Visualizer_Filte

  • Kami juga menambahkan dukungan tema untuk visualizer IEnumerable dan DataTable/DataSet, sehingga kedua jendela visualizer ini bertema untuk tema gelap, terang, dan biru Visual Studio.

Visualizer_Filte

  • Mulai 17.3 pratinjau 3 debugger akan secara otomatis memuat ulang artefak yang didekompilasi yang ganas seperti simbol dan file PDB. Jika Anda memilih untuk mendekompilasi pada sesi sebelumnya, artefak akan secara otomatis dimuat ulang untuk semua sesi berikutnya dan akan membawa Anda ke sumber yang didekompilasi lebih cepat di simpul Sumber Eksternal. Ini masih akan menghormati pengaturan JMC Anda.
  • Debugger sekarang menyediakan opsi baru untuk menonaktifkan beban gambar NGEN atau siap memuat (RDR) untuk kode terkelola. Anda dapat mengubah pengaturan di bawah Opsi> Alat > Penelusuran Kesalahan > Umum > Mencegah menggunakan gambar yang telah dikommpilasikan sebelumnya pada beban modul atau Anda juga dapat dengan mudah mencari pengaturan menggunakan salah satu kata kunci di bilah pencarian Visual Studio.
  • Sekarang Anda akan melihat bingkai tumpukan Pengecualian di dalam jendela Call Stack, jadi untuk semua pengecualian asinkron, Anda dapat dengan cepat memuat simbol atau menemukan sumber dan langsung masuk ke situs pengecualian. Bingkai tumpukan pengecualian di dalam jendela Tumpukan Panggilan akan menyediakan fungsionalitas tumpukan panggilan aktual. Fitur seperti navigasi otomatis, dengan cepat beralih bolak-balik antar bingkai, dan opsi beban simbol/dekompilasi untuk kembali ke kode sumber tempat pengecualian dilemparkan.

Visualizer_Filte

Umum

  • Akun GitHub sekarang menjelajah di seluruh komputer saat masuk di komputer baru dengan akun personalisasi yang sama (akun yang ditampilkan di kiri atas dialog pengaturan akun).

Installer

  • Sekarang Anda dapat memperbarui semua versi Visual Studio berdampingan dengan tombol "Perbarui semua" pada alat penginstal.

Alat Pengembangan Microsoft Teams (Teams Toolkit)

  • Templat proyek Aplikasi Microsoft Teams telah ditingkatkan dan sekarang membuat berbagai jenis aplikasi Teams, termasuk bot pemberitahuan, bot perintah, aplikasi tab, dan ekstensi pesan. Anda sekarang dapat membuat dan men-debug berbagai Aplikasi Microsoft Teams menggunakan Teams Toolkit untuk Visual Studio.
  • Sebaiknya buat proyek baru menggunakan templat yang diperbarui untuk Aplikasi Teams yang sudah ada yang telah Anda buat dengan versi Teams Toolkit sebelumnya.
  • Sekarang Anda dapat memilih kapan harus masuk dengan identitas M365 dan mendaftarkan sumber daya aplikasi Teams menggunakan opsi menu Siapkan Dependensi Aplikasi Teams Project > Teams > .
  • Siapkan Dependensi Aplikasi Teams akan mendaftarkan aplikasi Teams dan Bot untuk proyek Teams Anda.
  • Updates ke file manifest.template.json dapat disinkronkan dengan Portal Pengembang Teams untuk debug lokal dengan memilih opsi menu "Siapkan Dependensi Aplikasi Teams" lagi kapan saja.
  • Updates ke file manifest.template.json dapat disinkronkan dengan Portal Pengembang Teams untuk pratinjau jarak jauh dengan memilih Project > Opsi menu Teams Toolkit > Update Manifest di Portal Pengembang Teams.
  • Anda dapat mempratinjau file manifes sebelum sinkronisasi dengan mengklik kanan file manifest.template.json dan menggunakan opsi menu File Manifes Pratinjau.
  • Gunakan Provisi Toolkit > Project > Teams di menu Cloud untuk membuat sumber daya dalam langganan Azure.
  • Gunakan Project > Teams Toolkit > Deploy ke menu Cloud untuk menerbitkan kode ke sumber daya tersebut.
  • Anda dapat membuka aplikasi Teams dari jarak jauh di browser yang dibuat dari menu Provisi menggunakan menu aplikasi Teams Pratinjau.
  • Anda dapat meng-zip aplikasi Teams dan membuat paket aplikasi dengan memilih > opsi menu Project Teams Toolkit > Zip App Package untuk berbagi dan mengunggah tujuan.
  • Anda dapat menemukan semua opsi menu Teams Toolkit dengan mengklik kanan pada proyek aplikasi Teams, opsi tersebut sama dengan menu Toolkit Project > Teams.
  • Pelajari selengkapnya tentang Teams Toolkit di https://aka.ms/teams-toolkit-vs-docs

Produktivitas .NET

  • Dalam C# 10 kami memperkenalkan Global Usings. Global Usings menambahkan penggunaan ke bagian atas file secara kasatmata dan otomatis. Kami sekarang menampilkan ikon di bagian atas file Anda untuk memberi tahu Anda jika Global Usings aktif dalam file Anda dan jika Anda mengklik ikon, itu akan menunjukkan kepada Anda apa yang Digunakan Global tersebut. Penggunaan Global

  • Definisi Intip sekarang mendukung tautan sumber, sumber yang disematkan, dan sumber yang didekompilasi. Intip Definisi

  • Kami menambahkan tiga opsi berikut untuk menciutkan dan menguraikan tampilan saat file terbuka:

    • Ciutkan #regions saat file terbuka
    • Ciutkan menggunakan pada file terbuka
    • Ciutkan implementasi dari metadata saat file terbuka
  • Sekarang Anda dapat menerapkan Perbaiki Semua ke Use expression body or block body dan Convert to raw string literal refaktor.

  • Kami sekarang memiliki perbaikan kode yang memperbaiki batasan yang tidak valid. Tempatkan kursor Anda pada squiggle diagnostik di editor. Tekan Ctrl+. untuk memicu menu Tindakan Cepat dan Refaktor . Pilih Perbaiki batasan. Perbaiki Batasan

  • Kami sekarang memiliki refaktor yang memungkinkan Anda untuk beralih antara pernyataan tingkat atas dan gaya Program.Main. Tempatkan kursor Anda pada pernyataan tingkat atas. Tekan Ctrl+. untuk memicu menu Tindakan Cepat dan Refaktor . Pilih Konversi ke program gaya 'Program.Main'. Konversi ke pemfaktoran ulang Program.Main

  • Kami menambahkan cakupan tambahan ke operasi Perbaiki Semua. Selain menerapkan operasi Perbaiki Semua ke Dokumen, Proyek, dan Solusi, Anda dapat menerapkan Perbaiki Semua ke Anggota Yang Berisi dan Tipe Yang Berisi. Perbaiki Semua Anggota yang Berisi dan Berisi Jenis

  • Kami sekarang secara otomatis mengonversi komentar baris tunggal ke komentar dokumen saat Anda menambahkan garis miring tambahan ke satu komentar baris.

  • Kami sekarang memiliki opsi gaya kode yang memungkinkan Anda memperingatkan kemungkinan pengecualian dalam perulangan foreach. Perulangan Foreach secara implisit dilemparkan ke jenis turunan berdasarkan desain. Ini diperlukan sebelum generik ada tetapi dapat menyebabkan pengecualian runtime dalam beberapa kasus.

Personalisasi

  • Kapabilitas manajemen dokumen telah diperbarui. Baca posting blog kami untuk mempelajari lebih lanjut.

Fitur ini mencakup:

  • Tab disusun dalam beberapa baris.
  • Pulihkan dokumen terbaru.
  • Indikator kotor yang dimodifikasi.
  • Dropdown menunjukkan nama dokumen yang tidak terlihat dalam miring.

Razor (ASP.NET Core) Editor

  • Editor Razor baru sekarang memiliki dukungan penyelesaian penuh di dalam <attribute>.
  • Editor Razor baru sekarang menangani penyelesaian atribut HTML dengan benar saat mengetik = " ".
  • Editor Razor baru sekarang mendukung HTML, JavaScript, dan CSS OnTypeFormatting.

Alat uji

  • Penemuan Paralel sekarang diaktifkan secara default saat menjalankan pengujian dari Test Explorer. Ini memungkinkan Visual Studio menggunakan inti yang tersedia untuk menemukan pengujian secara paralel dan mengurangi waktu untuk melihat pengujian di Test Explorer.

  • Jendela Pengujian Unit Langsung sekarang memiliki bilah status, mirip dengan Test Explorer. Ini akan memberi Anda wawasan yang lebih baik tentang operasi yang sedang berlangsung dalam Pengujian Unit Langsung serta kesalahan permukaan yang terlihat. Bilah Status Pengujian Unit Langsung

  • vstest.console sekarang mendukung rakitan yang berjalan dari platform target dan kerangka kerja target yang berbeda dalam satu permintaan.

  • Cakupan Kode sekarang memiliki cache untuk instrumentasi statis untuk performa yang lebih baik.

  • Microsoft.CodeCoverage.Console sekarang ditambahkan ke alat baris perintah.

  • Arsitektur default untuk anyCPU .NET Framework proyek pengujian berubah dari x86 menjadi x64. Perubahan ini menyatukan bagaimana arsitektur default ditentukan di semua jenis proyek pengujian untuk selalu didasarkan pada arsitektur Visual Studio. Artinya dalam visualStudio versi x64, x64 akan digunakan, dan di masa mendatang ARM64 VisualStudio, ARM64 akan digunakan. Aturan yang sama juga berlaku untuk dotnet test, dan vstest.console. Untuk kembali menggunakan x86, navigasikan ke Arsitektur Prosesor Pengujian > untuk proyek > AnyCPU x86

  • Pengujian Jarak Jauh sekarang mendukung uji coba terhadap lingkungan jendela arm64 jarak jauh.

  • Pengalaman build baru untuk [Pengujian Unit Langsung] sekarang diaktifkan secara default. Baca posting blog kami untuk mempelajari lebih lanjut.

  • Anda sekarang dapat memilih untuk melihat informasi cakupan kode pada margin editor dengan memilih "Margin Glyphs" di jendela Hasil Cakupan Kode. Mengonversi ke string mentah

  • Pengujian Unit Langsung sekarang menyediakan tombol untuk mengatur ulang semua status. Dengan membuka Uji > Pengujian > Unit Langsung Reset status Pengujian Unit Langsung untuk solusi. Status Reset Pengujian Unit Langsung

  • Pengujian Unit Langsung sekarang mendukung file Razor.

Pengembangan TypeScript dan JavaScript

  • Proyek file JavaScript dan TypeScript sekarang dikecualikan dari analisis program kecuali direferensikan oleh file tsconfig.json atau jsconfig.json. Hasilnya harus ditingkatkan performanya dalam proyek besar dengan banyak file TypeScript dan JavaScript.

  • Proyek JavaScript (.esproj) yang dirujuk dari proyek ASP.NET sekarang menyediakan opsi untuk menyertakan output build produksi dalam penerbitan proyek ASP.NET.

  • Layanan bahasa dan pengkompilasi TypeScript 4.7 disertakan dalam Visual Studio. Lihat posting blog pengumuman TypeScript 4.7 untuk informasi selengkapnya.

  • Debugger JavaScript multi-target baru sekarang digunakan secara default dalam proyek Node.js (.njsproj).

  • Menutup otomatis tag HTML dalam file JavaScript dan TypeScript React (.jsx/.tsx).

  • Memperbaiki masalah di mana Akuisisi Tipe Otomatis (ATA) tidak berfungsi saat server bahasa TypeScript default dipilih.

  • Memperbaiki masalah di mana simpul dependensi dalam proyek Node.js (.njsproj) menunjukkan dependensi tidak langsung saat paket dipulihkan menggunakan npm 7 atau yang lebih tinggi.


Pemberitahuan Keamanan


Dari Komunitas Pengembang


Masalah yang Diketahui

Lihat semua masalah terbuka dan solusi yang tersedia di Visual Studio 2022 dengan mengikuti tautan di bawah ini.


Umpan balik dan saran

Kami ingin mendengar pendapat Anda! Anda dapat Melaporkan Masalah atau MenyarankanIkon Umpan Balik Fitur dengan menggunakan ikon Kirim Umpan Balik di sudut kanan atas alat penginstal atau IDE Visual Studio, atau dari Bantuan > Kirim Umpan Balik. Anda bisa melacak masalah dengan menggunakan Visual Studio Developer Community, tempat Anda menambahkan komentar atau mencari solusi. Anda juga bisa mendapatkan bantuan pemasangan gratis melalui dukungan Live Chat kami.


Blog

Manfaatkan wawasan dan rekomendasi yang tersedia di situs Blog Alat Pengembang untuk memberi Anda informasi terbaru tentang semua rilis baru dan sertakan postingan mendalam tentang berbagai fitur.


Bagian Atas Halaman