Catatan
Akses ke halaman ini memerlukan otorisasi. Anda dapat mencoba masuk atau mengubah direktori.
Akses ke halaman ini memerlukan otorisasi. Anda dapat mencoba mengubah direktori.
Pemeriksaan bug KERNEL_STACK_INPAGE_ERROR memiliki nilai 0x00000077. Pemeriksaan bug ini menunjukkan bahwa halaman data kernel yang diminta dari file halaman tidak dapat dibaca ke dalam memori.
Penting
Artikel ini untuk programmer. Jika Anda adalah pelanggan yang telah menerima kode kesalahan layar biru saat menggunakan komputer Anda, lihat Memecahkan masalah kesalahan layar biru.
Parameter KERNEL_STACK_INPAGE_ERROR
Empat parameter yang tercantum dalam pesan memiliki dua kemungkinan arti.
Jika parameter pertama adalah 0, 1, atau 2, parameter memiliki arti berikut.
| Parameter | Deskripsi |
|---|---|
1 |
0: Halaman data kernel diambil dari cache halaman. 1: Halaman diambil dari disk. 2: Halaman diambil dari disk, tumpukan penyimpanan mengembalikan SUCCESS, tetapi Status.Information tidak sama dengan PAGE_SIZE. |
2 |
Nilai yang muncul di tumpukan tempat tanda tangan harus berada. |
3 |
0 |
4 |
Alamat tanda tangan pada tumpukan kernel |
Jika parameter pertama adalah nilai selain 0, 1, atau 2, parameter memiliki arti berikut.
| Parameter | Deskripsi |
|---|---|
1 |
Kode status |
2 |
Kode status I/O |
3 |
Nomor file halaman |
4 |
Offset ke dalam file halaman |
Penyebab
Jika parameter pertama adalah 0 atau 1, tanda tangan tumpukan dalam tumpukan kernel tidak ditemukan. Kesalahan ini mungkin disebabkan oleh perangkat keras yang cacat, seperti kesalahan RAM.
Jika parameter pertama adalah 2, tumpukan driver mengembalikan status yang tidak konsisten untuk pembacaan halaman. Misalnya, tumpukan driver mengembalikan status keberhasilan meskipun tidak membaca seluruh halaman.
Jika parameter pertama adalah nilai selain 0, 1, atau 2, nilai parameter pertama adalah kode kesalahan NTSTATUS yang dikembalikan tumpukan driver setelah mencoba mengambil halaman data kernel. Anda dapat menentukan penyebab pasti kesalahan ini dari kode status I/O (parameter kedua). Beberapa kode status umum meliputi yang berikut ini:
0xC000009A, atau STATUS_INSUFFICIENT_RESOURCES, menunjukkan kurangnya sumber daya kumpulan yang tidak dipagasi. Kode status ini menunjukkan kesalahan driver di tumpukan penyimpanan. (Tumpukan penyimpanan harus selalu dapat mengambil data ini, terlepas dari ketersediaan sumber daya perangkat lunak.)
0xC000009C, atau STATUS_DEVICE_DATA_ERROR, menunjukkan blok buruk (sektor) pada hard disk.
0xC000009D, atau STATUS_DEVICE_NOT_CONNECTED, menunjukkan kabel yang rusak atau longgar, penghentian, atau pengontrol tidak melihat hard disk drive.
0xC000016A, atau STATUS_DISK_OPERATION_FAILED, menunjukkan blok buruk (sektor) pada hard disk.
0xC0000185, atau STATUS_IO_DEVICE_ERROR, menunjukkan penghentian yang tidak tepat atau kabel yang rusak pada perangkat SCSI atau bahwa dua perangkat mencoba menggunakan IRQ yang sama.
Kode status ini adalah yang paling umum yang memiliki penyebab khusus. Untuk informasi selengkapnya tentang kemungkinan kode status lain yang mungkin dikembalikan, lihat file Ntstatus.h di Microsoft Windows Driver Kit (WDK).
Infeksi virus juga dapat menyebabkan pemeriksaan bug ini.
Resolusi
Mengatasi masalah blok buruk: Jika Anda dapat memulai ulang komputer setelah kesalahan, Autochk berjalan secara otomatis dan mencoba memetakan sektor buruk untuk mencegahnya digunakan lagi.
Jika Autochk tidak memindai hard disk untuk kesalahan, Anda dapat memulai pemindai disk secara manual. Jalankan Chkdsk /f /r pada partisi sistem. Anda harus memulai ulang komputer sebelum pemindaian disk dimulai. Jika Anda tidak dapat memulai sistem karena kesalahan, gunakan Konsol Pemulihan dan jalankan Chkdsk /r.
Peringatan Jika partisi sistem Anda diformat dengan sistem file FAT, nama file panjang yang digunakan sistem operasi Windows mungkin rusak jika Anda menggunakan Scandisk atau alat hard disk berbasis MS-DOS lainnya untuk memverifikasi integritas hard disk drive Anda dari MS-DOS. Selalu gunakan versi Chkdsk yang cocok dengan versi sistem operasi Windows Anda.
Mengatasi masalah perangkat keras yang rusak: Jika status I/O 0xC0000185 dan file halaman berada di disk SCSI, periksa kabel disk dan penghentian SCSI untuk masalah.
Mengatasi masalah RAM yang gagal: Jalankan diagnostik perangkat keras yang disediakan produsen sistem, terutama pemindai memori. Untuk informasi selengkapnya tentang prosedur ini, lihat manual pemilik untuk komputer Anda.
Periksa apakah semua kartu adaptor di komputer didudukkan dengan benar. Gunakan penghapus tinta atau perawatan kontak listrik, yang tersedia di toko pasokan elektronik, untuk memastikan kontak kartu adaptor bersih.
Periksa Pemantau Peristiwa Masuk Sistem untuk pesan kesalahan tambahan yang mungkin membantu mengidentifikasi perangkat yang menyebabkan kesalahan. Anda juga dapat menonaktifkan penembolokan memori BIOS untuk mencoba mengatasi kesalahan ini.
Pastikan Paket Layanan Windows terbaru terinstal.
Jika langkah-langkah sebelumnya gagal mengatasi kesalahan, bawa motherboard sistem ke fasilitas perbaikan untuk pengujian diagnostik. Retakan, jejak tergores, atau komponen yang rusak pada motherboard dapat menyebabkan kesalahan ini.
Mengatasi infeksi virus: Periksa virus di komputer Anda dengan menggunakan perangkat lunak pemindaian virus komersial terbaru yang memeriksa Catatan Boot Master dari hard disk. Semua sistem file Windows dapat terinfeksi oleh virus.