Fungsi IsWindowsXPSP1OrGreater (versionhelpers.h)

Menunjukkan apakah versi OS saat ini cocok, atau lebih besar dari, Windows XP dengan versi Paket Layanan 1 (SP1).

Sintaks

VERSIONHELPERAPI IsWindowsXPSP1OrGreater();

Mengembalikan nilai

True jika versi OS saat ini cocok, atau lebih besar dari, Windows XP dengan versi SP1; jika tidak, salah.

Keterangan

Fungsi ini tidak membedakan antara rilis klien dan server. Ini akan mengembalikan true jika nomor versi OS saat ini sama dengan atau lebih tinggi dari versi klien yang dinamai dalam panggilan. Misalnya, panggilan ke IsWindowsXPSP3OrGreater akan mengembalikan true pada Windows Server 2008. Aplikasi yang perlu membedakan antara versi server dan klien Windows harus memanggil IsWindowsServer.

Untuk situasi di mana nomor versi Windows Server tidak dibagikan dengan rilis klien Windows, Anda dapat menggunakan IsWindowsVersionOrGreater untuk mengonfirmasi.

Contoh

Fungsi sebaris yang ditentukan dalam file header VersionHelpers.h memungkinkan Anda memverifikasi versi sistem operasi dengan mengembalikan nilai Boolean saat menguji versi Windows.

Misalnya, jika aplikasi Anda memerlukan Windows XP dengan SP1 atau yang lebih baru, gunakan pengujian berikut.

#include <VersionHelpers.h>
…
    if (!IsWindowsXPSP1OrGreater())
    {
       MessageBox(NULL, "You need at least Windows XP with SP1", "Version Not Supported", MB_OK);
    }

Persyaratan

Persyaratan Nilai
Klien minimum yang didukung Windows 2000 Professional [hanya aplikasi desktop]
Server minimum yang didukung Windows 2000 Server [hanya aplikasi desktop]
Target Platform Windows
Header versionhelpers.h
Pustaka Kernel32.lib; Ntdll.lib
DLL Kernel32.dll; Ntdll.dll

Lihat juga

IsWindows7OrGreater

IsWindows7SP1OrGreater

IsWindows8OrGreater

IsWindows8Point1OrGreater

IsWindowsServer

IsWindowsVistaOrGreater

IsWindowsVistaSP1OrGreater

IsWindowsVistaSP2OrGreater

IsWindowsXPOrGreater

IsWindowsXPSP2OrGreater

IsWindowsXPSP3OrGreater