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Risolvere i problemi di Esplora gemelli digitali di Azure: Errori di autenticazione

Questo articolo descrive le cause e i passaggi di risoluzione per la ricezione di errori di autenticazione durante l'esecuzione di Esplora gemelli digitali di Azure.

Sintomi

Quando si esegue Esplora gemelli digitali di Azure, viene visualizzato il messaggio di errore seguente:

Screenshot di un messaggio di errore in Esplora gemelli digitali di Azure, intitolato Assicurarsi di avere le autorizzazioni corrette.

Cause

Causa #1

Questo errore si verificherà se l'account Azure non dispone delle autorizzazioni di controllo degli accessi in base al ruolo di Azure necessarie impostate nell'istanza di Gemelli digitali di Azure. Per accedere ai dati nell'istanza, è necessario disporre rispettivamente del ruolo proprietario del proprietario dei dati di Gemelli digitali di Azure o del proprietario dei gemelli digitali di Azure nell'istanza che si sta tentando di leggere o gestire.

Per altre informazioni sulla sicurezza e sui ruoli in Gemelli digitali di Azure, vedere Sicurezza per le soluzioni gemelli digitali di Azure.

Soluzioni

Soluzione #1

Verificare che l'utente di Azure abbia il ruolo lettore dati gemelli digitali di Azure nell'istanza di Gemelli digitali di Azure se si sta cercando di leggere i dati o il ruolo proprietario dei dati di Gemelli digitali di Azure nell'istanza se si tenta di gestire i dati.

Si noti che questo ruolo è diverso da...

  • il nome precedente per questo ruolo durante l'anteprima, proprietario di Gemelli digitali di Azure (anteprima) ( il ruolo è lo stesso, ma il nome è cambiato)
  • ruolo proprietario per l'intera sottoscrizione di Azure. Il proprietario dei dati di Gemelli digitali di Azure è un ruolo all'interno di Gemelli digitali di Azure ed è compreso nell'ambito di questa singola istanza di Gemelli digitali di Azure.
  • ruolo proprietario in Gemelli digitali di Azure. Questi sono due ruoli di gestione distinti di Gemelli digitali di Azure e il proprietario dei dati di Gemelli digitali di Azure è il ruolo che deve essere usato per la gestione.

Se non si dispone di questo ruolo, configurarlo per risolvere il problema.

Controllare l'installazione corrente

Un modo per verificare che l'assegnazione di ruolo sia stata configurata correttamente consiste nel visualizzare le assegnazioni di ruolo per l'istanza di Gemelli digitali di Azure nel portale di Azure. Passare all'istanza di Gemelli digitali di Azure nel portale di Azure. Per arrivare, è possibile cercarlo nella pagina delle istanze di Gemelli digitali di Azure o cercare il nome nella barra di ricerca del portale.

Visualizzare quindi tutti i ruoli assegnati in Assegnazioni di ruolo del controllo di accesso (IAM). > L'assegnazione di ruolo deve essere visualizzata nell'elenco.

Screenshot delle assegnazioni di ruolo per un'istanza di Gemelli digitali di Azure nella portale di Azure.

Risolvere i problemi

Se non si dispone di questa assegnazione di ruolo, un utente con un ruolo proprietario nella sottoscrizione di Azure deve eseguire il comando seguente per assegnare all'utente di Azure il ruolo appropriato nell'istanza di Gemelli digitali di Azure.

Se si è un proprietario della sottoscrizione, è possibile eseguire questo comando. In caso contrario, contattare un proprietario per eseguire questo comando per conto dell'utente. Il nome del ruolo è Il proprietario dei dati di Gemelli digitali di Azure per l'accesso alla modifica o l'accesso ai dati di Gemelli digitali di Azure per l'accesso in lettura.

az dt role-assignment create --dt-name <your-Azure-Digital-Twins-instance> --assignee "<your-Azure-AD-email>" --role "<role-name>"

Per altre informazioni su questo requisito di ruolo e sul processo di assegnazione, vedere Configurare le autorizzazioni di accesso dell'utente.

Passaggi successivi

Leggere i passaggi di configurazione per la creazione e l'autenticazione di una nuova istanza di Gemelli digitali di Azure:

Altre informazioni sulla sicurezza e le autorizzazioni per Gemelli digitali di Azure: