Configurare il rilevamento dell'inoltro bidirezionale su ExpressRoute

ExpressRoute supporta il rilevamento dell'inoltro bidirezionale su peering sia privato che Microsoft. Quando si abilita il rilevamento dell'inoltro bidirezionale su ExpressRoute, è possibile velocizzare il rilevamento degli errori di collegamento tra i dispositivi MSEE (Microsoft Enterprise Edge) e i router configurati dal circuito ExpressRoute (CE/PE). È possibile configurare ExpressRoute sui dispositivi di routing perimetrali di clienti o partner (se si è usato il servizio di connessione gestita di livello 3). Questo documento illustra i vantaggi offerti dal rilevamento dell'inoltro bidirezionale e mostra come abilitare questa funzionalità su ExpressRoute.

Vantaggi del rilevamento dell'inoltro bidirezionale

Il diagramma seguente illustra il vantaggio dell'abilitazione di BFD sul circuito ExpressRoute: 1

È possibile abilitare un circuito ExpressRoute tramite connessioni di livello 2 o connessioni gestite di livello 3. In entrambi i casi, se nel percorso di connessione di ExpressRoute è presente più di un dispositivo di livello 2, la responsabilità di rilevare eventuali errori di collegamento nel percorso è della sessione BGP sovrastante.

Nei dispositivi MSEE, BGP keep-alive e hold-time sono in genere configurati rispettivamente come 60 e 180 secondi. Per questo motivo, quando si verifica un errore di collegamento, possono essere necessari fino a tre minuti per rilevare eventuali errori di collegamento e passare il traffico a una connessione alternativa.

È possibile controllare i timer BGP configurando un tempo inferiore di keep-alive e attesa della sessione nel dispositivo peer perimetrale. Se i timer BGP non sono uguali tra i due dispositivi di peering, la sessione BGP stabilirà usando il valore di tempo inferiore. Il tempo di keep-alive della sessione BGP può essere impostato su un valore minimo di tre secondi e il tempo di attesa su un valore minimo di 10 secondi. Tuttavia, l'impostazione di un timer BGP molto aggressivo non è consigliata perché il protocollo è a elevato utilizzo di processi.

In questo scenario, il rilevamento dell'inoltro bidirezionale può essere di aiuto poiché consente di rilevare gli errori di collegamento con un sovraccarico ridotto in un intervallo di frazioni di secondo.

Nota

Il failover BFD offre tempi di failover più rapidi quando viene rilevato un errore di collegamento, ma la convergenza complessiva della connessione richiederà fino a un minuto per il failover tra i gateway di rete virtuale ExpressRoute e gli MEE.

Abilitazione del rilevamento dell'inoltro bidirezionale

BFD è configurato per impostazione predefinita in tutte le interfacce di peering Private e Microsoft di ExpressRoute appena create negli msee. Di conseguenza, per abilitare il rilevamento dell'inoltro bidirezionale, è sufficiente configurarlo nei dispositivi primario e secondario. La configurazione del rilevamento dell'inoltro bidirezionale è un processo in due passaggi. Si configura il rilevamento dell'inoltro bidirezionale nell'interfaccia e quindi lo si collega alla sessione BGP.

Di seguito è riportato un esempio di configurazione CE/PE (con Cisco IOS XE).

interface TenGigabitEthernet2/0/0.150
   description private peering to Azure
   encapsulation dot1Q 15 second-dot1q 150
   ip vrf forwarding 15
   ip address 192.168.15.17 255.255.255.252
   bfd interval 300 min_rx 300 multiplier 3


router bgp 65020
   address-family ipv4 vrf 15
      network 10.1.15.0 mask 255.255.255.128
      neighbor 192.168.15.18 remote-as 12076
      neighbor 192.168.15.18 fall-over bfd
      neighbor 192.168.15.18 activate
      neighbor 192.168.15.18 soft-reconfiguration inbound
   exit-address-family

Nota

Per abilitare BFD in un peering privato o Microsoft già esistente, è necessario reimpostare il peering. Questa operazione deve essere eseguita nei circuiti configurati con peering privato prima di agosto 2018 e peering Microsoft prima di gennaio 2020. Vedere Reimpostare i peering ExpressRoute.

Negoziazione dei timer di rilevamento dell'inoltro bidirezionale

Tra i due peer di rilevamento dell'inoltro bidirezionale, quello più lento determina la velocità di trasmissione. Gli intervalli di trasmissione/ricezione del rilevamento dell'inoltro bidirezionale su dispositivi MSEE sono impostati su 300 millisecondi. In alcuni scenari, l'intervallo può essere impostato su un valore più elevato di 750 millisecondi. Configurando un valore più alto, è possibile forzare questi intervalli a essere più lunghi, ma non è possibile renderli più brevi.

Nota

Se sono stati configurati circuiti ExpressRoute con ridondanza geografica o si usa la connettività VPN IPSec da sito a sito come backup. L'abilitazione di BFD consente di eseguire il failover più rapidamente in seguito a un errore di connettività ExpressRoute.

Passaggi successivi

Per maggiori informazioni o assistenza, consultare i collegamenti seguenti: