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Numero KB originale: 3197393
Problema
Un utente di Microsoft 365 non è in grado di inviare messaggi di posta elettronica agli utenti di Exchange locali in una distribuzione ibrida di Exchange. L'utente di Microsoft 365 riceve il report non recapitario (NDR) seguente:
Il messaggio a User@contoso.com non è stato recapitato.
L'utente non è stato trovato in <contoso.com>
Il rapporto di mancato recapito contiene il codice di errore seguente:
550 5.1.10 RESOLVER. ADR. RecipientNotFound; Destinatario non trovato dalla ricerca di indirizzi SMTP
Causa
Questo problema si verifica se l'utente è stato creato in Microsoft 365. In questo scenario, l'ambiente Exchange locale non dispone di alcun oggetto a cui fare riferimento per l'utente. Di conseguenza, tutte le query per tale indirizzo SMTP hanno esito negativo.
Soluzione
Per risolvere questo problema, creare una cassetta postale remota nell'ambiente locale e quindi attendere o forzare la sincronizzazione della directory. A tal fine, attenersi alla seguente procedura:
Creare un oggetto locale per la cassetta postale cloud usando il cmdlet New-RemoteMailbox in Exchange Management Shell.
Nota
Questo oggetto deve avere lo stesso nome, alias e nome dell'entità utente (UPN) della cassetta postale cloud. Per altre informazioni, vedere New-RemoteMailbox.
Impostare la proprietà ExchangeGuid nel nuovo oggetto locale creato nel passaggio 1 in modo che corrisponda alla cassetta postale cloud. A tal fine, attenersi alla seguente procedura:
Connettersi a Exchange Online usando powershell remoto.
Per ulteriori informazioni, vedere Connessione a Exchange Online PowerShell.
Usare il cmdlet Get-Mailbox per recuperare il valore della
ExchangeGuid
proprietà della cassetta postale cloud. Ad esempio, eseguire il seguente comando:Get-Mailbox <MailboxName>| FL ExchangeGuid
Per altre informazioni, vedere Get-Mailbox.
Aprire Exchange Management Shell nel server Exchange locale.
Utilizzare il
Set-RemoteMailbox
cmdlet per impostare il valore dellaExchangeGuid
proprietà nell'oggetto locale sul valore recuperato nel passaggio 2b. Ad esempio, eseguire il seguente comando:Set-RemoteMailbox <MailboxName> -ExchangeGuid <GUID>
Per altre informazioni, vedere Set-RemoteMailbox.
Attendere che si verifichi la sincronizzazione della directory. In alternativa, forzare la sincronizzazione della directory.
Per altre informazioni, vedere Sincronizzare le directory.
Assicurarsi che l'oggetto utente di Microsoft 365 sia visualizzato come Sincronizzato con Active Directory.
Ulteriori informazioni
Ulteriore assistenza Visitare la community Microsoft.