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Sintomi
Quando si invia un messaggio di richiesta di attività in Outlook, la richiesta di attività del destinatario non contiene i pulsanti Accetta e Rifiuta o contiene dettagli delle attività leggibili. Questo problema può verificarsi per i destinatari interni o esterni all'organizzazione di Microsoft Exchange.
Ad esempio, la richiesta di attività del destinatario potrebbe essere simile all'esempio seguente.
Lo screenshot successivo mostra l'aspetto della richiesta di attività.
Causa
Outlook ha inviato la richiesta di attività come messaggio RTF (Rich Text Format), ma un componente di trasporto ha modificato il formato del messaggio in HTML. La conversione in HTML ha rimosso gli elementi del pulsante e ha ignorato il layout del messaggio.
Se il destinatario è interno all'organizzazione di Exchange, la configurazione di Exchange potrebbe avere:
- Connettore in uscita che instrada i messaggi tramite un servizio esterno. Il flusso di posta interno mantiene il formato dei messaggi RTF, ma i servizi esterni spesso convertono i messaggi RTF in HTML. Ad esempio, i servizi di dichiarazione di non responsabilità di firma e privacy converte i messaggi RTF in HTML.
Se il destinatario è esterno all'organizzazione di Exchange, la configurazione di Exchange potrebbe avere:
Connettore in uscita che indirizza i messaggi tramite un servizio esterno che modifica il formato del messaggio in HTML.
Impostazione di dominio
TNEFEnabled
remoto che converte i messaggi RTF in uscita in HTML.
Risoluzione
Per risolvere il problema, controllare le impostazioni seguenti e quindi apportare le modifiche appropriate:
Per i destinatari interni ed esterni, controllare se un connettore in uscita instrada i messaggi tramite un servizio esterno. In tal caso, è consigliabile aggiungere un'eccezione alla regola del flusso di posta che instrada i messaggi a tale connettore. Ad esempio, è possibile escludere i messaggi di richiesta di attività da instradare tramite servizi esterni creando un'eccezione per i messaggi con un oggetto che inizia con "
Task request:
".Per i destinatari esterni, controllare l'impostazione
TNEFEnabled
per tutti i domini remoti. A tale scopo, utilizzare il seguente comando:Get-RemoteDomain | Where {$_.TNEFEnabled -ne $true}
Se l'impostazione TNEFEnabled
di un dominio remoto è $null
o $false
, Exchange convertirà i messaggi RTF in HTML per i destinatari in tale dominio. Ad esempio, se l'impostazione per il TNEFEnabled
dominio remoto predefinito è $null
e se si tratta dell'unico dominio remoto, Exchange convertirà tutti i messaggi RTF esterni in HTML. Per risolvere il problema per un destinatario esterno interessato, seguire questa procedura:
Creare un dominio remoto per il dominio del destinatario esterno interessato.
Impostare
TNEFEnabled
su$true
per tale dominio eseguendo il comando seguente:Set-RemoteDomain -Identity <name of the new remote domain> -TNEFEnabled $true
Note
Evitare di impostare TNEFEnabled
su $true
nel dominio remoto predefinito perché tale modifica influirà su tutti i destinatari esterni, inclusi quelli il cui client di posta elettronica potrebbe non supportare i messaggi RTF.