Condividi tramite


Non è possibile sincronizzare una cartella condivisa impostata come collegamento in sincronizzazione OneDrive'app

Sintomi

Si crea un collegamento a una cartella archiviata in una raccolta documenti di SharePoint Online e quindi si aggiunge il collegamento a OneDrive. Quando si tenta di sincronizzare la raccolta documenti di SharePoint Online con l'app sincronizzazione Microsoft OneDrive, la sincronizzazione smette di funzionare e viene visualizzato il messaggio di errore seguente:

Non è possibile sincronizzare questa cartella. Si sta già sincronizzando un collegamento a una cartella da questa raccolta condivisa.

Causa

Si tratta di un comportamento legato alla progettazione del prodotto. Non è possibile sincronizzare una raccolta documenti già impostata come collegamento in OneDrive. Analogamente, non è possibile usare l'opzione Aggiungi collegamento ai file personali se la raccolta documenti è già sincronizzata.

Nota: Per una raccolta documenti di SharePoint, non è possibile usare sia il collegamento Sincronizza che Aggiungi alle funzionalità File personali .

Risoluzione

Per risolvere questo problema, usare uno dei metodi seguenti per rimuovere il collegamento.

Metodo 1: Rimuovere il collegamento dalla cartella OneDrive

  1. Aprire la cartella OneDrive nel dispositivo.
  2. Trovare la cartella di collegamento con una piccola icona di collegamento ( ).
  3. Fare clic con il pulsante destro del mouse sulla cartella di collegamento e scegliere Elimina.

Se non è possibile rimuovere la cartella di collegamento, sospendere la sincronizzazione nell'app sincronizzazione OneDrive e quindi riprovare a eliminare il collegamento.

Metodo 2: Rimuovere il collegamento dal sito di OneDrive

  1. Accedere all'account Microsoft 365 e quindi selezionare OneDrive dall'icona di avvio delle app ( ). In alternativa, aprire direttamente l'URL del sito di OneDrive .
  2. Nell'angolo in alto a sinistra selezionare File personali.
  3. Trovare la cartella di collegamento con una piccola icona di collegamento ( ).
  4. Fare clic con il pulsante destro del mouse sulla cartella o selezionare l'icona dei tre puntini ( ) accanto alla cartella e quindi selezionare Rimuovi.

Se non è possibile rimuovere il collegamento, sospendere la sincronizzazione nell'app sincronizzazione OneDrive e quindi riprovare a eliminare il collegamento.