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Si applica a: ✔️ macchine virtuali di Windows
Questo articolo fornisce i passaggi per risolvere i problemi in cui un processo critico si interrompe durante l'avvio in una macchina virtuale di Azure.
Sintomo
Quando si utilizza Diagnostica di avvio per visualizzare la schermata della macchina virtuale, si noterà che la schermata visualizza l'errore #0x000000EF con il messaggio Processo critico non riuscito.
Causa
Di solito, il problema è dovuto all'interruzione di un processo critico del sistema durante l'avvio. Puoi leggere ulteriori informazioni sui problemi critici del processo in "Bug Check 0xEF: CRITICAL_PROCESS_DIED".
Soluzione
Panoramica del processo
Suggerimento
Se hai un backup recente della VM, puoi provare a ripristinare la VM dal backup per risolvere il problema di avvio.
- Crea e accedi a una macchina virtuale di riparazione.
- Correggi qualsiasi danneggiamento del sistema operativo.
- Consigliato: prima di ripristinare la macchina virtuale, abilitare la console seriale e la raccolta dei dump di memoria.
- Ricostruisci la macchina virtuale.
Note
Quando si verifica questo errore di avvio, il sistema operativo guest non è operativo. Risolverai i problemi in modalità offline per risolvere questo problema.
Creare e accedere a una macchina virtuale di ripristino
- Utilizzare i passaggi 1-3 dei comandi di riparazione della VM per preparare una VM di riparazione.
- Utilizzando Connessione Desktop remoto, collegarsi alla macchina virtuale di ripristino.
Correggi qualsiasi danneggiamento del sistema operativo
Aprire un prompt dei comandi con privilegi elevati.
Eseguire il seguente comando SFC (System File Checker):
sfc /scannow /offbootdir=<BOOT DISK DRIVE>:\ /offwindir=<BROKEN DISK DRIVE>:\windows
- Dove
<BOOT DISK DRIVE>
è la partizione di avvio della macchina virtuale non funzionante e<BROKEN DISK DRIVE>
è la partizione del sistema operativo della macchina virtuale non funzionante. Sostituire i simboli maggiore di/minore di e il testo in essi contenuto, ad esempio "< testo qui >", con la lettera appropriata.
- Dove
Successivamente, utilizza il passaggio 5 dei comandi di riparazione della VM per riassemblare la VM e vedere se si avvia.
Se la macchina virtuale continua a non avviarsi, continuare a raccogliere il file di dump della memoria.
Raccogli il file di dump della memoria
Se il problema persiste dopo l'esecuzione di SFC, sarà necessaria l'analisi di un file di dump della memoria per determinare la causa del problema. Per raccogliere il file di immagine della memoria, attenersi alla seguente procedura:
Passaggio 1: individuare il file di dump e inviare un ticket di supporto
Parte 1: collegare il disco del sistema operativo a una macchina virtuale di ripristino
Eseguire uno snapshot del disco del sistema operativo della macchina virtuale interessata per creare un backup. Per altre informazioni, vedere Creare uno snapshot di un disco rigido virtuale.
Collegare il disco del sistema operativo a una macchina virtuale di ripristino.
Utilizzare Remote Desktop Protocol (RDP) per connettersi da remoto alla macchina virtuale di ripristino.
Se il disco del sistema operativo della macchina virtuale interessata è crittografato, disattivare la crittografia prima di andare al passaggio successivo. Per ulteriori informazioni, vedere Descrittografare il disco del sistema operativo crittografato.
Parte 2: individuare il file di dump e inviare un ticket di supporto
Nella macchina virtuale di ripristino, accedere alla cartella Windows sul disco del sistema operativo collegato. Ad esempio, se la lettera di unità assegnata al disco del sistema operativo collegato è F, passare a F:\Windows.
Individuare il file Memory.dmp, quindi inviare un ticket di supporto e allegare il file di dump.
Se non si riesce a trovare il file di dump, passare ai passaggi successivi per abilitare il registro dump e la console seriale, quindi riprodurre il problema.
Passaggio 2: attivare il registro dump e la console seriale
Importante
In questa sezione, metodo o attività viene illustrata la procedura per modificare il Registro di sistema. Se, tuttavia, si modifica il Registro di sistema in modo errato, possono verificarsi gravi problemi. Pertanto, assicurarsi di osservare attentamente la procedura seguente. Al fine di protezione, eseguire il backup del registro di sistema prima di modificarlo, in modo da poterlo ripristinare in caso di problemi. Per ulteriori informazioni su come eseguire il backup e il ripristino del Registro di sistema, vedi Come eseguire il backup e il ripristino del Registro di sistema in Windows.
Per attivare un registro dump e la console seriale, seguire questa procedura:
Aprire una sessione del prompt dei comandi con privilegi elevati come amministratore.
Eseguire i seguenti comandi BCDEdit utilizzando le opzioni /ems e /emssettings:
Attivare la console seriale:
bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
Verificare che lo spazio libero sul disco del sistema operativo sia maggiore della dimensione della memoria (RAM) sulla macchina virtuale.
Se lo spazio sul disco del sistema operativo non è sufficiente, è necessario modificare la posizione in cui viene creato il file di dump della memoria e fare riferimento a qualsiasi disco dati collegato alla macchina virtuale che disponga di spazio libero sufficiente. Per modificare la posizione, sostituisci
%SystemRoot%
con la lettera dell'unità del disco dati, ad esempioF:
, nei seguenti comandi.Per abilitare il file di dump del sistema operativo, eseguire i seguenti comandi load, add e unload per implementare la configurazione suggerita utilizzando lo strumento reg:
Caricare l'hive del Registro di sistema dal disco del sistema operativo danneggiato:
reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
Abilitare su ControlSet001:
reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Abilitare su ControlSet002:
reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Scaricare il disco del sistema operativo danneggiato:
reg unload HKLM\<broken-system>
Consigliato: prima di ricompilare la macchina virtuale, abilitare la console seriale e la raccolta di dump della memoria
Per abilitare la raccolta di dump della memoria e della console seriale, seguire questa procedura:
Aprire una sessione del prompt dei comandi con privilegi elevati come amministratore.
Eseguire i seguenti comandi BCDEdit utilizzando le opzioni /ems e /emssettings:
Attivare la console seriale:
bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /ems {<boot-loader-identifier>} ON bcdedit /store <volume-letter-containing-the-bcd-folder>:\boot\bcd /emssettings EMSPORT:1 EMSBAUDRATE:115200
Verificare che lo spazio libero sul disco del sistema operativo sia maggiore della dimensione della memoria (RAM) sulla macchina virtuale.
Se lo spazio sul disco del sistema operativo non è sufficiente, è necessario modificare la posizione in cui viene creato il file di dump della memoria e fare riferimento a qualsiasi disco dati collegato alla macchina virtuale che disponga di spazio libero sufficiente. Per modificare la posizione, sostituisci
%SystemRoot%
con la lettera dell'unità del disco dati, ad esempioF:
, nei seguenti comandi.Per abilitare il file di dump del sistema operativo, eseguire i seguenti comandi load, add e unload per implementare la configurazione suggerita utilizzando lo strumento reg:
Caricare l'hive del Registro di sistema dal disco del sistema operativo danneggiato:
reg load HKLM\<broken-system> <volume-letter-of-broken-os-disk>:\windows\system32\config\SYSTEM
Abilitare su ControlSet001:
reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet001\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Abilitare su ControlSet002:
reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v CrashDumpEnabled /t REG_DWORD /d 1 /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v DumpFile /t REG_EXPAND_SZ /d "%SystemRoot%\MEMORY.DMP" /f reg add "HKLM\<broken-system>\ControlSet002\Control\CrashControl" /v NMICrashDump /t REG_DWORD /d 1 /f
Scaricare il disco del sistema operativo danneggiato:
reg unload HKLM\<broken-system>
Ricostruisci la VM originale
Utilizza il passaggio 5 dei comandi di riparazione della VM per riassemblare la VM.
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