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Errore di arresto di Windows - 0xC000021A processo del sistema di stato terminato

Si applica a: ✔️ macchine virtuali di Windows

Questo articolo illustra i passaggi per risolvere i problemi in cui il sistema operativo rileva l'0xC000021A stop error code (Arresta codice di errore). Questo errore impedisce il riavvio di una macchina virtuale di Azure.

Sintomi

Quando si usa diagnostica di avvio per visualizzare uno screenshot della macchina virtuale, lo screenshot visualizza il messaggio seguente che indica che il sistema operativo ha rilevato un errore durante il riavvio:

Il tuo PC ha riscontrato un problema e deve essere riavviato. Stiamo solo raccogliendo alcune informazioni sull'errore, quindi puoi riavviare. (##% completato) Se desideri saperne di più, puoi cercare online in seguito questo errore: 0xC000021a.

Screenshot del codice di errore di arresto: #0xC000021A e il messaggio

Causa

L'errore 0xC000021A indica STATUS_SYSTEM_PROCESS_TERMINATED.

Questo errore si verifica quando un processo critico, ad esempio Winlogon (winlogon.exe) o il sottosistema di runtime del server client (csrss.exe), ha esito negativo. Dopo che il kernel rileva che uno di questi servizi è stato arrestato, restituisce il codice di errore STOP 0xC000021A . Questo errore potrebbe avere diverse cause, tra cui:

  • File di sistema non corrispondenti installati.
  • Installazione dell'aggiornamento service pack o KB non riuscita.
  • Un programma di backup usato per ripristinare un disco rigido non ha ripristinato correttamente i file che potrebbero essere stati in uso.
  • È stato installato un programma di terze parti incompatibile.

Soluzione 1: ripristinare la macchina virtuale da un backup

Se si dispone di un backup recente della macchina virtuale, è possibile provare a ripristinare la macchina virtuale dal backup per risolvere il problema di riavvio.

Soluzione 2: recuperare il file di dump della memoria

Se il ripristino del backup non risolve il problema, raccogliere un file di dump della memoria in modo che l'arresto anomalo possa essere analizzato. Per raccogliere il file di dump, consultare le sezioni seguenti.

Parte 1: collegare il disco del sistema operativo a una macchina virtuale di ripristino
  1. Eseguire uno snapshot del disco del sistema operativo della macchina virtuale interessata per creare un backup. Per altre informazioni, vedere Creare uno snapshot di un disco rigido virtuale.

  2. Collegare il disco del sistema operativo a una macchina virtuale di ripristino.

  3. Utilizzare Remote Desktop Protocol (RDP) per connettersi da remoto alla macchina virtuale di ripristino.

  4. Se il disco del sistema operativo della macchina virtuale interessata è crittografato, disattivare la crittografia prima di andare al passaggio successivo. Per ulteriori informazioni, vedere Descrittografare il disco del sistema operativo crittografato.

Parte 2: individuare il file di dump e inviare un ticket di supporto
  1. Nella macchina virtuale di ripristino, accedere alla cartella Windows sul disco del sistema operativo collegato. Ad esempio, se la lettera di unità assegnata al disco del sistema operativo collegato è F, passare a F:\Windows.

  2. Individuare il file Memory.dmp, quindi inviare un ticket di supporto e allegare il file di dump.

Note

Se si verificano problemi durante l'individuazione del file Memory.dmp , è possibile provare a usare chiamate di interrupt non mascherabili nella console seriale. È possibile usare queste indicazioni per generare un file di dump di arresto anomalo del sistema usando le chiamate NMI.

Passaggi successivi

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