Condividi tramite


Risolvere i problemi relativi al grafico Sales Pipeline e alle relative fasi in Dynamics 365 Sales

Questo articolo consente di riscontrare e risolvere i problemi relativi al grafico della Sales Pipeline e alle relative fasi.

Il grafico Sales Pipeline è costituito da fasi della pipeline di un'opportunità. La fase si basa sulla fase del processo aziendale in cui si trova l'opportunità, ad esempio 1-Qualify, 2-Develop e così via. Per altre informazioni, vedere Informazioni sul grafico della pipeline di vendita e sulle relative fasi.

Problema 1: più fasi della pipeline con sequenze diverse, ad esempio 6-Close e 7-Close

Causa

Questo problema può verificarsi se è stata modificata la sequenza di un'opzione di categoria di fasi( ad esempio, è stato modificato Chiudi da 6 a 7). Le opportunità esistenti che sono passate alla fase di chiusura prima di apportare questa modifica continueranno a mostrare lo stesso valore della fase della pipeline che era stato impostato quando sono passate alla fase di chiusura. Tuttavia, le opportunità che passano alla fase di chiusura dopo aver apportato questa modifica useranno la nuova sequenza per la fase di chiusura .

Risoluzione

È possibile risolvere questo problema reimpostando i valori per le opportunità meno recenti modificando la fase del processo aziendale in un'altra fase e quindi riportandolo alla fase Di chiusura oppure aggiornando l'attributo stepname dell'opportunità a livello di codice.

Problema 2 - Valori delle fasi della pipeline da più definizioni di flussi di processo aziendale

Causa

Questa operazione deve essere prevista se si usano più definizioni del processo aziendale per l'entità Opportunity. L'attributo di fase della pipeline viene impostato a ogni modifica di fase nel flusso del processo aziendale del record Opportunità, indipendentemente dal numero di flussi di processo aziendale che sono associati a tale record.

Risoluzione

Se hai più flussi di processo aziendale, considera di aggiungere un campo personalizzato al Processo di Vendita delle Opportunità e di impostare il suo valore in modo programmato per i cambi di fase richiesti nel flusso di processo aziendale per l'opportunità.

Problema 3: l'ordinamento del grafico della pipeline di vendita viene visualizzato in modo diverso nell'interfaccia unificata rispetto al client web legacy.

Il client Web legacy visualizza il grafico usando il valore dell'opzione categoria associata, mentre in Interfaccia unificata le fasi vengono visualizzate alfabeticamente. Poiché le fasi della pipeline sono precedute dall'ordine definito nel set di opzioni categoria Stage , vengono visualizzate in base alla sequenza di opzioni di categoria (1, 2 e così via).

Problema 4 - Le fasi non vengono ordinate numericamente quando il numero di fasi è superiore a 9

Causa

I grafici nell'interfaccia unificata sono ordinati alfabeticamente. Quando si hanno fasi di vendita superiori a 9, ad esempio 10-OnHold, 11-Pipeline, tali fasi vengono visualizzate nel grafico prima di qualsiasi fase che inizia con 2. In altre parole, il grafico esegue il rendering di tutte le fasi con il primo carattere come 1 e quindi visualizza le fasi a partire da 2 e così via.

Risoluzione

Per risolvere questo problema, è necessario configurare un attributo o una colonna personalizzata e popolarla in base ai requisiti del grafico. Per ulteriori informazioni, vedi Come creare e modificare le colonne.