Condividi tramite


Errore durante l'esecuzione di DirSyncConfigShell.psc1 in Windows Server 2008 R2: Impossibile caricare file o assembly

Questo articolo descrive uno scenario in cui viene visualizzato un errore quando si esegue DirSyncConfigShell.psc1 dopo l'installazione della versione 6765.0006 dello strumento di sincronizzazione directory in un computer basato su Windows Server 2008 R2.

Versione originale del prodotto: Microsoft Entra ID, Servizi cloud (ruoli Web/ruoli di lavoro), Microsoft Intune, Backup di Azure, Office 365 Identity Management
Numero KB originale: 2964373

Sintomi

Quando si esegue DirSyncConfigShell.psc1 dopo l'installazione della versione 6765.0006 dello strumento di sincronizzazione di Microsoft Azure Active Directory in un computer basato su Windows Server 2008 R2, viene visualizzato il messaggio di errore seguente:

AVVISO: si sono verificati gli errori seguenti durante il caricamento della console c:\programmi\Windows Azure Active Directory Sync\dirsyncfonfigshell.psc1: Impossibile caricare la configurazione dello snap-in di Windows PowerShell a causa dell'errore seguente: impossibile caricare il file o l'assembly 'file:///c:\programSync\Microsoft Online.Coexistence.PS.Config.dll' o una delle relative dipendenze. Questo assembly viene compilato da un runtime più recente del runtime attualmente caricato e non può essere caricato. Ad esempio, questo problema si verifica quando si esegue DirSyncConfigShell.psc1 per forzare la sincronizzazione della directory.

Causa

Questo problema si verifica se Windows Management Framework 3.0 non è installato nel computer basato su Windows Server 2008 R2.

Risoluzione

Esegui una delle operazioni seguenti:

  • Installare Windows Management Framework 3.0 nel computer basato su Windows Server 2008 R2. Per altre informazioni, vedere Windows Management Framework 3.0.
  • Eseguire lo strumento di sincronizzazione directory da un computer basato su Windows Server 2012 R2. Per installare lo strumento di sincronizzazione directory, vedere Installare o aggiornare lo strumento Di sincronizzazione directory.

Contattaci per ricevere assistenza

In caso di domande o bisogno di assistenza, creare una richiesta di supporto tecnico oppure formula una domanda nel Supporto della community di Azure. È possibile anche inviare un feedback sul prodotto al feedback della community di Azure.