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Questo articolo fornisce una soluzione ai problemi di prestazioni che si verificano quando si lavora con i file che si trovano in un file server.
Numero KB originale: 822219
Sintomi
È possibile che si verifichino uno o più dei sintomi seguenti quando si lavora con i file in rete:
Un file server basato su Windows configurato come file e server di stampa smette di rispondere e la funzionalità del server di stampa e file si arresta temporaneamente.
Si verifica un ritardo imprevisto lungo quando si apre, si salva, si chiude, si eliminano o si stampano file che si trovano in una risorsa condivisa.
Si verifica una riduzione temporanea delle prestazioni quando si usa un programma in rete. Le prestazioni rallentano in genere per circa 40-45 secondi. Tuttavia, alcuni ritardi possono durare fino a 5 minuti.
Si verifica un ritardo quando si eseguono operazioni di copia o backup dei file.
Esplora risorse smette di rispondere quando ci si connette a una risorsa condivisa o viene visualizzata una X rossa nell'unità di rete connessa in Esplora risorse.
Quando si accede al file server, dopo aver digitato il nome e la password nella finestra di dialogo Accedi a Windows , viene visualizzata una schermata vuota. Il desktop non viene visualizzato.
Un programma che utilizza la chiamata rpc (Remote Procedure Call) o usa named pipe per connettersi a un file server smette di rispondere.
Il server smette temporaneamente di rispondere e uno o più messaggi id evento simili ai messaggi seguenti vengono visualizzati nel log di sistema nel file server.
Quando si tenta di connettersi a una risorsa condivisa, viene visualizzato un messaggio di errore simile a uno dei messaggi seguenti:
Messaggio di errore 1
Errore di sistema 53. Impossibile trovare il percorso di rete.
Messaggio di errore 2
Errore di sistema 64. Il nome di rete specificato non è più disponibile.
Si è disconnessi in modo intermittente dalle risorse di rete e non è possibile riconnettersi alle risorse di rete nel file server. Tuttavia, è possibile effettuare il ping del server ed è possibile usare una sessione di Servizi Desktop remoto per connettersi al server.
Se più utenti tentano di accedere ai documenti di Microsoft Office nel server, la finestra di dialogo File è bloccata per la modifica non viene sempre visualizzata quando il secondo utente apre il file.
Una traccia di rete indica un ritardo da 30 a 40 secondi tra un comando client del servizio SMB e una risposta dal file server.
Quando si tenta di aprire un file di database di Access 2.0 (file .mdb) in Microsoft Access 97, in Access 2000 o in Access 2002, è possibile che venga visualizzato un messaggio di errore simile al seguente:
Errore del disco o della rete.
Quando si tenta di aprire un file di Microsoft Word, è possibile che venga visualizzato il seguente messaggio di errore:
Impossibile leggere il file da questo file_name. Ripristinare la connessione di rete o sostituire il disco floppy e riprovare.
Causa
Questo problema può verificarsi se un programma non Microsoft installato nel computer usa un driver di filtro in modalità kernel obsoleto. Il driver di filtro in modalità kernel potrebbe essere obsoleto se le condizioni seguenti sono vere:
Nel computer è installato uno dei programmi seguenti:
L'agente di backup ARCserve per Open Files o ARCserve Open File Agent da Computer Associates International, Inc. è installato nel computer e il driver Ofant.sys per il programma non è aggiornato.
Open Transaction Manager è installato nel computer e il driver Otman.sys per il programma non è aggiornato.
Note
Open Transaction Manager è incluso in determinati programmi di VERITAS Software Corporation, ma può anche essere installato separatamente dal programma VERITAS. Ad esempio, Open Transaction Manager può essere incluso con l'opzione Apri file. Questo programma può essere incluso in VERITAS Backup Exec.
Un programma VERITAS che usa il driver Otman4.sys o Otman5.sys (ad esempio Open File Option) viene installato nel computer e il driver Otman4.sys o Otman5.sys per il programma non è aggiornato.
Il driver per il programma non è compatibile con il driver di filtro installato nel computer da un programma antivirus non Microsoft. Di conseguenza, il driver di filtro nel server potrebbe restituire un codice di stato non corretto al servizio server. Ad esempio, il driver di filtro può restituire un codice STATUS_SUCCESS anziché un codice STATUS_OPLOCK_BREAK_IN_PROGRESS.
Risoluzione
Per risolvere questo problema, contattare il produttore del programma per richiedere la disponibilità di un aggiornamento del driver di filtro. Per ulteriori informazioni su come contattare Gli associati di computer per ottenere l'aggiornamento più recente per il driver Ofant.sys, visitare Computer Associates .For more information about how to contact Computer Associates to obtain the latest update for the Ofant.sys driver, visit Computer Associates.
Se Open Transaction Manager è stato installato separatamente, contattare Columbia Data Products, Inc. per richiedere la disponibilità di un aggiornamento che potrebbe risolvere il problema. Per contattare Columbia Data Products, visitare Columbia Data Products.
Per altre informazioni su come contattare VERITAS, visitare il supporto di VERITAS
Ulteriori informazioni
Importante
In questa sezione, metodo o attività viene illustrata la procedura per modificare il Registro di sistema. Se, tuttavia, si modifica il Registro di sistema in modo errato, possono verificarsi gravi problemi. Pertanto, assicurarsi di osservare attentamente la procedura seguente. Per una maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. Successivamente, è possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e il ripristino del Registro di sistema, vedi Come eseguire il backup e il ripristino del Registro di sistema in Windows.
Per risolvere temporaneamente questo problema, riavviare i servizi server nel server. Per riavviare i servizi server, seguire questa procedura:
Fare clic su Start, quindi scegliere Esegui.
Nella casella Apri digitare cmd e quindi fare clic su OK.
Al prompt dei comandi digitare le righe seguenti e premere INVIO dopo ogni riga:
net stop server net start server
Per risolvere questo problema, usare uno dei metodi seguenti:
Usare i log delle prestazioni e gli avvisi per monitorare il contatore Avg. Disk Queue Length dell'oggetto prestazioni PhysicalDisk . In condizioni normali, il numero di richieste di input/output in attesa (I/O) non è in genere superiore a 1,5 a 2 volte il numero di spindle presenti nel disco fisico. La maggior parte dei dischi ha uno spindle, anche se la matrice ridondante di dispositivi RAID (Independent Disks) in genere ha più di un spindle. Quando un programma esegue piccole operazioni di I/O successive, viene visualizzato un picco nel contatore Lunghezza coda disco corrente quando vengono accodate operazioni di I/O. È anche possibile che venga visualizzato un aumento del contatore Commutatori di contesto/sec dell'oggetto prestazioni di sistema .
Disabilitare il blocco opportunistico sul client o sul server. Per disabilitare il blocco opportunistico nel client, impostare il valore del Registro di sistema seguente su 1:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MRXSmb\Parameters\OplocksDisabled
Per disabilitare il blocco opportunistico nel server, impostare il valore del Registro di sistema seguente su 0:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\EnableOplocks
Per altre informazioni su come disabilitare il blocco opportunistico, vedere Configurazione del blocco opportunistico in Windows.
Modificare il Registro di sistema per disattivare temporaneamente il driver di filtro.
Per altre informazioni su come disattivare temporaneamente il driver di filtro in modalità kernel, vedere Come disattivare temporaneamente il driver di filtro in modalità kernel in Windows.
La chiave del Registro di sistema che archivia le informazioni per il driver Ofant.sys è Ofadriver.
Riferimenti
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