Condividi tramite


Logo di Visual Studio Note sulla versione di Visual Studio 2022 Preview

Versione 17.11 Preview 2

Data di rilascio: 11 giugno 2024

Questa versione è incentrata sui miglioramenti qualitativi della vita per tutti gli sviluppatori e i carichi di lavoro. Quando si usa Visual Studio, ci si vuole sentire autonomi e produttivi. Ecco perché le caratteristiche di qualità della vita sono così importanti: rendono la codifica un'esperienza fluida e piacevole, senza inutili problemi e mal di testa. Speriamo che ti piacerà questo aggiornamento.

Produttività Dalla community
Trovare il codice desiderato perl'anteprima 1 Ticket di feedback
Revisionidel codice più significative Preview 1 Ticket di feedback
Richieste pull con bozze e modelliPreview 1 Ticket di feedback
Tasti di scelta rapidafamiliari Anteprima 1 Ticket di feedback
GitHub Copilot Dalla community
GitHub Copilot sta ottenendo un'anteprima più intelligente2
Denominazione degli elementi semplificatiin Anteprima 2
Espressioni dei punti di interruzionegenerate dall'intelligenza artificiale (anteprima 2)
Debug e diagnostica Dalla community
Correzione più semplice delle eccezioni asincronePreview 1 Ticket di feedback
Profilatura più veloce e coerentedell'anteprima 1
Profila codice esterno con facilitàAnteprima 1 Ticket di feedback
Miglioramento del debug in Arm64Preview 2
Debug di Blazor WebAssemblyPreview 2
Punti di interruzioneC++ più veloci Preview 2
Aggiungere automaticamente punti di interruzione al gruppopredefinito Preview 2
VisualizzatoreIEnumerable Espressivo Anteprima 2
IDE Dalla community
Non perdere mai l'installazione di un componentePreview 1 Ticket di feedback
Rimanere aggiornati e sicuriPreview 2 Ticket di feedback
Autenticazione utentemigliorata Preview 1
Web Dalla community
Individuare le routedinamiche dell'API Web Preview 2 Ticket di feedback
Pacchetti NPM in Esplora soluzioni Prima 1
Giochi Dalla community
Build Insights QoL UpdatePreview 2
Unreal Engine Add Class TemplatesPreview 1 Ticket di feedback
Unreal Engine Add ModulePreview 2 Ticket di feedback
Barra degli strumentiunreal Engine Preview 1
.NET Dalla community
Aggiornamento di Esplora risorse(anteprima 2) Ticket di feedback
C++ Dalla community
Eseguire il debug dei progetti CMake in LinuxPreview 1 Ticket di feedback
Correzioni di bug principali Dalla community
Copia/incolla avanzata del codice sorgente C# in Office non riesce Preview 1 Ticket di feedback
Errore errato con puntatore in classe alla variabile membro Preview 1 Ticket di feedback
Ottimizzazione del tipo di commutatori di spostamento dei bit a destra da signed a unsigned Preview 1 Ticket di feedback
Indicizzare i limiti esterni quando si passa al ramo di anteprima 1 Ticket di feedback
Falsi positivi per l'avviso C26434 (analisi del codice) Anteprima 1 Ticket di feedback
Visualizzazioni parziali di std::variant nel debugger Preview 1 Ticket di feedback
MSVC v19.37+ generazione di codice non corretta per le espressioni aritmetiche Preview 2 Ticket di feedback
C4506 (nessuna definizione per la funzione inline) segnalata erroneamente per la specifica del modello... Anteprima 2 Ticket di feedback
Overload dei tipi integrali mancanti per le funzioni cmath Preview 2 Ticket di feedback

Nota

Vedere l'elenco completo di tutte le richieste di funzionalità segnalate dall'utente e le correzioni di bug apportate in questa versione.

Produttività

Trovare il codice desiderato per l'anteprima 1

Restringere una ricerca di codice dall'intera soluzione al documento corrente o al progetto corrente.

Ti senti mai come se vedessi troppi risultati nella ricerca di codice? Restringere lo stato attivo con le opzioni di ambito appena aggiunte in Ricerca codice.

Per l'esperienza di ricerca del codice predefinita e ogni filtro, è ora possibile impostare l'ambito su Intera soluzione, Progetto corrente o Documento corrente e attivare o disattivare l'inclusione di file esterni.

È possibile impostare ambiti diversi per filtri diversi. Ad esempio, l'esperienza predefinita può essere impostata per esaminare l'intera soluzione e i membri possono essere impostati per esaminare solo il documento corrente. Le selezioni verranno mantenute oltre la sessione corrente.

Definizione dell'ambito di ricerca all-in-one

Nota

Questa funzionalità deve essere abilitata in Strumenti -> Gestire le funzionalità di anteprima

📣Vedere il ticket di funzionalità per condividere il feedback e continuare la conversazione.

Revisioni del codice più significative Preview 1

Visualizzare i commenti delle richieste pull di Azure DevOps e GitHub direttamente nel file di lavoro.

È stato semplificato visualizzare i commenti delle richieste pull di GitHub e Azure DevOps direttamente nel file di lavoro in Visual Studio. È ora possibile rimanere nel contesto, apportare le modifiche al codice necessarie e interagire con i suggerimenti dei colleghi senza cambiare contesto nel browser.

Nuovi miglioramenti

Abilitare il flag di funzionalità, i commenti della richiesta pull, eseguire il checkout di qualsiasi ramo con un ramo di richiesta pull attivo e fare clic su Mostra commenti nei file in InfoBar.

Visualizzare la notifica dei commenti delle richieste pull

I miglioramenti più recenti includono un supporto migliore per @ menzioni e riferimenti agli elementi di lavoro, miglioramenti visivi al margine di attenzione e commento, l'aggiunta di avatar, una migliore sincronizzazione con il server e un punto di ingresso aggiuntivo nella finestra modifiche git.

Nota

Questa funzionalità deve essere abilitata in Strumenti -> Gestire le funzionalità di anteprima

📣Vedere il ticket di funzionalità per condividere il feedback e continuare la conversazione.E prendi questo sondaggio per migliorare ulteriormente la funzionalità.

Richieste pull con bozze e modelli Preview 1

Creare bozze di richieste pull e avviare le descrizioni con i modelli in Visual Studio.

È ora possibile creare bozze di richiesta pull e avviare le descrizioni con i modelli GitHub in Visual Studio. Si tratta delle due richieste principali per la creazione di un'esperienza di richiesta pull.

Richieste pull bozza

Usare il menu a discesa nel pulsante Crea per Crea come bozza.

Opzione Crea bozza richieste pull

Modelli di richiesta pull

Il modello di richiesta pull predefinito verrà usato quando si crea una nuova richiesta pull per GitHub e Azure DevOps. Altre informazioni su come aggiungere un modello di richiesta pull al repository nella documentazione di GitHub e nella documentazione di Azure DevOps.

Nota

Questa funzionalità deve essere abilitata in Strumenti -> Gestire le funzionalità di anteprima

📣Vedere il ticket di funzionalità per condividere il feedback e continuare la conversazione.E prendi questo sondaggio per migliorare ulteriormente la funzionalità.

Tasti di scelta rapida familiari Anteprima 1

Alcuni tasti di scelta rapida comuni corrispondono ora a quelli in altri IDE popolari.

Quando ci si sposta tra diversi IDE ed editor, può essere frustrante dover imparare di nuovo i tasti di scelta rapida. Sono state apportate alcune modifiche ad alcuni tasti di scelta rapida predefiniti per renderli più familiari e per preservare la memoria muscolare.

Attiva/Disattiva commenti per la riga

È stato possibile attivare o disattivare i commenti per la riga in Visual Studio per molto tempo, ma i tasti di scelta rapida predefiniti erano Ctrl+K, Ctrl+/. Sono stati ora aggiunti Ctrl+/ come tasti di scelta rapida alternativi, che corrispondono all'impostazione predefinita in molti altri IDE ed editor.

Attiva/Disattiva commenti per la riga

Apri il riquadro comandi

O Ricerca funzionalità, come viene chiamato in Visual Studio. I tasti di scelta rapida predefiniti per questa funzionalità sono ora Ctrl+Shift+P, che dovrebbero essere familiari agli utenti di VS Code per aprire il riquadro comandi.

Ricerca funzionalità

📣Vedere il ticket di funzionalità per condividere il feedback e continuare la conversazione.

GitHub Copilot

GitHub Copilot sta ottenendo un'anteprima più intelligente 2

GitHub Copilot include ora il contesto dall'intero repository e può eseguire ricerche nel Web

I sottoscrittori di GitHub Copilot Enterprise in Visual Studio ora possono usare GitHub Copilot Chat per ottenere risposte arricchite con il contesto dall'intero repository e dai risultati della ricerca Bing.

Ottenere risposte dall'intera codebase

GitHub Copilot Chat può ora rispondere a domande con la comprensione del repository completo, non solo le schede aperte. Indicizzare il repository in GitHub.com e quindi porre una domanda che indica @github. È possibile porre domande come @github dove viene implementata la limitazione della frequenza?

Cercare con il contesto del Web

La chat di GitHub Copilot può anche cercare in Bing per trovare informazioni al di fuori della conoscenza generale o della codebase. Quando si menziona @github, Github Copilot deciderà in modo intelligente quando usare Bing. È possibile porre domande come @github qual è la versione LTS più recente di Node.js?

La ricerca Bing è disponibile solo se abilitata da un amministratore. Per altri dettagli, vedere Abilitazione delle funzionalità di GitHub Copilot Enterprise o leggere la documentazione.

Denominazione degli elementi semplificati in Anteprima 2

È possibile usare GitHub Copilot per generare suggerimenti di denominazione per gli identificatori in C++.

GitHub Copilot può ora generare suggerimenti di denominazione per gli identificatori (variabili, metodi o classi) in base al modo in cui viene usato l'identificatore e lo stile del codice.

Rinominare i suggerimenti

Per provarlo, è necessaria una sottoscrizione di GitHub Copilot attiva. Passare a qualsiasi variabile da rinominare, fare clic con il pulsante destro del mouse su ->Rename (Tastiera: Ctrl+R, Ctrl+R). Si noterà un'icona sparkle di GitHub Copilot che è possibile fare clic o attivare/disattivare per generare suggerimenti di denominazione.

Questa funzionalità è disponibile per C#, C++ e altri linguaggi.

Espressioni dei punti di interruzione generate dall'intelligenza artificiale (anteprima 2)

Usare espressioni generate dall'intelligenza artificiale per inserire punti di interruzione condizionali o punti di traccia in C++.

Le espressioni generate dall'intelligenza artificiale per punti di interruzione condizionali e punti di traccia sono ora supportate in C++. GitHub Copilot analizza il codice e offre espressioni di punti di interruzione dettagliate, semplificando il processo di debug.

CPP per i suggerimenti per i punti di interruzione di intelligenza artificiale

Quando si posiziona il cursore all'interno del testo della condizione per un punto di interruzione condizionale/punto di analisi nella finestra delle impostazioni del punto di interruzione, GitHub Copilot offrirà immediatamente suggerimenti di espressioni generate dall'intelligenza artificiale in base alla codebase. È possibile selezionare la condizione più adatta alle proprie esigenze per l'inserimento del punto di interruzione condizionale o del punto di analisi.

Debug e diagnostica

Correzione più semplice delle eccezioni asincrone Preview 1

Il debugger si interrompe ora sulle eccezioni del metodo asincrono rilevate dal codice framework.

Il debug di codice asincrono, in particolare nei framework come ASP.NET, può essere complicato a causa del rischio che le eccezioni vengano generate attraverso limiti asincroni.

Ora, con Il debugger di Visual Studio si interrompe automaticamente quando un async Task metodo genera un'eccezione al codice del framework.

Interruzione in eccezioni asincrone

In questo modo è possibile identificare e diagnosticare facilmente i problemi nelle applicazioni ASP.NET, con conseguente maggiore velocità dei cicli di debug e una maggiore produttività.

Si noti che si tratta solo di progetti .NET 9 e più recenti.

📣Vedere il ticket di funzionalità per condividere il feedback e continuare la conversazione.

Profilatura più veloce e coerente dell'anteprima 1

Lo strumento di strumentazione nel profiler ora memorizza la selezione di destinazione tra le esecuzioni.

Lo strumento di strumentazione mantiene ora la selezione di destinazione tra le esecuzioni offrendo un vantaggio significativo migliorando la continuità delle sessioni di profilatura.

Con questo miglioramento, è possibile mantenere la destinazione specificata in più esecuzioni di strumentazione, eliminando la necessità di attività di selezione ripetitive.

La destinazione di strumentazione persiste

Profila codice esterno con facilità Anteprima 1

Il profiler supporta la decompilazione automatica per le librerie .NET, consentendo una semplice profilatura del codice esterno.

Il profiler di Visual Studio offre ora la decompilazione automatica per le librerie .NET negli scenari in cui il codice sorgente non è disponibile. Grazie alla decompilazione automatica del codice durante la ricerca dell'origine, anche senza simboli caricati o percorsi di file esatti, è possibile ottenere informazioni dettagliate sulla struttura e sui problemi di prestazioni del codice.

Decompilazione dell'origine del profiler

Questa funzionalità è particolarmente vantaggiosa quando si tratta di codice esterno non utente, poiché consente di analizzare e ottimizzare le prestazioni dell'applicazione in modo efficace, migliorando così il flusso di lavoro di sviluppo.

📣Vedere il ticket di funzionalità per condividere il feedback e continuare la conversazione.

Miglioramento del debug in Arm64 Preview 2

Il debugger di Visual Studio supporta le applicazioni AnyCPU manifestate per l'esecuzione come arm64.

Visual Studio supporta in modo nativo la compilazione e il debug di app Arm64 nei processori basati su Arm. Sfortunatamente, le applicazioni compilate con l'impostazione AnyCPU in esecuzione in un computer Arm64, per impostazione predefinita usano l'emulazione x64. Anche se le funzionalità dell'emulatore x64 sono state espanse, gli scenari di CPU Arm più efficienti sono supportati quando le applicazioni vengono eseguite in modo nativo.

Per supportare meglio il comportamento nativo previsto, l'aggiornamento di Windows 24H2 introduce una nuova <impostazione supportataArchitectures> per i file manifesto dell'app. Gli sviluppatori .NET possono includere un elenco di architetture supportate (amd64 o arm64), segnalando in modo esplicito che un'applicazione compilata con l'impostazione AnyCPU deve essere eseguita in modo nativo usando ARM64 CLR nei dispositivi Arm64.

Con questa versione Visual Studio può leggere queste nuove voci di manifesto all'avvio dell'applicazione, consentendo l'avvio del debug in base all'architettura corretta.

Debug di Blazor WebAssembly Preview 2

Anteprima dell'esperienza di debug migliorata per le app WebAssembly Blazor destinate a .NET 9 o versione successiva.

Visual Studio offre ora un'anteprima di un'esperienza di debug migliorata per le app WebAssembly Blazor destinate a .NET 9 o versione successiva:

  • I tipi di dati visualizzati nel debugger corrispondono ora ai tipi di dati .NET previsti.
  • I membri del tipo e la visibilità dei membri usano le icone previste.
  • Lo stack di chiamate visualizzato viene pulito per visualizzare solo lo stack di chiamate .NET e rispetta correttamente l'impostazione Just My Code.
  • La finestra moduli è ora supportata.
  • Il supporto della valutazione delle espressioni nella finestra Immediata e per gli orologi e i punti di interruzione condizionali viene espanso e migliorato.

Miglioramenti al debug di Blazor

Per abilitare la nuova esperienza di debug in anteprima:

  • Abilitare l'impostazione Abilita nuovo debugger .NET 8+ Mono (anteprima).
  • Installare la versione più recente di .NET 9 SDK.
  • Aggiornare l'app Blazor in modo che sia destinato a .NET 9.

Limitazioni note:

  • Ricaricamento rapido durante il debug non è ancora completamente funzionante. Verrà risolto in un aggiornamento futuro.

Punti di interruzione C++ più veloci Preview 2

Ottimizzare il debug con prestazioni avanzate dei punti di interruzione condizionali in C++

Le prestazioni dei punti di interruzione condizionale in C++ sono state notevolmente migliorate tramite un'implementazione rielaborata.

A partire dalla versione 17.10, la valutazione iniziale rivela almeno un miglioramento delle prestazioni del 70%, riducendo il tempo di esecuzione da 80 secondi a 21 secondi oltre 80.000 iterazioni.

Prestazioni del punto di interruzione condizionale C++

Come illustrato nel video, il lato sinistro mostra le prestazioni dei punti di interruzione condizionali nella versione 17.9, mentre il lato destro mostra le prestazioni nella versione 17.10 e successive.

Aggiungere automaticamente punti di interruzione al gruppo predefinito Preview 2

Organizzare i punti di interruzione per la risoluzione dei problemi rapidi con i gruppi di punti di interruzione predefiniti in Visual Studio.

È ora possibile contrassegnare il gruppo di punti di interruzione selezionato come predefinito, assicurandosi che tutti i punti di interruzione appena aggiunti vengano inclusi automaticamente in tale gruppo.

Gruppo di punti di interruzione predefinito

Questo miglioramento semplifica la gestione e l'organizzazione dei punti di interruzione, offrendo un debug semplice durante l'analisi di più problemi.

Visualizzatore IEnumerable Espressivo Anteprima 2

La funzionalità di espressione modificabile nel visualizzatore IEnumerable consente la modifica diretta e la visualizzazione dell'espressione LINQ nel debugger di Visual Studio.

Il debugger di Visual Studio offre ora una funzionalità di espressione modificabile nel IEnumerable visualizzatore, un potente miglioramento per gli sviluppatori che usano le raccolte.

Panoramica

Con questa nuova funzionalità, durante la visualizzazione di una raccolta o di un set di dati, è possibile modificare direttamente la casella di testo delle espressioni nella parte superiore della finestra di dialogo con le espressioni LINQ desiderate. Il visualizzatore viene aggiornato in tempo reale, riflettendo la modifica dei dati risultante dalla query.

Casella di testo Espressione modificabile

Potenziali applicazioni

La funzionalità di espressione modificabile facilita il debug di set di dati densi e manipolazioni complesse della raccolta. È possibile applicare facilmente diversi filtri o ordinare gli ordini alle raccolte in base alle esigenze. Sperimentando trasformazioni e filtri dei dati direttamente all'interno del debugger di Visual Studio, è possibile semplificare il flusso di lavoro di sviluppo e ottenere un debug più efficiente. Ecco un esempio per provare autonomamente:

Esempio di casella di testo Editable Expression

IDE

Non perdere mai l'installazione di un componente Preview 1

Usando i file *.vsconfig, è possibile assicurarsi che il team disponga di tutti i componenti e le estensioni necessari installati dalla soluzione.

Molti team usano file *.vsconfig per standardizzare le installazioni di Visual Studio dei team. I file *.vsconfig possono essere inseriti in un repository o nella directory della soluzione di un progetto e Visual Studio rileverà automaticamente se i componenti specificati nel file *.vsconfig sono mancanti.

Estensione privata in .vsconfig

Se mancano, verrà visualizzata una notifica, ad esempio quella mostrata di seguito.

InfoBar in Esplora soluzioni che richiede di installare componenti e estensioni mancanti

Sono stati apportati due miglioramenti a questa esperienza in Visual Studio 2022 versione 17.11 Preview 1.

  1. Prima di tutto, Visual Studio è in grado di rilevare se mancano estensioni ospitate in locale o in rete dall'installazione e, in tal caso, verrà richiesto di installarle. In precedenza, rispetto alle estensioni, Visual Studio era in grado di riconoscere solo se mancavano le estensioni del Marketplace.
  2. In secondo luogo, Visual Studio richiederà nuovamente la notifica in determinate situazioni, ad esempio se il file *.vsconfig è stato modificato perché vengono aggiunti nuovi componenti o estensioni. In precedenza, la notifica veniva visualizzata solo fino a quando non hai agito su di esso, a quel punto sarebbe stata soppressa per sempre.

📣Vedere il ticket di funzionalità per condividere il feedback e continuare la conversazione.

Rimanere aggiornati e sicuri Preview 2

Mantenere Visual Studio aggiornato e sicuro eseguendo la registrazione in Microsoft Updates.

Mantenere il software aggiornato con cadenza regolare è una procedura consigliata per garantire la sicurezza.

Gli aggiornamenti della sicurezza di Visual Studio saranno disponibili per tutti i singoli utenti tramite il canale Microsoft Update, che fa parte del sistema Windows Update. Gli utenti che si registrano in questo modulo riceveranno e installeranno automaticamente gli aggiornamenti della sicurezza mensili di Visual Studio in modo invisibile all'utente e in background quando il computer è inattivo, semplificando così l'aggiornamento e la sicurezza.

È possibile visualizzare in anteprima questa esperienza con Visual Studio 2022 a partire da giugno 2024 attivando l'opzione Ricevi aggiornamenti per altri prodotti Microsoft nell'interfaccia utente di Windows Update e abilitando la chiave del Registro di sistema PreviewAutomaticUpdates. Dopo aver scelto questa esperienza, se è installato Visual Studio 2022 versione 17.9 o precedente, il sistema di aggiornamento di Windows fornirà e installerà automaticamente la versione di sicurezza mensile più recente di Visual Studio. Altri dettagli sono disponibili qui.

Windows Update - Opzioni avanzate

Questa funzionalità è un'estensione della soluzione di aggiornamenti dell'amministratore, progettata per aiutare le organizzazioni a garantire la sicurezza. Molte aziende, tra cui Microsoft, usano questa soluzione per distribuire automaticamente centinaia di migliaia di aggiornamenti della sicurezza ogni mese.

📣Vedere il ticket di funzionalità per condividere il feedback e continuare la conversazione.

Autenticazione utente migliorata Preview 1

Visual Studio usa ora il broker autenticazione di Windows altrimenti noto come WAM come meccanismo di autenticazione predefinito.

Visual Studio ora usa il Web Account Manager (WAM) come meccanismo di autenticazione principale. Questa integrazione non solo semplifica l'esperienza di autenticazione per Visual Studio, ma migliora anche la sicurezza delle credenziali.

Ecco come si presenta la nuova esperienza WAM:

Finestra di dialogo Seleziona account WAM che mostra gli account Windows disponibili

In che modo questo influisce sulla tua esperienza?

L'uso di WAM come esperienza di autenticazione predefinita offre molti vantaggi, tra cui:

  • l'integrazione di Windows: oltre a ridurre il numero complessivo di richieste di autenticazione, è ora possibile selezionare gli account Windows esistenti anziché immettere ripetutamente le credenziali.
  • Migliore protezione dei token: i token di aggiornamento sono protetti meglio in quanto ora sono associati al dispositivo.
  • Supporto per le funzionalità di sicurezza più recenti:
    • Sfrutta le funzionalità avanzate del sistema operativo come le chiavi Windows Hello e FIDO.
    • Accedi alle funzionalità più recenti e più avanzate di Microsoft Entra ID e ai criteri di accesso condizionale.

Web

Individuare le route dinamiche dell'API Web Preview 2

Esplora endpoint è stato aggiornato per individuare gli endpoint in fase di esecuzione.

Quando si usano ASP.NET API Web core, è possibile usare Esplora endpoint per visualizzare e interagire con gli endpoint.

Esplora endpoint individua gli endpoint in modo statico per visualizzare il set iniziale di endpoint. Esistono alcuni endpoint che non possono essere individuati in modo statico. Ad esempio, qualsiasi endpoint definito in un progetto di libreria di classi è un esempio. Esistono altri modi per registrare gli endpoint che non possono essere individuati in modo statico.

Quando si esegue o si esegue il debug dell'API Web, Visual Studio individua anche le route in fase di esecuzione e le aggiunge a Esplora endpoint.

Esplora endpoint

📣Vedere il ticket di funzionalità per condividere il feedback e continuare la conversazione.

Pacchetti NPM in Esplora soluzioni Preview 1

Vedere i pacchetti NPM visualizzati nel nodo Dipendenze in Esplora soluzioni.

Sono state unificate le esperienze NPM disponibili nei progetti ASP.NET e JavaScript e TypeScript. Anche i pacchetti NPM verranno quindi elencati in Esplora soluzioni per progetti JavaScript e TypeScript.

Pacchetti NPM in Esplora soluzioni

Questa è la stessa esperienza che si ottiene per NuGet, ma è disponibile ora anche per NPM.

Giochi

Build Insights QoL Update Preview 2

Aggiunge vari miglioramenti della qualità della vita a C++ Build Insights.

In questo aggiornamento sono state aggiunte modifiche di qualità della vita all'integrazione di Build Insights per C++. È ora possibile filtrare i risultati della traccia di Informazioni dettagliate di compilazione in base al progetto. Per i risultati in ogni riga, verrà ora visualizzato il percorso relativo e il nome del file anziché il percorso completo. È stato migliorato anche il raggruppamento dei risultati nella visualizzazione File inclusi.

Build Insights QoL Update

Unreal Engine Add Class Templates Preview 1

Aggiungere modelli di classe unreal Engine comuni al progetto con la nuova aggiungi classe.

Quando si modifica direttamente un progetto unreal Engine, è ora possibile aggiungere altri modelli di classe unreal Engine comuni al progetto con la nuova finestra di dialogo Aggiungi classe . Questa finestra di dialogo fornisce un elenco di modelli di classe unreal Engine comuni che è possibile aggiungere al progetto. È anche possibile aggiungere la classe a un modulo scelto.

Per iniziare, fare clic con il pulsante destro del mouse sul progetto in Esplora soluzioni e selezionare Aggiungi classe del motore unreal>. Nella finestra di dialogo Aggiungi nuovo elemento selezionare Unreal Engine Class (Classe motore unreal) per aprire la finestra di dialogo Aggiungi classe.

Aggiungi classe del motore Unreal

📣Vedere il ticket di funzionalità per condividere il feedback e continuare la conversazione.

Unreal Engine Add Module Preview 2

Aggiungere moduli unreal Engine al progetto con il nuovo modulo Aggiungi modulo.

È ora possibile aggiungere moduli Unreal Engine al progetto con la nuova finestra di dialogo Aggiungi modulo .

Per iniziare, fare clic con il pulsante destro del mouse sul progetto in Esplora soluzioni e selezionare Aggiungi modulo motore unreal>. Nella finestra di dialogo Aggiungi nuovo elemento selezionare Modulo motore Unreal vuoto per aprire la finestra di dialogo Aggiungi modulo .

Aggiungi classe del motore Unreal

📣Vedere il ticket di funzionalità per condividere il feedback e continuare la conversazione.

Barra degli strumenti unreal Engine Preview 1

Accedere rapidamente alle azioni correlate a Unreal Engine tramite una barra degli strumenti dedicata.

La nuova barra degli strumenti di Unreal Engine consente di accedere rapidamente alle azioni correlate al motore Unreal. La barra degli strumenti è disponibile quando si dispone di un progetto Unreal Engine caricato in Visual Studio. La barra degli strumenti include le azioni seguenti:

  1. Collegamento rapido ai processi del motore Unreal
  2. Ripetere l'analisi della cache dei progetti
  3. Accesso rapido al log del motore unreal
  4. Pagina di configurazione del motore unreal di accesso rapido per Visual Studio

Barra degli strumenti di Unreal Engine

.NET

Aggiornamento di Esplora risorse (anteprima 2)

Il nuovo Esplora risorse rende più semplice che mai gestire i file resx in .NET.

In questa versione di Visual Studio viene introdotto un'interfaccia utente di Esplora risorse rinnovata per soddisfare meglio le esigenze dello sviluppatore .NET moderno.

In questo aggiornamento sono stati apportati i miglioramenti seguenti:

  1. Visualizzazione delle risorse muti: è ora possibile caricare più file e visualizzare tutte le localizzazioni contemporaneamente all'interno della stessa visualizzazione.
  2. Ricerca e filtro: è stata aggiunta la ricerca per trovare risorse in soluzioni di grandi dimensioni.
  3. Commenti: ogni traduzione di una risorsa ha ora un proprio commento, tutti visibili contemporaneamente nella griglia dei dati. Cercare l'icona a forma di triangolo piccolo nell'angolo di ogni cella con un commento.
  4. Avvisi: convalida segnaposto e avvisi di traduzione mancanti.
  5. Accessibilità e interfaccia utente: è stata migliorata la compatibilità con le utilità per la lettura dello schermo e la tecnologia di assistive technology, è stata aggiunta la funzionalità di zoom alla griglia dei dati e ora è possibile usare Vs Theming per l'editor (inclusa la modalità scura).

Miglioramento di Datagrid

📣Vedere il ticket di funzionalità per condividere il feedback e continuare la conversazione.E prendi questo sondaggio per migliorare ulteriormente la funzionalità.

C++

Eseguire il debug dei progetti CMake in Linux Preview 1

Eseguire il debug degli script CMake per i progetti destinati a Linux usando WSL e SSH.

È stato aggiunto il supporto per il debugger CMake nei progetti CMake destinati a Linux tramite WSL o SSH. Il debugger CMake consente di eseguire il debug degli script CMake e dei file CMakeLists.txt tramite il debugger di Visual Studio.

Per avviare una sessione di debug di CMake, impostare un punto di interruzione nel file CMakeLists.txt e quindi passare a Project > Configure Cache with CMake Debugging (Configura cache con debug CMake).

CMake debugger Linux

📣Vedere il ticket di funzionalità per condividere il feedback e continuare la conversazione.



Suggerimento

Se sono presenti funzionalità che si desidera visualizzare negli aggiornamenti futuri di Visual Studio, inviare un ticket di funzionalità.

Nota

La roadmap illustra le priorità e la direzione per il futuro di Visual Studio, quindi assicurarsi di controllarla.

Da tutti noi del team, grazie per aver scelto Visual Studio. In caso di domande, contattare Microsoft su Twitter o Developer Community.

Buona codifica!
Team di Visual Studio