この記事は、Microsoft Office Outlook 用 Microsoft Dynamics CRMを構成しようとしたときに発生する問題を解決するのに役立ちます。
適用対象: Microsoft Dynamics CRM 2016、Dynamics CRM 2015、Dynamics CRM 2013、Microsoft Dynamics CRM 2011
元の KB 番号: 3183901
症状
Microsoft Office Outlook 用 Microsoft Dynamics CRMを構成しようとすると、次のエラーが表示されます。
Microsoft Dynamics CRM サーバーとの通信に問題があります。 サーバーが使用不可になっている可能性があります。 後でもう一度試してみてください。 この問題が解決しない場合は、システム管理者にお問い合わせください。
Error.AspNetInstallPath.Exception at Microsoft.Crm.Application.Outlook.Config.ConfigInfo.GetAspDotNetPath() at Microsoft.Crm.Application.Outlook.Config.GlobalRepositoryConfigurator.SetLaptopClientRegistryValues() at Microsoft.Crm.Application.Outlook.Config.GlobalRepositoryConfigurator.SetConfigurationRegistryValuesAction() at Microsoft.Crm.Application.Outlook.Config.GlobalRepositoryConfigurator.Configure(IProgressEventHandler progressEventHandler) at Microsoft.Crm.Application.Outlook.Config.ConfigEngine.Configure(Object stateInfo)
原因
このエラーは、Microsoft .NET Framework のインストールに問題がある場合に発生する可能性があります。
解決方法
オプション 1
Microsoft .NET Framework 修復ツールをダウンロードして実行します。
オプション 2 (Windows 8 以降)
.NET Framework をアンインストールして再インストールします。
注記
CRM 2013 for Outlook では、.NET Framework 4 以降が使用されます。 CRM 2015 for Outlook では、.NET Framework 4.5 以降が使用されます。 CRM 2016 for Outlook では、.NET Framework 4.5.2 以降が使用されます。
- コントロール パネルにアクセスし、プログラムのアンインストール (プログラムと機能)を開きます。
- [Windows の機能の有効化または無効化] を選択します。
- .NET Framework の選択を削除し、 OK をクリックします。
- [閉じる] をクリックします。
- [Windows の機能の有効化または無効化] を選択します。
- .NET Framework とその下の ASP.NET オプションも有効にします。
- [OK] をクリックします。
オプション 3 (Windows 7)
プログラムの追加と削除内で .NET Framework を修復します。
- コントロール パネルにアクセスし、プログラムのアンインストール (プログラムと機能)を開きます。
- Microsoft .NET Framework を選択し、 Uninstall/Change をクリックします。
- Repair オプションを選択し、[次へ] をクリック。