Email ルーターがアクセス許可のために Microsoft Dynamics から電子メールを送信できない

この記事では、Email ルーターがアクセス許可のために Microsoft Dynamics から電子メールを送信できない問題の解決策について説明します。

適用対象:Microsoft Dynamics 365 Customer Engagement Online
元の KB 番号: 4494727

現象

Dynamics 365 Emailルーターを使用してDynamics 365インスタンスから電子メールを送信する場合、電子メールは保留中の送信状態になり、実際には送信されないことがあります。

[保留中の送信] 状態の電子メールを示すスクリーンショット。

Dynamics Email Router の例外ログには、次のエラーが表示される場合があります。

処理する送信電子メール メッセージのチェック中にエラーが発生しました: https://disco.crm.dynamics.com/\<OrgName>。 System.ServiceModel.FaultException'1[Microsoft.Xrm.Sdk.OrganizationServiceFault]: ユーザーに send-as 権限がありません。 (エラーの詳細は例外の詳細と等しくなります。

ErrorCode: 0x8004480D
メッセージ: ユーザーに送信権限がありません。

原因

この動作は、Dynamics 365 アプリケーションの以前のバージョンでこれらのアクセス許可を必要とせずに機能している可能性があります。 バージョン 8.2.2 および 9.x の特定のイテレーションでセキュリティ モデルに変更が導入されたため、電子メール ルーターが別のユーザーの電子メールを送信するには、これらのアクセス許可を明示的に付与する必要があります。

解決方法

このメールを送信するユーザーは、個人用オプションで他の Dynamics ユーザーから電子メールを送信できるようにする必要があります。

[他の Microsoft Dynamics 365 ユーザーに代理で電子メールを送信できるようにする] オプションを選択するスクリーンショット。

アカウントがEmailルーターで使用されている場合は、Dynamics 内の [別のユーザー] アクセス許可として [送信] Emailも必要です。

[別のユーザーとしてEmailを送信する] アクセス許可のスクリーンショット。

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