Databricks ノートブックの形式を管理する

既定では、Databricks のノートブックは .ipynb (IPython または Jupyter) 形式で作成されます。 代わりにソース形式を使用することもできます。

引き続き、さまざまな形式でノートブックをインポートおよびエクスポートできます。 Databricks ノートブックのインポートとエクスポートを参照してください。

ノートブックの形式

Databricks では、IPYNB (既定) とソースの 2 つの形式でノートブックの作成と編集がサポートされています。

Git フォルダーを使用して、ノートブックを含むソース ファイルを管理できます。 Git フォルダーでは、特定 の Databricks アセットの種類 のみがサポートされています。 この形式は、次の表に示すように、ノートブックをリモート リポジトリにコミットする方法に影響します。

ノートブックのソース形式 説明
ソース ソース コードのみをキャプチャする基本的な形式。 .py、 .scala、 .r 、 .sqlなどのコード言語を通知するサフィックスが付いています。
IPYNB (ジュピター) ソース コード、ノートブック環境、視覚化定義、ノートブック ウィジェット、およびオプションの出力をキャプチャする豊富な形式。 IPYNB ノートブックには、Databricks ノートブックでサポートされている任意の言語のコードを含めることができます (pyの.ipynb部分に関わらず)。 IPYNB 形式を使用すると、必要に応じてノートブックと共にノートブックの出力をバージョン管理できます。

IPYNB 形式では、リモート Git リポジトリ上の Databricks ノートブックの表示エクスペリエンスも向上します。 GitHub や GitLab をご利用の場合、プル要求内のノートブックの差分表示機能を強化する機能を有効にできます。これにより、ノートブックの変更内容の確認やコード レビューがより簡単になります。

IPYNB ノートブックのリッチ diff の GitHub サポートの詳細については、「Feature Preview: Rich Jupyter Notebook Diffs」(機能プレビュー: Jupyter Notebook のリッチ diff) を参照してください。 IPYNB ノートブックの差分に対する GitLab サポートの詳細については、Jupyter Notebook ファイルを参照してください。

ソース形式のノートブックを通常のPython、Scala、SQL ファイルと区別するために、Azure Databricksはコメント "Databricks notebook source" を Python、Scala、SQL ノートブックの先頭に追加します。 このコメントは、Azure Databricksがスクリプト ファイルではなくノートブックとしてファイルを正しく解析することを保証します。

ノートブックの既定の形式設定を変更する

IPYNB ノートブックは、Azure Databricksで新しいノートブックを作成するときの既定の形式です。

既定値を Azure Databricks ソース形式に変更するには、Azure Databricks ワークスペースにログインし、ページの右上にあるプロファイルをクリックし、Settings をクリックし、Developer に移動します。 [エディターの設定] 見出しでノートブックの形式を既定に変更します。

プロファイルの開発者設定で既定のノートブック形式を変更する

ノートブックの形式を変換する

Azure Databricks UI を使用して、既存のノートブックを別の形式に変換できます。

既存のノートブックを別の形式に変換するには:

  1. ワークスペースでノートブックを開きます。

  2. ワークスペース メニューから [ファイル ] を選択し、[ ノートブックの形式] を選択して、目的の形式を選択します。 Jupyter (.ipynb) (推奨) またはソース (.scala、.py、.sql、.r) のいずれかを選択できます。 ノートブックの現在の形式はグレー表示され、横にチェックマークが付いています。

    ワークスペース ファイル メニューが展開され、ノートブック形式オプションが表示されます。

Azure Databricksでサポートされているノートブックの種類の詳細については、「 Databricks ノートブックのインポートとエクスポートを参照してください。

IPYNB ノートブックの出力コミットを管理する

出力は、テーブルの表示や視覚化など、Databricks プラットフォームでノートブックを実行した結果です。 ソース管理フォルダー内の IPYNB ノートブックの場合、ノートブックの出力をリモート リポジトリにコミットする方法を管理できます。

ノートブック出力のコミットを許可する.ipynb

ワークスペース管理者がこの機能を有効にしている場合にのみ、出力をコミットできます。 既定では、Git フォルダーの管理設定では、.ipynb ノートブックの出力はコミットできません。 ワークスペースの管理者特権がある場合は、この設定を変更できます。

  1. Azure Databricks ワークスペースの上部バーでユーザー名をクリックし、[設定] を選択します。

  2. ワークスペース管理配下で、開発 をクリックします。

  3. Reposセクションで、Repos に IPYNB 出力のエクスポートを許可を許可: IPYNB 出力をオンに切り替え可能に設定してください。

    管理コンソール: Git フォルダーに IPYNB 出力のエクスポートを許可します。

Von Bedeutung

出力が含まれる場合、視覚化とダッシュボードの構成は、作成する .ipynb ノートブックに含まれます。

IPYNB ノートブック出力成果物のコミットを制御する

リポジトリ内の .databricks/commit_outputs 設定ファイルは、どの .ipynb ノートブック出力をコミットするかを制御します。 ワークスペース管理者が出力コミットを許可した後、Gitダイアログからこのファイルを作成できます:

  1. .ipynbを、.databricks/commit_outputsノートブックはあるがファイルがないGitフォルダに対して開きます。

  2. ダイアログ上部の情報アラートで「commit_outputs 構成ファイルを作成」をクリックします。

    Notebook コミット UI: commit_outputs ファイルを作成するボタン。

また、特定のIPYNBノートブックの出力を含めたり除外したりするには、File メニューを使用することもできます。 設定ファイルが存在しない場合、選択時に Azure Databricks が設定ファイルを作成します。 Gitダイアログでアラートを閉じた場合は、このオプションを使ってください。

  1. ファイルメニューでノートブック出力をコミットを選択します。 メニュー項目は、ワークスペース管理者が出力コミットを許可した後、Gitフォルダ内のIPYNBノートブックでのみ利用可能です。

    ノートブック エディター: ノートブックの出力の状態と制御をコミットします。

  2. 「コミット出力設定」ダイアログで、出力を含める または 出力を除外する を選択し、変更 をクリックします。

    ノートブックの出力をコミットするダイアログボックス。