適用対象: ✔️ Front Door Standard ✔️ Front Door Premium
この記事では、Azure Front Door でのファイル圧縮に関する問題のトラブルシューティングについて説明します。
症状
ご利用のルートに対して圧縮が有効になっているにもかかわらず、ファイルが圧縮されていない状態で戻されています。
ヒント
ファイルが圧縮されているかどうかを確認するには、Fiddler などのツール、またはブラウザーの開発者ツールを使用してください。 HTTP 応答内で Content-Encoding
ヘッダーを探します。
gzip、bzip2、または deflate という値がそれに含まれている場合、コンテンツは圧縮されています。
原因
以下の原因が考えられます。
- コンテンツが圧縮の対象ではありません。
- そのファイルの種類に対して、圧縮が有効になっていません。
- 有効な圧縮の種類を示すヘッダーが HTTP 要求に欠落しています。
- 配信元からチャンク コンテンツが送信されています。
トラブルシューティングの手順
ヒント
Azure Front Door 構成の変更が反映されるまで、最大 10 分かかる可能性があります。 今回圧縮を初めて設定する場合は、その設定が POP に確実に反映されるまで 1 から 2 時間かかります。
要求を確認する
ブラウザーの開発者ツールを使用して、要求の内容を確認します:
- 要求が配信元ではなく、
<endpointname>.z01.azurefd.net
に送信されていることを確認します。 - 要求に、gzip、deflate、または bzip2 を含む Accept-Encoding ヘッダーが存在することを確認します。
圧縮の設定を確認する
Azure portal で、ご利用のエンドポイントに移動し、[ルート] パネルの [構成] を選択します。 圧縮が有効になっていることを確認します。
配信元サーバーで要求の Via ヘッダーをチェックする
Via ヘッダーは、プロキシ サーバーを示します。 既定では、Microsoft IIS サーバーによる圧縮に Via ヘッダーは使用されません。 これをオーバーライドするには、次を行ってください。
- IIS 6: IIS のメタベース プロパティで HcNoCompressionForProxies="FALSE" に設定する。 IIS 6 圧縮に関するページを参照してください。
- IIS 7 以降: サーバーの構成で noCompressionForHttp10 と noCompressionForProxies を False に設定します。 HTTP 圧縮に関するページを参照してください。
次のステップ
詳細については、Azure Front Door の FAQ に関するページを参照してください。