ホスト インスタンスの追加
概要
BizTalk Server管理コンソールまたは Windows Management Instrumentation (WMI) を使用して、ホスト インスタンスを追加できます。 BizTalk Serverでは、ホスト インスタンスを一度に 1 つのサーバーにのみ追加できます。 ホスト インスタンスの詳細については、「 ホスト インスタンス」を参照してください。 WMI を使用してホスト インスタンスを追加する方法については、UI ガイダンスと開発者 API 名前空間リファレンスの「MSBTS_HostInstance (WMI)」を参照してください。
ホスト インスタンスを追加すると、そのホストのインスタンスは BizTalk Server のインスタンスにマップされます。 既存のホスト インスタンスを修復する必要がある場合は、ホスト インスタンスのプロパティを更新できます。 既存のホスト インスタンスを再度追加するには、インスタンスを停止する必要があります。 ホスト インスタンスの停止の詳細については、「ホスト インスタンス を停止する方法」を参照してください。
Note
その 26 個のホスト インスタンスをさらに作成する場合は、サポート技術情報の記事「User32.dll または Kernel32.dll が初期化に失敗する」184802の指示に従う必要があります。これは で https://go.microsoft.com/fwlink/?LinkId=26176入手できます。 このサポート技術情報の資料に記載されている内容を反映した後で、ホスト インスタンスを追加する必要がある場合は、BTSNTSvc サービスの各インスタンスに割り当てるメモリ量を減らしてみてください。 メモリ量を減らすことによって、追加のインスタンスを作成するのに必要なメモリを提供できます。
Note
サービス アカウントには、ホスト インスタンスのインストール先サーバーに対する "サービスとしてログオン" アクセス許可が自動的に与えられます。
前提条件
ここで示す手順を実行するには、管理者グループのメンバーおよび BizTalk Server 管理者グループのメンバーとしてログオンする必要があります。
また、次のデータベースが置かれているサーバーにおいて、db_securityadmin SQL Server データベース ロールおよび securityadmin SQL Server ロールのメンバーであることが必要です。
BAM プライマリ インポート (BAMPrimaryImport)
BizTalk 管理 (BizTalkMgmtDb)
BizTalk メッセージ ボックス (BizTalkMsgBoxDb) (すべて)
BizTalk Tracking (BizTalk DTADb)
ルール エンジン (BizTalkRuleEngineDb)
注意事項
ホスト インスタンスのアカウント情報は、BizTalk Server 管理コンソールまたは Windows Management Instrumentation (WMI) スクリプトを使用して更新することをお勧めします。 これにより、BizTalk Server が BizTalk Server データベースのアカウント情報を更新し、データベースとホスト インスタンス間でセキュリティ構成が同期された状態を維持することができます。
手順
[スタート]、[すべてのプログラム]、[Microsoft BizTalk Server 20xx] の順にクリックし、[BizTalk Server管理] をクリックします。
コンソール ツリーで、[BizTalk Server管理] を展開し、[BizTalk] グループを展開して、[プラットフォーム設定] をクリックします。
[ ホスト インスタンス] を右クリックし、[ 新規] をクリックし、[ ホスト インスタンス] をクリックします。
[ ホスト インスタンスのプロパティ ] ダイアログ ボックスで、次の操作を行い、[OK] をクリック します。
プロパティ 目的 ホスト名 選択したサーバーに関連付けられているホストの名前を表示します。 サーバー 選択したホストに関連付けられているサーバーを表示します。 ログオン ホスト インスタンスを実行する、新しいサービス アカウントのアカウント名を表示します。 構成 クリックすると、[ ログオン資格情報 ] ダイアログ ボックスが表示されます。ここで、ホスト インスタンスを実行するアカウントのアカウント名とパスワードを入力できます。 [ホスト インスタンスの開始を無効にする] 選択したホストの状態を有効から無効に変更する場合、このチェック ボックスをオンにします。 ホスト インスタンスを開始せずに設定を保持する場合は、インスタンスを無効にすると便利です。 ホスト インスタンスをインストールしたら、インスタンスを再起動して、メッセージがメッセージ ボックス データベースにルーティングされるようにする必要があります。 ホスト インスタンスの開始の詳細については、「ホスト インスタンス を開始する方法」を参照してください。
の既知の問題
BizTalk ホスト インスタンスの作成時に、指定した BizTalk Server ランタイム コンピューターを利用できない場合、状態が "アンインストールの失敗" のホスト インスタンスが作成される
問題
BizTalk 管理コンソールが、BizTalk Serverランタイム コンピューターにリモートのコンピューターにインストールされている場合、BizTalk Server コンピューターが使用できない場合でも、リモート BizTalk Server コンピューターにホスト インスタンスを作成しようとすることができます。
使用できないBizTalk Server コンピューターで BizTalk ホストのインスタンスを作成しようとすると、次のエラー メッセージが表示されるダイアログ ボックスが表示されます。
サーバー <サーバー名>へのホスト <ホスト名>のインストールに失敗しました。
追加情報:
RPC サーバーが利用できません。 (WinMgmt)
[OK] をクリックしてダイアログ ボックスを消すと、次のエラー メッセージを示すダイアログ ボックスが表示されます。
サーバー <サーバー名>でのホスト <ホスト名>の中止されたインストールのクリーンアップに失敗しました。
追加情報:
Windows NT サービス BTSSvc{<GUID>} を削除するときにエラーが発生しました。 (WinMgmt)
[OK] をクリックしてこのダイアログ ボックスを閉じると、BizTalk ホストのインスタンスが BizTalk 管理コンソールに表示され、[状態] が [アンインストールに失敗しました] と表示されます。
原因
ホスト インスタンスが作成されると、指定されたBizTalk Server コンピューターにホスト インスタンスがインストールされる前に、BizTalk 管理データベースにエントリが作成されます。 指定されたBizTalk Server コンピューターへのホスト インスタンスのインストールが失敗した場合、BizTalk 管理プログラムはホスト インスタンスのアンインストールを試みますが、指定されたBizTalk Serverコンピューターが使用できないため、アンインストールも失敗します。
解決方法
BizTalk Admininstration Console で状態が [アンインストールに失敗しました] の BizTalk ホスト インスタンスが作成された場合は、指定されたBizTalk Server コンピューターが使用可能になった後にホスト インスタンスを削除し、ホスト インスタンスを再作成します。
Note
BizTalk 管理コンソールで BizTalk ホスト インスタンスが作成され、[アンインストールの状態] が失敗した場合、指定されたBizTalk Serverコンピューターが再び使用可能になった後でも、ホスト インスタンスは機能しません。
参照
BizTalk ホストとホスト インスタンスの管理ホスト インスタンスの開始 ホスト インスタンスの停止 ホスト インスタンスの削除 ホスト インスタンスのプロパティの変更