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インターネット インフォメーション サービスのトラブルシューティング

Microsoft インターネット インフォメーション サービス (IIS) は、HTTP、SOAP、Windows SharePoint Services アダプターなどのさまざまな機能のために、Microsoft BizTalk Server によって広く使用されています。 このトピックでは、IIS で発生する可能性のある既知の問題と、これらの問題に対する考えられる解決策について説明します。

既知の問題

このトピックに記載されているエラーは、フレンドリ HTTP エラー メッセージを無効にするように Internet Explorer を構成しない限り表示されない場合があります。

フレンドリ HTTP エラー メッセージを無効にするように Internet Explorer を構成するには

  1. [ツール] メニューの [インターネット オプション] をクリックします。

  2. [ 詳細設定 ] タブの [ 参照 ] セクションで、[ わかりやすい HTTP エラー メッセージを表示 する] チェック ボックスをオフにし、[OK] をクリック します

  3. Internet Explorer を閉じます。

IIS サーバー上の Web ページにアクセスすると、"HTTP 404 - ファイルが見つかりません" というエラーが発生する

問題

IIS サーバー上の Web ページにアクセスしようとすると、次のようなエラーが表示されます。

ページが見つかりません

-又は-

HTTP 404 - ファイルが見つかりません

原因

このエラーは、次の理由で発生する可能性があります。

  • 要求されたファイルの名前が変更されました。

  • 要求されたファイルが別の場所に移動されたか、削除されました。

  • 要求されたファイルは、メンテナンス、アップグレード、またはその他の不明な原因により、一時的に使用できません。

  • 要求されたファイルが存在しません。

  • IIS 6.0: 適切な Web サービス拡張機能または MIME の種類が有効になっていません。

  • 仮想ディレクトリは、別のサーバー上のドライブのルートにマップされます。

解決策

https://support.microsoft.com/kb/248033で使用可能な「IIS サーバーから "HTTP 404 - ファイルが見つかりません" というエラーが返される一般的な理由」248033、マイクロソフト サポート技術情報の記事の解決策セクションの手順に従います。

IIS サーバー上の Web ページにアクセスするときに、"サーバーまたは DNS エラーが見つかりません" が発生する

問題

IIS サーバー上の Web ページにアクセスしようとすると、次のようなエラーが表示されます。

ページを表示できない

-又は-

サーバーまたは DNS エラーが見つかりません

原因

このエラーは、次の理由で発生する可能性があります。

  • Internet Explorer の接続設定が正しくありません。

  • 正しく構成されていない、機能していない、または互換性のないファイアウォールまたはプロキシ ソフトウェアがインストールされている。

  • Hosts ファイルに正しくないエントリがあります。

  • ネットワーク アダプターが正しく機能していないか、互換性のないネットワーク アダプター ドライバーがインストールされています。

解決策

https://support.microsoft.com/kb/326155で利用可能な「Internet Explorer で Web サイトにアクセスしようとするとエラー メッセージが表示される」326155マイクロソフト サポート技術情報の記事の解決策セクションの手順に従ってください。

IIS サーバー上の Web ページにアクセスするときに "401 - アクセスが拒否されました" エラーが発生する

問題

IIS サーバー上の Web ページにアクセスしようとすると、次のようなエラーが表示されます。

401 - アクセスが拒否されました

原因

IIS では、エラーのより具体的な原因を示す複数の異なる 401 エラーが定義されています。 次の特定のエラー コードがブラウザーに表示されます。

  • 401.1 - ログオンに失敗しました。

  • 401.2 - サーバー構成が原因でログオンに失敗しました。

  • 401.3 - リソースの ACL が原因で承認されていません。

  • 401.4 - フィルターによる承認に失敗しました。

  • 401.5 - ISAPI/CGI アプリケーションによる承認に失敗しました。

  • 401.7 – Web サーバー上の URL 承認ポリシーによってアクセスが拒否されました。 このエラー コードは IIS 6.0 に固有です。

    IIS 7.0 の状態コードの完全な一覧については、microsoft サポート技術情報の記事 943891「IIS 7.0 の HTTP 状態コード」を参照 https://support.microsoft.com/kb/943891

解決策

IIS のアクセス許可の問題を解決するためのガイドラインの手順に従って、IIS のアクセス許可の問題を解決します。

IIS サーバー上の Web ページにアクセスするときに "500 - 内部サーバー エラー" が発生する

問題

IIS サーバー上の Web ページにアクセスしようとすると、次のようなエラーが表示されます。

500 - 内部サーバー エラー

原因

このエラー メッセージは、さまざまなサーバー側の問題が原因で発生する可能性があります。

解決策

この問題を解決するには、以下の手順を実行します。

  • このエラーが発生する理由については、IIS サーバーのアプリケーション ログを確認してください。

  • エラーの原因を特定するのに役立つ可能性がある情報については、IIS ログ ファイルまたは HTTPERR ログ ファイルを確認してください。 既定では、Windows Server オペレーティング システムを実行しているコンピューター上の IIS ログ ファイルは、次のディレクトリにあります。

    %WinDir%\system32\LogFiles\W3SVC1\

    %WinDir% は、IIS サーバー上の Windows ディレクトリの場所のプレースホルダーです。

    既定では、Windows Server 2008 または Windows Vista を実行しているコンピューター上の IIS ログ ファイルは、次のディレクトリにあります。

    C:\inetpub\logs\LogFiles\W3SVC1\

    既定では、Windows Server 上の HTTPERR ログ ファイルは次のディレクトリにあります。

    %WinDir% の system32LogFilesHTTPERR

    HTTPERR ログ ファイルは、Windows Server 2008 SP2 または Windows Vista コンピューターでのみ使用できます。

IIS サーバー上の Web ページにアクセスするときに "サービスを利用できません" エラーが発生する

問題

IIS サーバー上の Web ページにアクセスしようとすると、次のようなエラーが表示されます。

サービス利用不可

原因

このエラーの最も一般的な原因は、Web ページのアプリケーション プール (IIS 6.0 および IIS 7.0) が停止していることです。 これは一般に、指定されたユーザー名とパスワードが無効な ID でアプリケーション プールまたは COM+ アプリケーションが構成されている場合に発生します。

解決策

IIS のアクセス許可の問題を解決するためのガイドライン 」トピックの「IIS アプリケーション ホスト プロセス ID の設定」セクションの手順に従って、適切なホスト プロセス ID を設定します。

こちらもご覧ください

IIS のアクセス許可の問題を解決するためのガイドライン