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Microsoft Entra のバックアップと回復のトラブルシューティング (プレビュー)

Important

Microsoft Entra のバックアップと回復は現在プレビュー段階です。 ベータ版、プレビュー版、または他の方法で一般公開されていない Azure の機能に適用される法的条件については、Microsoft Azure プレビューの追加利用規約を参照してください。

この記事は、Microsoft Entra のバックアップと回復 (バックアップ アクセス、差分レポート ジョブ、回復ジョブなど) を使用するときの一般的な問題を診断して解決するのに役立ちます。

開始する前に

トラブルシューティングを行う前に、次の前提条件を確認してください。

  • テナントは 従業員テナント です (外部 ID と B2C テナントはサポートされていません)。
  • テナントに Microsoft Entra ID P1 または P2 ライセンスがあります。
  • 適切な Microsoft Entra Backup ロールを持つアカウントでサインインしています。
    • Microsoft Entra Backup Reader
    • Microsoft Entra Backup Administrator

グローバル管理者ロールには、必要なアクセス許可もあります。

これらの前提条件が満たされていない場合、操作が承認エラーまたは空の結果で失敗する可能性があります。

問題: バックアップが一覧に表示されない

この問題は、バックアップ リストに表示されるバックアップ数が予想よりも少ない場合、またはタイムスタンプが重複している場合に発生します。

Symptoms

  • 予想される 5 日間ではなく、5 日未満のバックアップが表示されます。
  • 2 つ以上のバックアップのバックアップ一覧に同じタイムスタンプが表示されます。

考えられる原因

最も古いバックアップは、サービスの初期化中、テナントのオンボード中、またはバックエンドの一時的な状態により、表示されるバックアップ日数が一時的に5日未満になる可能性があります。 この条件は、データの損失やバックアップの失敗を示すわけではありません。

Resolution

アクションは必要ありません。 サービスは引き続き新しいバックアップを自動的に作成します。

問題: 差分レポートまたはリカバリージョブを開始できない

この問題は、競合、承認エラー、またはサポートされていないオブジェクトの種類が原因で、差分レポートまたは回復ジョブの開始に失敗した場合に発生します。

Symptoms

  • 差分レポートまたは復旧ジョブが起動しません。
  • エラーは、競合または承認エラーを示します。
  • 使用するオブジェクトの種類は、スコープ フィルターのドロップダウンには表示されません。

考えられる原因

  • 別の差分レポートまたは回復ジョブが既に実行されています。
  • サインインしているユーザーには、必要な Microsoft Entra Backup ロールがありません。
  • 選択したオブジェクトの種類は、現在のリリースのバックアップと回復ではサポートされていません。

Resolution

  1. 別の差分レポートまたは回復ジョブが実行されているかどうかを確認します。 一度に実行できるジョブは 1 つだけです。
  2. アカウントに適切なロールがあることを確認しましょう。差分レポート用のMicrosoft Entra Backup Reader または復旧用のMicrosoft Entra Backup Administrator
  3. スコープを設定しようとしているオブジェクトの種類とオブジェクト属性がサポートされていることを確認します。 スコープ フィルターには、サポートされているオブジェクトの種類と属性のみが表示されます。

問題: 相違レポートの問題

このセクションでは、変更の欠落、実行時間の長いジョブ、失敗したジョブ、取り消されたジョブ、不足しているレポートなど、相違レポートに関連する一般的な問題のトラブルシューティングに役立ちます。

Symptoms

  • 差分レポートには、探していたオブジェクトの変更は含まれていませんでした。
  • 差分レポートは数時間実行されており、いつ終了したかはわかりません。
  • 差分レポートの状態は "Failed" です。
  • 前に生成した差分レポートが見つかりません。
  • [キャンセル] を選択しましたが、差分レポートは引き続き実行されているようです。

考えられる原因

  • オブジェクトまたはプロパティは、現在のリリースのプレビューではサポートされていません。
  • バックアップ状態と現在の状態の間でオブジェクトが変更されませんでした。
  • 差分レポートでは、多数のオブジェクトまたは変更が処理されています。
  • 一度に実行できる相違レポートまたは回復ジョブは 1 つだけです。
  • レポートが取り消されたか、完了前に失敗しました。
  • 差分レポートは無期限に保持されません。

Resolution

予想される変更がない場合:

  1. オブジェクトの種類とプロパティが現在のリリースでサポートされていることを確認します。
  2. バックアップの作成後にオブジェクトが変更されたことを確認します。
  3. ハード削除されたオブジェクトとサポートされていないプロパティは含まれません。

差分レポートが長時間にわたって実行されている場合:

推定差分レポートの生成時間を参照してください。 大規模なテナントまたは大規模な変更セットの処理に時間がかかる場合があります。

  • 取り消しが必要でない限り、レポートの実行を続行できるようにします。

差分レポートが失敗した場合:

  1. レポートの詳細に表示されるジョブの状態とエラー メッセージを確認します。
  2. 特定のオブジェクトの種類やオブジェクト ID など、より狭いスコープを使用して、差分レポートを再試行してください。
  3. 他の差分レポートまたは復旧ジョブが同時に実行されていないことを確認します。

以前の相違レポートが見つからない場合:

差分レポートは、作成されたバックアップに関連付けられます。

  1. バックアップを参照し、それに関連付けられている相違レポート ジョブの一覧を確認します。
  2. レポートが一覧に表示されない場合、差異レポートは終了日から 5 日間保持されるため、使用できなくなる可能性があります。

取り消し後も差分レポートの実行が続く場合:

  1. キャンセルはベスト エフォートです。 [キャンセル] を選択した後も、一部の処理が短時間続く場合があります。
  2. ジョブが実行中の状態のままである場合は、状態が更新されるまで待ってから、新しいレポートを開始します。

問題: リカバリージョブの問題

この問題は、回復ジョブが予期されたオブジェクトを回復しない場合、予想よりも長く実行される場合、または警告が表示された状態で完了した場合に発生します。

Symptoms

  • 回復ジョブは、差分レポートに表示されたオブジェクトを回復しませんでした。
  • 復旧ジョブは数時間実行されており、いつ完了したかはわかりません。
  • 回復ジョブの状態が "警告付きで完了しました" です。
  • 復旧ジョブを取り消しましたが、ジョブはまだ実行中と表示されています。

考えられる原因

  • 差分レポートに表示されるオブジェクトまたはプロパティ (オンプレミス同期プロパティなど) は、復旧ではサポートされていません。
  • 回復ジョブには、多数のオブジェクトまたは変更が含まれています。
  • 一度に実行できる相違レポートまたは回復ジョブは 1 つだけです。
  • 変更の処理中に回復ジョブが取り消されたか中断されました。
  • 一部の復旧アクションは、障害または取り消しが発生する前に部分的に成功する可能性があります。

Resolution

  1. 回復ジョブの詳細から、失敗した変更の一覧を確認します。
  2. サポートされているクラウド専用オブジェクトに焦点を当てて、より狭いスコープで復旧を再試行します。

この問題は、以前に完了した回復ジョブが表示されなくなった場合、または一部のリンクのみが復旧された場合に発生します。

Symptoms

  • 昨日実行した復旧ジョブが見つかりません。
  • 回復ジョブでは、一部のリンクまたはプロパティのみが復旧され (たとえば、5 つ中 1 つ)、回復されなかったリンクまたはプロパティが表示されます。

考えられる原因

  • 回復ジョブの詳細は、ジョブが完了してから 5 日後に自動的に削除されます。
  • 一部のリンクは、現在のリリースでは復旧できません。
  • 特定のリンクは、存在しなくなった他のオブジェクトまたは状態に依存します。
  • 回復ジョブが完了し、部分的な成功を示す警告が表示されます。

Resolution

前に実行した復旧ジョブが見つからない場合:

  1. 復旧に使用された バックアップ タイムスタンプ を見つけます。
  2. 復旧履歴を確認して、そのバックアップ タイムスタンプに関連付けられている復旧ジョブを見つけます
  3. ジョブが一覧に表示されなくなった場合、それは利用できなくなっている可能性があります。復旧ジョブは終了日から 5 日間保持されます。

すべてのリンクが回復されなかった場合:

  1. 警告やリンク変更の失敗があるか、復旧ジョブの詳細を確認します。
  2. 回復する予定のリンクが現在のリリースでサポートされていることを確認します。
  3. 次の場合、一部のリンクは復旧されない可能性があります。
    • 関連オブジェクトが存在しなくなりました。
    • リンクの種類はサポートされていません。
  4. 必要に応じて、サポートされていないリンクまたは失敗したリンクを手動で再作成します。

エラー条件とメッセージ

状態 エラー コードとメッセージ
無効なバックアップ ID でクエリされた差分レポート 404 Not Found: これは、復旧に有効なタイムスタンプではありません。 指定されたタイムスタンプは、使用可能なバックアップの一覧に含まれている必要があります。
無効なジョブ ID でジョブが照会される 404 見つかりません
別の差分レポートまたは回復ジョブがまだ実行中のときに、新しいジョブが開始される。 409 競合: 復旧ジョブが現在進行中です。 完了するのを待つまでは、新しいジョブを開始しないでください。
差分レポートが完了していない間に変更を取得する 400 無効な要求: 識別子 {key} を持つジョブは、変更を列挙する前に正常に完了している必要があります。
管理者権限が不足 403 禁止: この要求に対する承認が拒否されました。 資格情報を確認してください。

既知の制限

プレビュー期間中の Microsoft Entra のバックアップと回復には、次の既知の制限事項が適用されます。

部分プロパティカバレッジ

バックアップと回復 では、 サポートされているオブジェクトのすべてのプロパティがカバーされるわけではありません。 この制限には、読み取り専用プロパティ、システム生成プロパティ、特殊なビジネス ロジックに依存するプロパティが含まれます。 詳細については、 サポートされているプロパティの一覧 を参照してください。 Microsoft では、時間の経過と同時に、より多くのプロパティのサポートを拡大しています。

テナントサポートスコープ

Microsoft Entra のバックアップと回復は、従業員テナントでのみサポートされています。 外部 ID と B2C テナントはサポートされていません。

ハード削除されたオブジェクト

ハード削除されたオブジェクト は回復できません 。 これらのオブジェクトは差分レポートに含まれていないので、復旧ジョブを通じて再作成または復元することはできません。 ハード削除のリスクを軽減するには、 保護されたアクションを構成することを検討してください。

オンプレミス同期オブジェクト

オンプレミスの Active Directory から同期されたユーザーとグループは、Microsoft Entra のバックアップと回復では回復できません。 これらのオブジェクトは、オンプレミスの Active Directory 環境で直接復旧する必要があります。

回復では、静的グループ メンバーシップ リンクのみがサポートされます。 グループ所有者のリンク、ユーザー マネージャーの関係、およびスポンサー リンクはサポートされていません。