元の KB 番号: 2027064
現象
2010 年、Microsoft Exchange Server 2013、または Microsoft Exchange Server Microsoft Exchange Server実行しているコンピューターで Exchange Management Shell (EMS) または Exchange 管理コンソール (EMC) を起動しようとするとき2016 では、次のエラー メッセージが表示されます。
指定されたリモート ホストへの接続が拒否されました。 WS-Management サービスがリモート ホストで実行されており、正しいポートと HTTP URL で要求をリッスンするように構成されていることを確認します。 詳細については、「about_Remote_Troubleshooting ヘルプ」トピックを参照してください。
原因
この問題は、次の条件の 1 つ以上が当てはまるために発生します。
- MSExchangePowerShellAppPool アプリケーション プールで問題が発生しているか、実行されていません。
- ユーザーに リモート PowerShell が有効な 状態がありません。
- Windows リモート管理 (WinRM) がサーバーで正しく構成されていません。
解決方法
この問題を解決するには、次のいずれかの方法を使用します。
MSExchangePowerShellAppPool アプリケーション プールが実行されていることを確認します。 プールが実行されている場合は、それをリサイクルしてみてください。 次に、イベント ログのエラーまたは警告をチェックします。
接続しようとしているユーザーが リモート PowerShell が有効 になっていることを確認します。 ユーザーがリモート PowerShell に対して有効になっているかどうかを判断するには、有効になっているアカウントを使用して Exchange 管理シェルを起動し、次のクエリを実行します。
(Get-User <username>).RemotePowershellEnabled
このクエリは 、True または False の応答を返 します。 応答が False の場合、ユーザーはリモート PowerShell に対して有効になっていません。 ユーザーを有効にするには、次のコマンドを実行します。
Set-User \<username> -RemotePowerShellEnabled $True
WinRM がサーバーで正しく構成されていることを確認します。 これを行うには、次の手順を実行します。
WinRM QuickConfig を実行します。 これを行うには、[スタート] をクリックし、[検索の開始] ボックスに「WinRM QuickConfig」と入力し、Enter キーを押します。
両方のテストが成功し、アクションが必要ないことを確認します。 何らかのアクションが必要な場合は、プロンプト ウィンドウで [ はい ] をクリックして、WinRM 構成の変更を許可します。
[スタート] をクリックし、[検索の開始] ボックスに「cmd」と入力し、Enter キーを押します。 [コマンド プロンプト] ウィンドウで、コマンド プロンプトで 「WinRM enumerate winrm/config/listener 」と入力し、Enter キーを押します。
ポート 5985 の HTTP プロトコルのリスナーが存在し、リスナーがすべてのアドレスでリッスンしていることを確認します。