次の方法で共有


SCOM は異常な正常性セットを報告します

現象

Microsoft System Center Operations Manager (SCOM) から、環境内のマネージド可用性 正常性セット の一部が異常であるという通知を受け取ります。

影響を受けるサーバーで Microsoft Windows アプリケーションとサービスのイベント ログを検索すると、 Microsoft>Exchange>ActiveMonitoring>ProbeResult の下に一覧表示されている一部のイベントに次のエラー メッセージが含まれていることがわかります。

System.ApplicationException: monitoring mailbox <UPN of health mailbox account> not found!
at Microsoft.Exchange.Monitoring.ActiveMonitoring.Common.CommonAccessTokenHelper.
ResolveRootOrgUser(String emailAddress, IRecipientSession& recipientSession)

また、影響を受けるサーバー上のフォルダーにある ActiveMonitoringTraceLogs アクティブな監視トレース ログには、次の情報を表示するエントリが含まれています。

Component: "Common"
LogLevel: "Warning"
Method: "CreateMonitoringMailbox"
Source: "DirectoryAccessor.cs:1380"
Message: "Exception is caught trying to disable email address policy in OnPrem for monitoring mailbox: 
<UPN of health mailbox account>, error : Microsoft.Exchange.Data.Directory.ADNoSuchObjectException: 
Active Directory operation failed on <FQDN of domain controller>. The object <DN of health mailbox account> 
does not exist."

: ActiveMonitoringTraceLogs フォルダーは にあります %ExchangeInstallPath%\Logging\Monitoring\Monitoring\MSExchangeHMWorker\ActiveMonitoringTraceLogs

原因

Exchange Health Manager Worker プロセス (MSExchangeHMWorker.exe) によって新しい正常性メールボックスが作成されると、メールボックスのパラメーター値を にFalse設定EmailAddressPolicyEnabledしようとします。 ただし、ドメイン コントローラーが複数ある環境では、Active Directory レプリケーションの遅延が引き続き EmailAddressPolicyEnabled として True設定される可能性があります。 そのシナリオでは、次の問題が発生します。

  • MSExchangeHMWorker.exe による電子メール アドレス ポリシーの無効化が失敗すると、「現象」セクションに記載されているアクティブな監視トレース ログ エラー メッセージが生成されます。

  • Exchange Health Manager Worker プロセスが失敗した操作を再試行しないため、メール アドレス ポリシーは有効のままです。 organizationのメール アドレス ポリシーによっては、メールボックスの SMTP アドレスに UPN とは異なる値が割り当てられる場合があります。

  • 一部の アクティブ監視 プローブでは、メールボックスの SMTP アドレスが UPN と一致しない場合、アプリケーションとサービスのイベント ログにエラーが生成されます。 たとえば、プローブは RpsDeepTestPSProxyProbe/CertificateSid.<CN of health mailbox> 、"現象" セクションに表示される Applications and Services イベント ログにエラー メッセージを生成します。 このようなエラーにより、Operations Manager は一部の正常性セットを異常として報告します。

解決方法

この問題を解決するには、次の手順を実行します。

  1. 次のコマンドを実行して、各正常性メールボックスの EmailAddressPolicyEnabled パラメーター値を に False設定します。

    Get-Mailbox -Monitoring | Set-Mailbox -EmailAddressPolicyEnabled $False
    
  2. 次のコマンドを実行して、各正常性メールボックスのプライマリ SMTP アドレスが UPN と一致することを確認します。

    Get-Mailbox -Monitoring | Select-Object UserPrincipalName | foreach {Set-Mailbox -Identity $_.UserPrincipalName -PrimarySmtpAddress $_.UserPrincipalName}