元の KB 番号: 4036518
現象
ユーザーのメールボックスが Microsoft 365 に移行されると、想定どおりに、ユーザーが代理人であるオンプレミスの会議室メールボックスから会議出席依頼を受け取ります。
ただし、これらの会議は、開催者によって出席者として追加されたかのように、ユーザーの予定表に直接表示されます。 また、要求を承諾または拒否しようとする試みは、リソース メールボックスではなくユーザーから直接行われます。
原因
この問題は、以下の条件に該当する場合に発生します。
- オンプレミスの会議室メールボックスのリソース デリゲートは、クラウド ユーザーを含む配布グループです。
- トランスポート ニュートラル カプセル化形式 (TNEF) は、会議出席依頼がクラウド メールボックスに送信されるときに使用されるリモート ドメインでは明示的に有効になっていません。
解決方法 1
組織レベル (推奨) で問題を解決するには、クラウド ユーザーの *.mail.onmicrosoft.com
ターゲット アドレスとして使用される内容に応じて、リモート ドメインで TNEF を有効にします。 これを行うには、以下のコマンドレットを実行します。
Set-RemoteDomain <domain> - TNEFEnabled $true
解決方法 2
シングル ユーザー レベルで問題を解決するには、会議室メールボックスのリソース デリゲートとして配布グループを削除し、その配布グループを、リソース デリゲートである必要があるすべてのメンバーの一覧に置き換えます。 これを行うには、次の手順を実行します。
次のコマンドレットを使用して、現在のデリゲートの一覧を取得します。
[System.Collections.ArrayList]$delegates=@((Get-CalendarProcessing <room>).ResourceDelegates)
次のコマンドレットを使用して、配列から配布グループを削除します。
$delegates.remove("<Identity of distribution group to remove>")
次のコマンドレットを使用して、1 人のユーザーを配列に追加します (追加するユーザーに対して繰り返されます)。
$delegates.add("<Identity of single user to add>")
次のコマンドレットを使用して変更を適用します。
Set-calendarprocessing <room> -resourcedelegates $delegates
解決策 3
会議室メールボックスをオンプレミスからクラウドに移行し、その配布グループのメンバーである他のすべての代理人を移行します。
詳細情報
TNEF の詳細については、「 リモート ドメインを使用した TNEF メッセージの書式設定の管理」を参照してください。
コマンドレットの Set-remotedomain
詳細については、「 Set-RemoteDomain」を参照してください。