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グループ ポリシーを使用して既定の電子メール クライアントを構成できない

現象

グループ ポリシーを使用して既定の電子メール クライアントを管理する場合、この構成を行う設定を見つけることができません。

原因

Microsoft Outlook の既定のグループ ポリシー テンプレートには、既定の電子メール クライアントを構成するための設定は含まれていません。

解決方法

注:

このセクションの手順の実行には注意が必要です。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 変更する前に、問題の発生に備えて復元用にレジストリのバックアップを作成してください。

既定の電子メール クライアントを設定するには、お使いのバージョンの Windows の指示に従います。

Windows 10とWindows 8

Windows 10とWindows 8の両方が、既定のアプリケーション設定を格納するレジストリの部分を保護します。 既定のアプリのセットを定義するには、グループ ポリシーで XML ベースのポリシーを使用する必要があります。 ポリシーを作成して展開するには、次の手順に従います。

手順 1. アプリの関連付け XML ファイルを作成する

  1. Windows で、「既定のアプリ」と入力します (または、[設定][既定のアプリ] を開きます)。

  2. [ 既定のアプリをプロトコルで選択する] を選択します

  3. スクロールして一覧内の MAILTO を探し、Outlook を既定のアプリとして設定します。

    Outlook を既定のアプリとして設定する手順を示すスクリーンショット。

  4. 既定値を設定した後、 DISM を使用してこれらの値を XML にエクスポートします。

    注:

    作成したファイルのファイル名と場所を書き留めます。

  5. 管理者特権のコマンド プロンプトで、次のコマンドを入力します。

    Dism /Online /Export-DefaultAppAssociations:"F:\AppAssociations.xml"
    

    注:

    • XML ファイルは、DISM の実行に使用されるユーザー アカウントに設定されている既定値に基づいています。
    • Outlook が MailTo リンクを開く既定のアプリとして設定されていることを確認するには、次のような XML で返される行を探します。
    <Association Identifier="mailto" ProgId="Outlook.URL.mailto.15" ApplicationName="Outlook 2016" />
    

手順 2. GPO を使用してアプリの関連付け XML ファイルを展開する

  1. Windows で「gpedit.msc」と入力して、ローカル グループ ポリシー エディターを開きます。

  2. [コンピューターの構成>] [管理用テンプレート>] Windows コンポーネント>エクスプローラー を開きます。

  3. [既定の関連付けの設定] 構成ファイル ポリシーをダブルクリックし、[有効] に設定します。

  4. 前に作成したアプリ関連付け XML ファイルへのパスを指定します。

    注:

    これは、すべてのクライアントがアクセスできるローカル パスまたはネットワークの場所です。

このポリシーでは、レジストリに次のキーを作成する必要があります。

サブキー: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System

文字列値: DefaultAssociationsConfiguration

値データ: \ServerPath\AppAssociations.xml

注:

このポリシーは、ドメインに参加しているクライアントに対してのみ機能します。

このポリシーを設定すると、ユーザーが再びサインインした後に、既定のアプリケーションの関連付けが適用されます。 MailTo リンクが Outlook のメール メッセージを開くようになりました。

Windows 7

グループ ポリシーを使用して既定の電子メール クライアントを構成するには、カスタムの .adm テンプレートを作成します。 次に、このテンプレートをローカル グループ ポリシー エディターに追加して、ポリシー設定を構成できるようにします。 これを行うには、次の手順を実行します。

  1. メモ帳でテキスト ファイルを作成します。

  2. 次のテキストをコピーしてテキスト ファイルに貼り付けます。

    CLASS MACHINE
    CATEGORY !!Default_E-mail_Client
     POLICY !!Default_Client
     KEYNAME "SOFTWARE\Clients\Mail"
     EXPLAIN !!Explain_Default_Client
      PART !!labeltext_Default_Client EDITTEXT
       VALUENAME ""
     DEFAULT "Microsoft Outlook"
       END PART
      END POLICY
    END CATEGORY
    
    [strings]
    Default_E-mail_Client="Default e-mail client policy"
    Default_Client="Default e-mail client"
    Explain_Default_Client="This policy configures Outlook as the default e-mail client"
    labeltext_Default_Client="Default E-mail Client:"
    Microsoft_Outlook="Microsoft Outlook"
    
  3. ファイルを DefaultEmailClient.adm として保存します。

  4. ファイルを閉じます。

  5. ローカル グループ ポリシー エディターにファイルを追加します。

    メモDefaultEmailClient.adm ファイルをローカル グループ ポリシー エディターに追加する手順はさまざまです。 詳細については、Windows のドキュメントを参照してください。

  6. [ コンピューターの構成] で、[ 管理用テンプレート] を展開します

  7. ポリシー ツリーで、[ 既定の電子メール クライアント ポリシー ] ノードを選択します。

  8. 詳細ウィンドウで、[ 既定の電子メール クライアント ] 設定をダブルクリックします。

    メモ[ローカル グループ ポリシー エディター] の詳細ウィンドウに [既定の電子メール クライアント ポリシー] 設定が表示されない場合は、グループ ポリシー エディターのフィルター設定が管理されていないポリシーを非表示にしていないことを確認します。 たとえば、Windows Server 2003 で、[表示] メニューの [フィルター処理] を選択します。 次に、[フル マネージドチェックできるポリシー設定のみを表示する] ボックスをオフにします。

  9. [有効] を選択します。

  10. このポリシーで構成する既定の電子メール クライアントを指定します。 (既定の選択は Microsoft Outlook です)。

    メモ ワークステーションに登録されている電子メール クライアントがわからない場合は、レジストリの次のサブキーの下にあるキーを調べます。

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail

    各キーの名前は、ワークステーションにインストールされている電子メール クライアントの名前です。

  11. [OK] をクリックします。

詳細

  • Windows 10とWindows 8では、[Windows 設定]> でこのオプションを手動で設定できます。各プロトコルの既定のアプリを選択します。
  • Windows 7 では、既定の電子メール クライアントは通常、[インターネットのプロパティ] ダイアログ ボックスの [プログラム] タブで構成されます。 ただし、ローカル管理者グループのメンバーでない場合は、この変更を行う適切なアクセス許可がない可能性があります。 これは、設定がレジストリのHKEY_LOCAL_MACHINE サブツリーに格納されるためです。