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Microsoft 365 にサインインするときに "申し訳ありませんが、サインインできません" というエラーが表示される

症状

Microsoft 365 ポータルにサインインしようとすると、次のエラー メッセージが表示されます。

申し訳ございません。サインインに問題があります。

さらに、次のエラー メッセージが表示される場合もあります。

AADSTS7000112: アプリケーション '00000002-0000-0ff1-ce00-000000000000'(Office 365 Exchange Online) が無効になっています。

原因

この問題は、Exchange Online アプリケーションのサービス プリンシパルがテナントで無効になっている場合に発生します。

解決策

これらの手順を実行する前に、次の前提条件が満たされていることを確認してください。

  • Windows PowerShell 用の Azure Active Directory モジュールをインストールします。 詳細については、「 Microsoft 365 PowerShell への接続」を参照してください。
  • この手順は、Microsoft 365 グローバル管理者によって実行されます。

この問題を解決するには、次の手順に従ってください。

  1. Exchange Online アプリケーションのサービス プリンシパルの現在の状態を確認します。 これを行うには、以下のコマンドレットを実行します。

    (Get-MsolServicePrincipal -AppPrincipalId 00000002-0000-0ff1-ce00-000000000000).accountenabled
    
  2. 次のコマンドレットを実行して、Exchange Online のサービス プリンシパルを有効にします。

    Get-MsolServicePrincipal -AppPrincipalId 00000002-0000-0ff1-ce00-000000000000 | Set-MsolServicePrincipal -AccountEnabled $true
    

Azure AD および MSOnline PowerShell モジュールは、2024 年 3 月 30 日の時点で非推奨となります。 詳細については、非推奨に関するアップデートを参照してください。 この日以降、これらのモジュールのサポートは、Microsoft Graph PowerShell SDK への移行支援とセキュリティ修正に限定されます。 非推奨のモジュールは、2025 年 3 月 30 日まで引き続き機能します。

Microsoft Entra ID (旧称 Azure AD) を使用するには、Microsoft Graph PowerShell に移行することをお勧めします。 移行に関する一般的な質問については、「移行に関する FAQ」を参照してください。 注: MSOnline のバージョン 1.0.x では、2024 年 6 月 30 日以降に中断が発生する可能性があります。