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サーバー上にある Access データベースを開こうとすると、「既に使用されているファイル」のエラーが発生する

元の KB 番号: 289681

注:

この記事は、Microsoft Access データベース (.accdb または .mdb) にのみ適用されます。 シングル ユーザー コンピューターのユーザー インターフェイスに関する知識が必要です。

現象

サーバー上にあるデータベースを開こうとすると、次のエラー メッセージが表示されることがあります。

ファイル名>を使用<できませんでした。ファイルは既に使用されています。

原因

データベースがあるフォルダーに対する作成のアクセス許可がないと、Microsoft Jet データベース エンジンはロック情報ファイルを作成できません。 このファイルは、複数のユーザーがデータベースを開く場合に必要です。 そのため、対応するファイルが存在しない場合は、作成のアクセス許可がないユーザーのみがデータベースを開きます。

注:

ロック情報ファイルは次の形式です。

  • 2003 以前のバージョンの Access の *.ldb
  • Access 2007/2010 の *.laccdb

回避策

この動作を回避するには、データベースを開くすべてのユーザーが、データベースが格納されているフォルダーの読み取り、書き込み、および作成のアクセス許可を持っていることを確認します。

さらに、セキュリティが強化された Access データベースを使用している場合は、データベースを開くユーザーがフォルダーに対する読み取りおよび書き込みアクセス許可も持っている必要があります。 フォルダーには、ワークグループ情報 (.mdw) ファイルが含まれています。

詳細情報

共有モードでデータベースを開く場合、Microsoft Jet データベース エンジンは、データベース自体と同じフォルダーにロック情報ファイル (*.ldbまたは*.laccdb) を作成できる必要があります。

.ldb ファイルの詳細については、 [ヘルプ] メニューの [Microsoft Access ヘルプ] をクリックし、Office アシスタントまたはアンサー ウィザードに「Access データベースの共有」と入力します。最後に [検索] をクリックして、表示される内容を参照してください。

関連情報

.ldb ファイルの詳細については、次の記事を参照してください。

Access のロック ファイル (.laccdb と .ldb) の概要