サーバー上にある Access データベースを開こうとすると、"ファイルが既に使用されています" というエラーが表示される

元の KB 番号: 289681

この記事は、Microsoft Access データベース (.accdb と .mdb) にのみ適用されます。 シングル ユーザー コンピューター上のユーザー インターフェイスに関する知識が必要です。

症状

サーバー上にあるデータベースを開こうとすると、次のエラー メッセージが表示されることがあります。

ファイル名<filename>は既に使用中のため、使用できませんでした。

原因

データベースが配置されているフォルダーの作成アクセス許可がない場合、Microsoft Jet データベース エンジンはロック情報ファイルを作成できません。 このファイルは、複数のユーザーがデータベースを開くために必要です。 そのため、対応するファイルがまだ存在しない場合は、作成権限を持たないユーザーがデータベースを排他的に開きます。

ロック情報ファイルは次のとおりです。

  • Access 2003 および以前のバージョンの Access の *.ldb
  • Access 2007/2010 の *.laccdb

対処法

この動作を回避するには、データベースを開くすべてのユーザーが、データベースが配置されているフォルダーの読み取り、書き込み、作成のアクセス許可を持っていることを確認します。

さらに、セキュリティ強化された Access データベースを使用している場合は、データベースを開くユーザーにもフォルダーに対する読み取りおよび書き込みアクセス許可があることを確認します。 このフォルダーにはワークグループ情報 (.mdw) ファイルが含まれています。

詳細情報

共有モードでデータベースを開くには、Microsoft Jet データベース エンジンが、データベース自体と同じフォルダーにロック情報ファイル (*.ldbまたは *.laccdb) を作成できる必要があります。

.ldb ファイルの詳細については、[ ヘルプ ] メニューの [Microsoft Access ヘルプ] をクリックし、Office アシスタントまたは応答ウィザードで 「共有アクセス データベース 」と入力し、[ 検索 ] をクリックしてコンテンツを表示します。

リファレンス

.ldb ファイルの詳細については、次の記事を参照してください。

Access でファイル (.laccdb と .ldb) をロックする方法の概要