次の方法で共有


一部の Office アプリケーションが応答しない

現象

Office アプリケーションは、一般的な使用シナリオで応答を停止します。

原因

Microsoft Office 2013 以降、Office スイートのアプリケーションでは、オプションが使用可能な場合にハードウェア アクセラレーションを利用します。 これを行うために、Office はコンピューターにインストールされているグラフィックス アダプターを使用します。 これにより、Office アプリケーションはグラフィックス ドライバー コードを読み込んで使用します。 Intel グラフィックス アダプターを使用するシステムの場合、一部のバージョンの Intel グラフィックス ドライバーには、Office アプリケーションの応答を停止させるヒープ破損のバグがあります。

次の Intel グラフィックス ドライバーバージョンがこの問題を引き起こします。

バージョン
26.20.100.6951
26.20.100.6952
26.20.100.6998
26.20.100.6999
26.20.100.7000
26.20.100.7063

解決方法

お使いのコンピューターに影響を受ける Intel グラフィックス ドライバーの 1 つがあるかどうかを確認します。 これを行うには、次の手順を実行します。

  1. コントロール パネルで、[ハードウェアとサウンド>デバイス マネージャー] を選択します
  2. [ディスプレイ アダプター] 項目を展開します。 Intel グラフィックス アダプターがある場合は、ドライバーが一覧に表示されます。 Intel アダプターが表示された場合は、アダプターを右クリックし、[ プロパティ] を選択します。
  3. [ ドライバー ] タブで、[ ドライバーのバージョン ] フィールドの情報を確認します。

影響を受けるグラフィックス ドライバーのいずれかのバージョンがある場合は、次のいずれかのオプションを使用して問題を解決します。

オプション 1: Intel グラフィックス ドライバーを更新する

修正プログラムを含む Intel グラフィックス ドライバーは、バージョン 26.20.100.7262 です。 最適な解決策は、グラフィックス ドライバーをこのバージョン (またはそれ以降) に更新することです。 これを行うには、アダプターのプロパティ ダイアログ ボックスで [ ドライバー ] タブを開き、[ ドライバーの更新 ] ボタンを選択して、更新されたグラフィックス ドライバーを検索します。

注:

更新されたグラフィックス ドライバーが見つからない場合は、OEM Web サイトまたは Intel Web サイトからドライバーの更新プログラムを検索します。

オプション 2: Office のバージョンを更新する

Office には、特定の Office バージョンの修正プログラムが付属しています。 この修正プログラムは、影響を受ける Intel グラフィックス ドライバーがコンピューターにインストールされているかどうかを検出します。 その場合、Office はハードウェア アクセラレーションの使用を回避します。 代わりに、Windows Advanced Rasterization Platform (WARP) と呼ばれるソフトウェア ラスタライザーを使用します。

この修正プログラムを含む Office のバージョンは次のとおりです。

リリース バージョン
1911 年 (2019 年 11 月) 16.0.12325.20120
1910 年 (2019 年 10 月) 16.0.12228.20364
1907 年 (2019 年 7 月) 16.0.11929.20516
1901 年 (2019 年 1 月) 16.0.11328.20492
Office Insider 16.0.12406.20000

問題を解決するには、Office のインストールを更新します。

注:

Office バージョンの修正プログラムは、Nvidia Optimus グラフィックス アダプターを使用しているユーザーには機能しません。 このシナリオを回避する方法の詳細については、「オプション 4: Nvidia Optimus」セクションを参照してください。

オプション 3: Office でハードウェア アクセラレーションを手動で無効にする

Intel グラフィックス ドライバーをアップグレードできない場合や、修正プログラムが適用されたバージョンに Office を更新できない場合は、[ オプション] ダイアログ ボックスでハードウェア アクセラレータを無効にすることができます。 これを行うには、次の手順を実行します。

  1. 任意の Office アプリケーションで、[ファイルオプション] を選択します>。
  2. [詳細] ウィンドウで、[ハードウェア グラフィックス アクセラレータのチェックを無効にする] ボックスを選択します。
  3. [OK] を選択します。

ヒント

このオプションを選択した場合は、Intel グラフィックス ドライバーをバージョン 26.20.100.7262 (またはそれ以降) に更新するときに、[ハードウェア グラフィックス アクセラレーションのチェックを無効にする] ボックスをオフにすることをお勧めします。 これは、Office が可能な限り最高のパフォーマンスを使用して実行できるように行う必要があります。

オプション 4: Nvidia オプティマス

このセクションは、次のいずれかのグラフィックス アダプターがインストールされている Office ユーザーを対象とします。

  • 問題の原因となるグラフィックス ドライバーのバージョンを持つ Intel グラフィックス アダプター
  • Nvidia Optimus グラフィックス アダプター

これらのユーザーの場合、修正プログラムがあるバージョンに Office を更新することはできません。 これは、Nvidia Optimus グラフィックス アダプターが、障害のある Intel グラフィックス アダプターを間接的に読み込んで使用できるためです。 これらのユーザーは、「オプション 3: Office でハードウェア アクセラレーションを手動で無効にする」セクションの手順に従って問題を回避する必要があります。

一部のコンピューターには、Nvidia Optimus ドライバーの動作方法を指示するサードパーティ製ソフトウェアがあります。 これらのコンピューターで Intel グラフィックス アダプターを使用しないように構成できる場合があります。 これを行う方法については、サード パーティベンダーにお問い合わせください。

サードパーティの情報に関する免責事項

この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。 明示的か黙示的かにかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。