Microsoft 365 への接続を試みるときに Outlook が連続的にパスワードの入力を要求する
現象
Outlook プロファイルの作成または Microsoft 365 メールボックスへの接続を試みるときに、クライアントでは "接続中..." というメッセージが表示されるにもかかわらず、連続的に資格情報の入力を要求されます。 資格情報を要求するプロンプトをキャンセルすると、次のエラー メッセージが表示されます。
Microsoft Exchange への接続が利用できません。 この処理を完了するには、Outlook をオンラインで使用するか、Microsoft Exchange に接続する必要があります。
原因
この問題は、[Microsoft Exchange] ダイアログ ボックスの [セキュリティ] タブの [ログオン ネットワーク セキュリティ] 設定が [匿名認証] 以外の値に設定されている場合に発生する可能性があります。
解決方法
注:
Microsoft Outlook 2016 および最近のビルドの Outlook 2013 は、この問題の影響を受けません。 これらのバージョンは、「現象」セクションに記載されている問題を防止するように更新されています。 これらのバージョンでは [ログオン ネットワーク セキュリティ] 設定が無効になっているか、Microsoft Exchange 電子メール アカウント設定が削除されています。
新しいバージョンの Outlook の場合
自己診断ツールの実行
Exchange Online メールボックスに接続しようとすると、「現象」に記載されているエラーが発生している Microsoft 365 のお客様である可能性があります。 また、Outlook 2013 または Outlook 2016 の新しいバージョンを既に実行している可能性があります。 両方の条件に該当する場合は、診断を実行し、エラーの原因となる可能性のある問題を判別できます。 診断は自動チェックを行い、検出された問題の修正に使用できる解決策を提供します。 [診断: Outlook で何度もパスワードの入力を要求されます] を選択して診断を開始します。
Exchange On-Premises のメールボックスに接続する場合は、以下の資料を参照して、トラブルシューティングに関する追加の情報を確認してください。
さらに、一般的な原因については、次のフォーラムのスレッドを参照してください。
影響を受けるバージョンの Outlook の場合
古いバージョンの Outlook を使用している場合に、この問題を修正するには、[ログオン ネットワーク セキュリティ] 設定を [匿名認証] に変更します。 これを行うには、次の手順を実行します。
Outlook を終了します。
コントロール パネルを開き、以下のいずれかを実行します。
- Windows 10、Windows 8.1、または Windows 7 の場合は、[スタート] ボタンをクリックし、[検索] ボックスに「コントロール パネル」と入力して、Enter キーを押します。
- Windows 8 の場合は、右端から中央にスワイプしてチャームを表示し、[検索] をタップまたはクリックして、[検索] ボックスに「コントロール パネル」と入力します。 または、[スタート] 画面で「コントロール パネル」と入力し、検索結果の [コントロール パネル] をタップまたはクリックします。
コントロール パネルで [メール] をダブルクリックします。
[プロファイルの表示] をクリックし、目的の Outlook プロファイルを選択して、[プロパティ] をクリックします。
[電子メール アカウント] をクリックします。
目的の電子メール アカウントをクリックし、[変更] をクリックします。
[アカウントの変更] ダイアログ ボックスで [詳細設定] をクリックします。
[Microsoft Exchange] ダイアログ ボックスで [セキュリティ] タブをクリックします。
[ログオン ネットワーク セキュリティ] の一覧で [匿名認証] を選択し、[OK] をクリックします。
[次へ] をクリックし、[完了] をクリックしてから、[アカウント設定] ダイアログボックスの [閉じる] をクリックします。
[メール設定] ダイアログ ボックスの [閉じる] をクリックしてから、[OK] をクリックして [メールの制御] パネルを閉じます。
詳細
Outlook プロファイルで匿名認証のレジストリ設定を見つけて確認するには、次の手順に従います。
重要
"Profiles" レジストリ パスを使用した Outlook プロファイルの変更はサポートされておらず、これを行うと、Outlook プロファイルがサポートされていない状態になる可能性があります。 このセクションの手順の実行には注意が必要です。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 アクセスする前に、問題の発生に備えて復元用のレジストリのバックアップを作成してください。
レジストリ エディターを開きます。
- Windows 10、Windows 8.1、または Windows 8 の場合は、Windows ロゴ キーを押しながら R キーを押して [ファイル名を指定して実行] ダイアログ ボックスを開き、「regedit.exe」と入力して [OK] をクリックします。
- Windows 7 の場合は、[スタート] ボタンをクリックし、[検索の開始] ボックスに「regedit」と入力して、Enter キーを押します。 管理者のパスワードを要求するダイアログ ボックスが表示された場合はパスワードを入力して [OK] をクリックし、確認を要求するダイアログ ボックスが表示された場合は [許可] をクリックします。
使用している Outlook のバージョンに応じて、以下のレジストリ パスを見つけます。
Outlook 2013 の場合
HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Outlook\Profiles
Outlook 2010 および 2007 の場合
HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles
このサブキーの下で、目的の Outlook プロファイルの名前を見つけて展開します。
このプロファイルの下で、9375CFF0413111d3B88A00104B2A6676 キーを見つけて展開します。
9375CFF0413111d3B88A00104B2A6676 キーの下で、プロファイルの各アカウントのサブキーを確認します。 最初のサブフォルダ― (00000001)を選択し、Account Name バイナリ値をダブルクリックして、そのデータを調べます。 目的の SMTP アドレスが含まれている Account Name 値が見つかるまで、このプロセスを繰り返します。 たとえば、Account Name 値が \00000003 サブキーの下にある guidopica@contoso.com を指しているとします。
\0000000x サブキーの下で、Service UID バイナリ値を見つけます。 それは GUID を表しています (c3 d1 9a 7b 80 1b c4 4a 96 0a e5 b6 3b f9 7c 7e など)。
手順 6 で特定した GUID 値と一致するサブフォルダーをプロファイル内で見つけます (\c3d19a7b801bc44a960ae5b63bf97c7e など)。
手順 7 で見つけたサブフォルダーの下で、01023d0d バイナリ値を調べます。 それは GUID を表しています (5f cf d5 f1 ba 5c 6f 45 b3 57 cc 5e 0d 16 94 58 など)。
手順 8 で特定した GUID 値と一致するサブフォルダーをプロファイル内で見つけます (\5fcfd5f1ba5c6f45b357cc5e0d169458 など)。
手順 9 で見つけたサブキーの下で、00036619 バイナリ値を調べます。 この値によって、Outlook が匿名認証を使用しているかどうかを確認できます。
バイナリ: 00036619
データ: 01 f0 00 80 == 匿名認証
他の値であれば、匿名認証以外の認証方法が使用されています。