元の KB 番号: 2966790
現象
メールボックスの代理人を持たないユーザーは、Microsoft Outlook で次の問題のいずれかまたは両方を見つけます。
会議出席依頼がユーザーに送信されると、会議はユーザーの予定表に仮の状態で正しく表示されますが、Outlook は要求を受信トレイにルーティングしません。 たとえば、要求は削除済みアイテム フォルダーに表示されます。
出席者がユーザーが作成した会議出席依頼に応答すると、ユーザーの予定表の会議追跡情報に応答が正しく反映されますが、Outlook は応答を受信トレイにルーティングしません。 たとえば、削除済みアイテム フォルダーに応答が表示されます。
原因
この問題は、次の理由で発生する可能性があります。
原因 1
IPM の受信メッセージを保持する MAPI 受信フォルダー。計画。MEETING メッセージ クラスは受信トレイ フォルダーに設定されていません。 代わりに、[削除済みアイテム] フォルダーに会議アイテムが表示されます。
Exchange Online PowerShell を使用して、この原因をテストできます。 次のいずれかの方法を使用します。
Note
どちらの方法も有用な情報を提供します。 たとえば、メソッド A は、削除済みアイテム フォルダーに誤って送信された会議アイテムの数を示し、メソッド B は特定のアイテムが配信されたフォルダーを確認します。
方法 A
次の Get-MailboxFolderStatistics PowerShell コマンドレットを実行します。
Get-MailboxFolderStatistics -Identity <user ID> -FolderScope NonIpmRoot -IncludeOldestAndNewestItems | ? Name -eq "Schedule" | FL Name,FolderType,NewestItemReceivedDate,ItemsInFolder
次のスクリーンショットは、コマンドレットの出力例を示しています。
このため、 ItemsInFolder count 値は 0 以外で、 NewestItemReceivedDate タイムスタンプ値は、最新の誤って削除された会議アイテムの日時と一致します。
方法 B
次の Get-MessageTrace および Get-MessageTraceDetail PowerShell コマンドレットを実行します。
Get-MessageTrace -StartDate <search start date> -EndDate <search end date> | ? Subject -match <item subject> | Get-MessageTraceDetail
次のスクリーンショットは、コマンド出力の例を示しています。
この原因の場合、deliver イベントの Detail パラメーターの値は次のとおりです: The message was successfully delivered to the folder: DefaultFolderType:LegacySchedule
。
原因 2
IPM を持つメッセージの場合。Rule.Version2.Message メッセージ クラスでは、PR_RULE_MSG_PROVIDER プロパティの値が正しくSchedule+ EMS Interface
に設定されていません。
解決方法
Exchange Online PowerShell で原因 1 をテストし、原因 1 が適用できないことが判明した場合は、 原因 2 の問題から始めます。 それ以外の場合は、 原因 1 のソリューションから開始。
原因 1 の解決策
Note
次の手順を使用するには、ユーザーであるか、ユーザーのメールボックスへのフル アクセス許可を持っている必要があります。 Outlook デスクトップ クライアントがインストールされている Microsoft Windows ベースのコンピューターと、メールボックスの Outlook プロファイルで手順を実行します。
Outlook で File>Office account>About Outlook を選択して、デスクトップ クライアントが 32 ビット版か 64 ビット 版かを判断。
Outlook のインストールに合わせて、 MFCMAPI の最新バージョン (32 ビットまたは 64 ビット) をダウンロードして抽出します。
重要
MFCMAPI エディターはサポートされていますが、それを使用してメールボックスの設定を編集する場合は注意してください。 MFCMAPI エディターを誤って使用すると、メールボックスが永続的に破損する可能性があります。
Outlook を閉じ、MFCMapi.exeを実行します。 MFCMAPI のスタートアップ画面が表示されたら、それを閉じます。
Tools>Options を選択して、Options ウィンドウを開きます。
MFCMAPI をオンライン モードに設定するには、次のオプションの両方を選択し、 OK を選択します。
- OpenMsgStore を呼び出すときに MDB_ONLINE フラグを使用する
- OpenEntry を呼び出すときに MAPI_NO_CACHE フラグを使用する
重要
手順 5 を完了していることを確認します。
Session>Logon を選択して、Choose Profile ウィンドウを開きます。
影響を受けるユーザーの Outlook プロファイルを選択し、 OK を選択します。
Display Name列で該当するメールボックスをダブルクリックして開きます。
表示された新しいウィンドウで、 MDB>Display>Receive フォルダー テーブルを選択します。
Receive Folder Table ウィンドウで、Message Class 列に IPM があることを確認します。計画。会議エントリ。 次の例のスクリーンショットは、そのエントリを示しています。
Receive フォルダー テーブルウィンドウにIPM が含まれていない場合。計画。MEETING エントリで、手順 5 を完了したことを再確認します (MFCMAPI をオンライン モードに設定します)。 手順 5. を完了した場合は、残りの手順をスキップし、 原因 2 の解決策を試してください まだ実行していない場合)。
Root コンテナーを展開します。
Scheduleを右クリックし、[ Advanced>Set receive folder を選択して、SetReceiveFolder ウィンドウを開きます。
「 IPM」と入力します。計画。MEETING Class フィールドで 削除の関連付けを選択し、 OKを選択します。
Receive フォルダー テーブル ウィンドウを更新し、IPM であることを確認します。計画。MEETING エントリが存在しなくなりました。
ユーザーの問題が解決されているかどうかを確認します。 問題が解決しない場合は、 原因 2 の解決 まだ実行していない場合は試してください。
原因 2 の解決策
MFCMAPI を初期化するには、 原因 1 の解決 の手順 1 から 8 を完了します。
Root コンテナーを展開し、 Top of Information Store を展開します。
[受信トレイ] を右クリックし、[関連するコンテンツ テーブルを開く] を選択します。
上部のウィンドウで、 Message Class 列ヘッダーを選択して列を並べ替えます。
IPM.Rule.Version2.Message
の値を持つ Message Class 列の各メッセージについて、メッセージを選択します。
下のウィンドウで、 PR_RULE_MSG_PROVIDER プロパティの値を確認します。
PR_RULE_MSG_PROVIDERプロパティ値が
Schedule+ EMS Interface
されている場合は、上部のウィンドウでメッセージを削除します。
次のスクリーンショットの例では、メッセージ クラスが
IPM.Rule.Version2.Message
で、 PR_RULE_MSG_PROVIDER プロパティ値がSchedule+ EMS Interface
のメッセージを削除する方法を示しています。ユーザーの問題が解決されているかどうかを確認します。 問題が解決しない場合は、 原因 1 の解決 まだ実行していない場合は試してください。