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アクション可能なメッセージが正しく表示されない

現象

操作可能なメッセージ が Microsoft Outlook で正しく表示されません。

次のスクリーンショットは、正しくレンダリングされたアクション可能なメッセージを示しています。

正しくレンダリングされるアクション可能なメッセージのスクリーンショット。

次のスクリーンショットは、誤ってレンダリングされた場合に同じアクション可能メッセージを示しています。

正しくレンダリングされないアクション可能なメッセージのスクリーンショット。

原因

アクション可能なメッセージを正しくレンダリングするために、Outlook は次の GET 要求を使用して、自動検出 V2 サービスから Actions プロトコル エンドポイント URL を取得します https://outlook.office365.com/autodiscover/autodiscover.json/v1.0/<user email address>?protocol=actions

要求が成功した場合、自動検出 V2 サービスは HTTP 状態コード 200 を返し、要求された URL を応答本文に提供します。 たとえば、応答本文は です { "Protocol": "Actions", "Url": https://outlook.office365.com/actionsb2netcore }

ただし、Outlook がインストールされているユーザーのコンピューターで自動検出 V2 サービスが無効になっている場合、GET 要求は失敗し、Outlook はアクション プロトコル エンドポイントに接続できません。

注:

サブキーの下Computer\HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Outlook\AutoDiscoverにレジストリ エントリが存在し、エントリの DisableAutodiscoverV2Service DWORD 値DisableAutodiscoverV2Serviceが である場合、自動検出 V2 サービスは1無効になります。

解決方法

この問題を解決するには、次の手順に従って、Outlook がインストールされているユーザーのコンピューターで自動検出 V2 サービスを有効にします。

重要

このセクション、方法、またはタスクには、レジストリの編集方法が記載されています。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 レジストリを変更する際には十分に注意してください。 保護のために、レジストリを変更する前にレジストリをバックアップして、問題が発生した場合にレジストリを復元できるようにします。 レジストリをバックアップおよび復元する方法の詳細については、「Windows でレジストリをバックアップおよび復元する方法」を参照してください。

  1. ユーザーのコンピューターがドメインに参加していて、グループ ポリシーを使用してorganizationが自動検出を制御する場合は、[自動検出グループのDisable the Autodiscover V2 service無効化] ポリシーでオプションが有効になっていないことを確認します。

  2. Outlook がインストールされているユーザーのコンピューターで regedit を実行します。

  3. レジストリ サブキーに Computer\HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Outlook\AutoDiscover 移動します。

  4. レジストリ エントリの DWORD 値を にDisableAutodiscoverV2Service0設定するか、レジストリ エントリを削除します。

  5. 次の自動検出キャッシュ ファイルを削除します。

    1. %LocalAppData%\Microsoft\Outlook\<any 部分ファイル名> - Autodiscover.xml

    2. %LocalAppData%\Microsoft\Outlook\16\<any ファイル名>.xml

    3. %LocalAppData%\Microsoft\Outlook\16\<any ファイル名>.json

  6. Outlook を再起動します。