元の KB 番号: 3114786
現象
HTML ベースのページを使用して Microsoft Outlook で電子メール メッセージを自動的に作成する場合、メッセージの [件名] 行と本文が作成されない場合があります。
原因
この問題は、コンピューターに次のレジストリ キーがない場合に発生します。
HKEY_CURRENT_USER\Software\Clients\Mail
最新バージョンのインターネット エクスプローラーまたは Microsoft Edge がインストールされている場合は、システムにこのレジストリ キーが必要です。
解決方法
警告
レジストリ エディターの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。 マイクロソフトは、レジストリ エディターの誤用により発生した問題に関しては、一切責任を負わないものとします。 レジストリ エディターは、自己の責任においてご使用ください。
この問題を解決するには、レジストリ エディターを使用してレジストリ キーを手動で追加しますHKEY_CURRENT_USER\Software\Clients\Mail
。 これを行うには、次の手順を実行します。
Outlook とインターネット エクスプローラーを終了します。
レジストリ エディターを起動します。 それには、使用している Windows のバージョンに応じて、以下のいずれかの方法を使用します。
Windows 8とWindows 10: Windows キーを押しながら R キーを押して、[実行] ダイアログ ボックスを開きます。 「regedit.exe」と入力し、[OK] をクリック します。
Windows 7 と Windows Vista: [ スタート] をクリックし、[検索の 開始 ] ボックスに「regedit」と入力し、Enter キーを押します。 管理者のパスワードを要求するダイアログ ボックスが表示された場合はパスワードを入力して [OK] をクリックし、確認を要求するダイアログ ボックスが表示された場合は [許可] をクリックします。
Windows XP: [ スタート] をクリックし、[ 実行] をクリックし、「regedit」と入力して、[OK] をクリック します。
次のレジストリ キーを見つけます。
HKEY_CURRENT_USER\Software\Clients
- [ クライアント ] サブキーを選択します。
- [ 編集 ] メニューの [ 新規 ] ->[キー] をクリックします。
- 「 メール」と入力し、[OK] をクリック します。
- レジストリ エディターを終了します。
Outlook とインターネット エクスプローラーを再起動します。
詳細
次の HTML サンプルでは、電子メール メッセージが自動的に作成されます。
<html>
<head>
<title>Test</title>
</head>
<body>
<FORM name=USER REGISTER action="mailto:<recipient e-mail address>" method=post target=_self encType=text/plain>
<TABLE>
<TBODY>
<TD><FONT>Text</FONT></TD>
<TD><INPUT name=Text></TD>
<TD><INPUT type=submit value=Submit name=User Register></TD>
</TBODY>
</TABLE>
</FORM>
</body>
</html>
Microsoft は、例示のみを目的としてプログラミング例を提供しており、明示または黙示にかかわらず、いかなる責任も負わないものとします。 これには、市販性または特定の目的との適合性についての黙示の保証も含まれますが、これに限定はされません。 この記事は、説明されているプログラミング言語、手順を作成およびデバッグするために使用されているツールに読者が精通していることを前提にしています。 マイクロソフト サポート窓口では、特定のプロシージャの機能説明に関するご質問に対して支援いたしますが、本例を特定の目的を満たすために機能を追加したり、プロシージャを構築することは行いません。