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3DES 証明書を使用してメッセージの暗号化を解除するときに、デジタル ID 名が見つからないエラー

元の KB 番号: 4459215

現象

3DES 暗号化機能のみを持つ証明書を使用して Microsoft Outlook で暗号化された電子メール メッセージを開くと、次のエラー メッセージが表示されます。

基になるセキュリティ システムでデジタル ID 名が見つかりません

原因

Outlook ビルド 16.0.8518.1000 以降、Microsoft は既定のフォールバック アルゴリズムを 3DES から AES256 にアップグレードしました。 「現象」セクションに記載されている問題では、暗号化された電子メール メッセージは、この Outlook ビルドまたは後のビルドを使用しているユーザーによって送信されます。

解決方法

重要

このセクションの手順の実行には注意が必要です。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 変更する前に、問題の発生に備えて復元用にレジストリのバックアップを作成してください。

この問題を解決するには、AES256 暗号化機能以上の証明書を使用してメッセージを暗号化することをお勧めします。

3DES 暗号化アルゴリズムを使用する必要がある場合は、送信者のコンピューターに次のレジストリ値を追加できます。

HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Security

DWORD = UseAlternateDefaultEncryptionAlg
値 = 1

String = DefaultEncryptionAlgOID
Value = 1.2.840.113549.3.7

注:

指定された文字列値は、3DES 暗号化アルゴリズムの OID を示しています。

詳細

送信者が電子メール メッセージの暗号化に使用した証明書には、属性が SMIMECapabilities 含まれていません。 これは、Outlook が受信者の機能を事前に判断できなかったことを意味します。 そのため、一般的に受け入れられるセキュリティで保護されたアルゴリズムを選択しました。

詳細については、インターネット エンジニアリング タスク フォース (IETF) RFC 5751 の「2.5.2 SMIME 機能属性」 セクションを参照してください。